当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]lumaqq无法使用
帖子发表于 : 2008-07-23 17:47 

注册: 2008-07-15 14:45
帖子: 38
送出感谢: 0 次
接收感谢: 0 次
这几天pidgin登录QQ老是掉线,想装个lumaqq看下,结果下载了个lumaqq安装完后打不开,主菜单里也有快捷图标,放到桌面上来也是打不开,通过终端运行提示如下:(大串英文)
victory@ares:~$ cd /opt/LumaQQ
victory@ares:/opt/LumaQQ$ ./lumaqq
victory@ares:/opt/LumaQQ$ Exception in thread "main" java.lang.NoClassDefFoundError: org.eclipse.emf.ecore.plugin.EcorePlugin
at java.lang.Class.initializeClass(libgcj.so.81)
at org.eclipse.emf.ecore.resource.impl.URIConverterImpl.<clinit>(URIConverterImpl.java:207)
at java.lang.Class.initializeClass(libgcj.so.81)
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.getURIConverter(ResourceSetImpl.java:413)
at org.eclipse.emf.ecore.resource.impl.ResourceImpl.getURIConverter(ResourceImpl.java:838)
at org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:865)
at edu.tsinghua.lumaqq.eutil.GlobalUtil.load(GlobalUtil.java:126)
at edu.tsinghua.lumaqq.LumaQQ.readGlobalSettingFile(LumaQQ.java:228)
at edu.tsinghua.lumaqq.LumaQQ.main(LumaQQ.java:119)
Caused by: java.lang.ClassNotFoundException: org.eclipse.core.runtime.jobs.ISchedulingRule not found in gnu.gcj.runtime.SystemClassLoader{urls=[file:./lib/xerces.jar,file:./lib/swt.jar,file:./lib/poifs.jar,file:./lib/org.eclipse.ui.workbench_3.2.0.I20051214-1200.jar,file:./lib/org.eclipse.osgi_3.2.0.v20051212a.jar,file:./lib/org.eclipse.jface_3.2.0.I20051214-0010.jar,file:./lib/org.eclipse.equinox.common_1.0.0.v20051205.jar,file:./lib/org.eclipse.emf.ecore.xmi_2.2.0.jar,file:./lib/org.eclipse.emf.ecore_2.2.0.jar,file:./lib/org.eclipse.emf.common_2.2.0.jar,file:./lib/org.eclipse.core.runtime_3.2.0.v20051208.jar,file:./lib/org.eclipse.core.resources_3.2.0.v20051208.jar,file:./lib/org.eclipse.core.commands_3.2.0.I20051212-2000.jar,file:./lib/lumaqq_xsd.jar,file:./lib/lumaqq_template.jar,file:./lib/lumaqq.jar,file:./lib/log4j-1.2.8.jar,file:./lib/jql_protocol.jar,file:./lib/jql_net.jar,file:./lib/je.jar,file:./lib/jdom.jar,file:./lib/commons-logging.jar,file:./lib/commons-codec.jar,file:./], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
at java.net.URLClassLoader.findClass(libgcj.so.81)
at gnu.gcj.runtime.SystemClassLoader.findClass(libgcj.so.81)
at java.lang.ClassLoader.loadClass(libgcj.so.81)
at java.lang.ClassLoader.loadClass(libgcj.so.81)
at java.lang.VMClassLoader.defineClass(libgcj.so.81)
at java.lang.ClassLoader.defineClass(libgcj.so.81)
at java.security.SecureClassLoader.defineClass(libgcj.so.81)
at java.net.URLClassLoader.findClass(libgcj.so.81)
at gnu.gcj.runtime.SystemClassLoader.findClass(libgcj.so.81)
at java.lang.ClassLoader.loadClass(libgcj.so.81)
at java.lang.ClassLoader.loadClass(libgcj.so.81)
at java.lang.VMClassLoader.defineClass(libgcj.so.81)
at java.lang.ClassLoader.defineClass(libgcj.so.81)
at java.security.SecureClassLoader.defineClass(libgcj.so.81)
at java.net.URLClassLoader.findClass(libgcj.so.81)
at gnu.gcj.runtime.SystemClassLoader.findClass(libgcj.so.81)
at java.lang.ClassLoader.loadClass(libgcj.so.81)
at java.lang.ClassLoader.loadClass(libgcj.so.81)
at java.lang.VMClassLoader.defineClass(libgcj.so.81)
at java.lang.ClassLoader.defineClass(libgcj.so.81)
at java.security.SecureClassLoader.defineClass(libgcj.so.81)
at java.net.URLClassLoader.findClass(libgcj.so.81)
at gnu.gcj.runtime.SystemClassLoader.findClass(libgcj.so.81)
at java.lang.ClassLoader.loadClass(libgcj.so.81)
at java.lang.ClassLoader.loadClass(libgcj.so.81)
at java.lang.Class.initializeClass(libgcj.so.81)
...8 more

是不是我的ubuntu java版本太低还是怎么回事,请指教!!!!!!!!!!!!!!
java版本为1.5.0


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译