当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 无法更新
帖子发表于 : 2008-07-23 19:18 

注册: 2007-08-03 12:17
帖子: 48
送出感谢: 0 次
接收感谢: 0 次
在更新管理器中,安装更新时,会出现以下错误:E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

是怎么回事,还有怎么解决?
在终端输入dpkg --configure -a出现leiyunlong@leiyunlong-desktop:~$ dpkg -- configure -a
dpkg: 需要一个指示操作的选项

输入 dpkg --help 可获得安装和卸载软件包的有关帮助 [*];
使用“dselect”或是“aptitude”就能在友好的界面下管理软件包;
输入 dpkg -Dhelp 可看到 dpkg 除错标志的值的列表;
输入 dpkg --force-help 可获得所有强制操作选项的列表;
输入 dpkg-deb --help 可获得有关操作 *.deb 文件的帮助;
输入 dpkg --license 可阅读版权许可证和无担保的说明 (GNU GPL) [*]。

带有 [*] 的选项将会输出较大篇幅的文字 - 可使用管道将其输出连接到“less”或“more”!


最后由 leiyunlong 编辑于 2008-07-23 19:35,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-07-23 19:20 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
lz你的毛病:
1.不搜索
2.不看出错信息

代码:
sudo dpkg --configure -a


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-07-23 19:21 
头像

注册: 2007-07-10 12:16
帖子: 525
送出感谢: 0 次
接收感谢: 0 次
很明显阿
引用:
run 'dpkg --configure -a' to correct the problem.

代码:
sudo dpkg --configure -a


_________________
像一条秋天的道路:还未来得及扫干净,它又为干枯的树叶所覆盖。

The Kafka Project http://www.kafka.org


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Yahoo [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译