当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 15 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 登陆界面的分辨率过大,怎么修改过来?
帖子发表于 : 2008-07-25 18:16 

注册: 2008-04-04 12:05
帖子: 44
送出感谢: 0 次
接收感谢: 0 次
登陆界面的分辨率过大,怎么修改过来?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-07-25 18:25 
头像

注册: 2007-06-13 15:57
帖子: 12567
地址: 在他乡
送出感谢: 50
接收感谢: 87
代码:
sudo gedit /etc/X11/xorg.conf

找到以下几行
代码:
Section “Screen”
Identifier “Default Screen”
Monitor “Configured Monitor”
Device “Configured Video Device”
Depth 24
Virtual 1024 768
Endsection

Virtual后就是你的分辨率,改成你合适的。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-07-25 21:42 

注册: 2008-04-04 12:05
帖子: 44
送出感谢: 0 次
接收感谢: 0 次
谢谢你的回复!我按这个方法
代码:
sudo gedit /etc/X11/xorg.conf


显示出来的是
代码:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "cn"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
EndSection

Section "Device"
   Identifier   "Configured Video Device"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
EndSection


而没有找到
代码:
Section “Screen”
Identifier “Default Screen”
Monitor “Configured Monitor”
Device “Configured Video Device”
Depth 24
Virtual 1024 768
Endsection


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-07-25 21:50 
头像

注册: 2006-04-05 18:12
帖子: 474
送出感谢: 0 次
接收感谢: 0 次
没有的话就给加上去这一行
代码:
Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
   Defaultdepth   24
   SubSection "Display"
      Depth   24
      Virtual   1280   800
      Modes   "1280x800@60"   "1280x720@60"   "1280x768@60"   "800x600@60"   "800x600@56"
   EndSubSection
EndSection


然后1024和768的地方改成你需要的分辨率就行了


_________________
Fedora Notes


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-07-25 21:57 
头像

注册: 2006-04-05 18:12
帖子: 474
送出感谢: 0 次
接收感谢: 0 次
楼主还可以看这里
http://forum.ubuntu.org.cn/viewtopic.ph ... b22c3c74f2


_________________
Fedora Notes


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-07-26 9:09 

注册: 2008-04-04 12:05
帖子: 44
送出感谢: 0 次
接收感谢: 0 次
好像还是不行,纳闷。

虽然登录界面分辨率没多大关系,但问题解决不了总觉得不舒服。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-07-26 9:49 
头像

注册: 2007-06-13 15:57
帖子: 12567
地址: 在他乡
送出感谢: 50
接收感谢: 87
没有的原因很简单,你没有选择你使用的显示器,告诉我你使用的显示器,以最佳分辨为1024*768为例。
代码:
gksu displayconfig-gtk
选择显示器的类型,一般CRT的,选择CRT1024*768。LCD选择LCD1024*768
显卡也选择一下,(如果你使用受限驱动,在“受限驱动”里安装完成)。确实,重启X,再按上面我说的修改,或者根本不用修改了。祝你好运


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-07-26 14:53 

注册: 2008-04-04 12:05
帖子: 44
送出感谢: 0 次
接收感谢: 0 次
daf3707 写道:
没有的原因很简单,你没有选择你使用的显示器,告诉我你使用的显示器,以最佳分辨为1024*768为例。
代码:
gksu displayconfig-gtk
选择显示器的类型,一般CRT的,选择CRT1024*768。LCD选择LCD1024*768
显卡也选择一下,(如果你使用受限驱动,在“受限驱动”里安装完成)。确实,重启X,再按上面我说的修改,或者根本不用修改了。祝你好运


谢谢,楼上几位好心人的回复。我的是 CRT 1024*768


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-07-26 19:38 

注册: 2008-04-04 12:05
帖子: 44
送出感谢: 0 次
接收感谢: 0 次
所有问题都已经解决,谢谢2位的帮忙!


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-07-26 19:44 

注册: 2008-01-09 22:41
帖子: 18311
送出感谢: 0 次
接收感谢: 6
gj315 写道:
谢谢你的回复!我按这个方法
代码:
sudo gedit /etc/X11/xorg.conf


显示出来的是
代码:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "cn"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
EndSection

Section "Device"
   Identifier   "Configured Video Device"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
EndSection


而没有找到
代码:
Section “Screen”
Identifier “Default Screen”
Monitor “Configured Monitor”
Device “Configured Video Device”
Depth 24
Virtual 1024 768
Endsection


这里:

代码:
Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
EndSection


改成

代码:
Section “Screen”
Identifier “Default Screen”
Monitor “Configured Monitor”
Device “Configured Video Device”
Depth 24
Virtual 1024 768
Endsection


还有一个就是分辨率不是过大,而是过小,显示内容过大吧![/code]


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-07-26 22:36 
头像

注册: 2007-05-06 2:46
帖子: 15634
送出感谢: 0 次
接收感谢: 2
gksu displayconfig-gtk

登陆界面分辨率问题总算解决了


:P


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-08-29 10:55 

注册: 2008-08-26 14:36
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
我也有这样的问题,按daf3707的方法解决了,谢谢daf3707


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-09-19 1:14 

注册: 2008-08-19 3:30
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
谢谢二楼先!不爽了好久,终于解决了 :)


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 登陆界面的分辨率过大,怎么修改过来?
帖子发表于 : 2010-08-01 10:01 

注册: 2010-07-21 18:08
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
Mark,好办法


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 登陆界面的分辨率过大,怎么修改过来?
帖子发表于 : 2010-09-25 17:16 

注册: 2010-08-03 13:44
帖子: 29
送出感谢: 0 次
接收感谢: 0 次
好东西,今晚来解决它!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 15 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译