说说小弟开硬件加速遇到的问题!

为当前最终发行版之前的所有版本提供支持
回复
maple0730
帖子: 51
注册时间: 2008-07-26 16:34
送出感谢: 0
接收感谢: 0

说说小弟开硬件加速遇到的问题!

#1

帖子 maple0730 » 2008-07-28 17:35

郁闷啊
开硬件加速屏幕的分辨率变的好低啊
只有620*350 还是最高的
请问下怎么调高分辨率啊·
我的显卡是 NVIDIA GF4 MX 400的
头像
syrano
帖子: 4313
注册时间: 2007-10-06 18:40
送出感谢: 0
接收感谢: 5 次

#2

帖子 syrano » 2008-07-28 17:57

sudo gedit /etc/X11/xorg.conf
Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 90.0
VertRefresh 50.0 - 120.0
Option "DPMS"
EndSection
修改这一节的这两项
HorizSync 30.0 - 90.0
VertRefresh 50.0 - 120.0
E=m c^2
maple0730
帖子: 51
注册时间: 2008-07-26 16:34
送出感谢: 0
接收感谢: 0

#3

帖子 maple0730 » 2008-07-28 19:54

不行阿
还有其他的解决办法吗
delectate
帖子: 18311
注册时间: 2008-01-09 22:41
送出感谢: 0
接收感谢: 6 次

#4

帖子 delectate » 2008-07-28 20:06

maple0730 写了:不行阿
还有其他的解决办法吗
安装正确的驱动
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#5

帖子 leeaman » 2008-07-28 20:09

贴你的 /etc/X11/xorg.conf 出来看看啊,试试用sudo displayconfig-gtk配置正确的显示器看看
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
maple0730
帖子: 51
注册时间: 2008-07-26 16:34
送出感谢: 0
接收感谢: 0

#6

帖子 maple0730 » 2008-07-28 21:14

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 90.0
VertRefresh 50.0 - 120.0
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
EndSection


这就是咯
我下咯官方驱动
但是我不会装
头像
thefour
帖子: 429
注册时间: 2008-03-05 12:31
来自: 示爱须唱山歌
送出感谢: 0
接收感谢: 0

#7

帖子 thefour » 2008-07-28 22:00

在显示器后面的标签找它的型号
在 应用程序->其它->显示器和显卡 选择之
六十学裁缝,晚否......
maple0730
帖子: 51
注册时间: 2008-07-26 16:34
送出感谢: 0
接收感谢: 0

#8

帖子 maple0730 » 2008-07-28 22:29

还是不明白····
maple0730
帖子: 51
注册时间: 2008-07-26 16:34
送出感谢: 0
接收感谢: 0

#9

帖子 maple0730 » 2008-07-29 0:31

1. 防患于未然,先装libc, 运行 sudo apt-get install libc6-dev, 下载,安装,成功。
2. ctrl + alt + F2, 这时候你应该看到黑屏,呵呵,当然现在你的x server 并没有关闭,不信?ctrl + alt + F7 , 又回来了不是?
3. 回到1 里面的黑屏,这时候应该能看到要求login的指令,用root登录,输入密码,搞定
4. ok, 现在可以关闭 X server 了,运行 /etc/init.d/gdm stop. (如果你不用gnome,,自己google一下)。看到一则关闭OK的消息。这时候X server真正关闭了。不信?再试试 ctrl + alt +F7, 没反应了把,还是黑屏!(还真试阿?再用 ctrl + alt +F2 退回去把)
5. 运行安装程序 sh /home/yourname/xxx.run 呵呵,这时候应该看到界面了,选择一下什么ok之类的就好,然后到那个下载Kernel Interface,再到自己编译界面,应该比较顺利。
6. OK,编译好了,安装完了,安装程序会询问你是否自动更新配置,对于我这样的懒人之接ok就好了。

这所我照上面网上找的方法安装的
但是 在命令提示符下显示
unknown id NVIDIA-Linux-x86-96.43.07-pkg1.run
头像
thefour
帖子: 429
注册时间: 2008-03-05 12:31
来自: 示爱须唱山歌
送出感谢: 0
接收感谢: 0

#10

帖子 thefour » 2008-07-29 2:31

我看主要原因还是U没法自动识别你的显示器
2楼说的那两项分别是水平扫描频率、扫描频率
不同的显示器这两项的数值都有可能不同
(如我的是30-71 、 50-160)
弄清楚显示器的型号
在网上就能搜出这两项的正确数值
六十学裁缝,晚否......
头像
20sanguo
帖子: 777
注册时间: 2008-05-10 9:53
送出感谢: 0
接收感谢: 2 次

#11

帖子 20sanguo » 2008-07-29 7:43

如果内核不是很特殊,用新利得搜索选装对应内核的n卡驱动,一般最多装3次应该能成功,有3个不同的,一个一个试,你那种卡可能是用new的?
白水月
帖子: 86
注册时间: 2008-03-10 11:28
送出感谢: 0
接收感谢: 0

#12

帖子 白水月 » 2008-07-30 14:47

恩,我还是菜鸟,不知怎么开硬解。
先学习下......
maple0730
帖子: 51
注册时间: 2008-07-26 16:34
送出感谢: 0
接收感谢: 0

#13

帖子 maple0730 » 2008-07-31 7:53

郁闷
弄咯这么久还是米弄好
倒塌
哪位神啊
搭救我吧···
maple0730
帖子: 51
注册时间: 2008-07-26 16:34
送出感谢: 0
接收感谢: 0

#14

帖子 maple0730 » 2008-07-31 11:41

问题已经解决
谢谢大家的帮忙~!!
回复

回到 “老旧版本支持”