[已解决][问题]请问 这个软件包可用更新为什么会出错误呢?

为当前最终发行版之前的所有版本提供支持
回复
hlcaou
帖子: 17
注册时间: 2008-07-28 8:49
送出感谢: 0
接收感谢: 0

[已解决][问题]请问 这个软件包可用更新为什么会出错误呢?

#1

帖子 hlcaou » 2008-07-29 15:50

系统安装完成后 在更新管理器 的linux-image-2.6.24-19-generic 的更新无法安装

错误信息如下 E: /var/cache/apt/archives/linux-image-2.6.24-19-generic_2.6.24-19.36_i386.deb: 无法在安装新的版本前,为“./boot/vmlinuz-2.6.24-19-generic”做一个符号链接备份

哪位大侠知道是什么原因哪 在此先谢谢了。。。
上次由 hlcaou 在 2008-07-30 13:11,总共编辑 1 次。
头像
oneleaf
论坛管理员
帖子: 10208
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#2

帖子 oneleaf » 2008-07-29 16:01

这个是ubuntu的一个bug来着,你可以按照如下处理:

1. 编辑 /var/lib/dpkg/status 文件, 找个列表的 broken 包, 在那个包上面删除这个信息.
2. mv /var/lib/dpkg/info /var/lib/dpkg/info_old
3. mkdir /var/lib/dpkg/info
4. apt-get update, apt-get -f install
hlcaou
帖子: 17
注册时间: 2008-07-28 8:49
送出感谢: 0
接收感谢: 0

#3

帖子 hlcaou » 2008-07-30 5:02

oneleaf 写了:这个是ubuntu的一个bug来着,你可以按照如下处理:

1. 编辑 /var/lib/dpkg/status 文件, 找个列表的 broken 包, 在那个包上面删除这个信息.
2. mv /var/lib/dpkg/info /var/lib/dpkg/info_old
3. mkdir /var/lib/dpkg/info
4. apt-get update, apt-get -f install


具体如何操作呢 能详细说下么
头像
oneleaf
论坛管理员
帖子: 10208
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#4

帖子 oneleaf » 2008-07-30 12:07

上面就是步骤啊。
1 sudo nano /var/lib/dpkg/status
找到你的包,修改Status为:

Status: install ok installed

保存。
hlcaou
帖子: 17
注册时间: 2008-07-28 8:49
送出感谢: 0
接收感谢: 0

#5

帖子 hlcaou » 2008-07-30 13:10

oneleaf 写了:上面就是步骤啊。
1 sudo nano /var/lib/dpkg/status
找到你的包,修改Status为:

Status: install ok installed

保存。


问题解决了。谢谢
回复

回到 “老旧版本支持”