[教学]UBUNTU8.04下安装ATI显卡驱动8.7催化剂版

为当前最终发行版之前的所有版本提供支持
02015678
帖子: 110
注册时间: 2007-11-10 14:29
送出感谢: 1 次
接收感谢: 1 次
联系:

[教学]UBUNTU8.04下安装ATI显卡驱动8.7催化剂版

#1

帖子 02015678 » 2008-08-01 10:27

ATi X000系列、9000系列、AMD780G请使用ATi开源驱动,详见 常见硬件支持 置顶帖
安装后,如果检测出驱动是Mesa说明安装不成功
一、安装8.7催化剂方法
1、到驱动之家(http://www.mydrivers.com)或者ATI官方网站下载8.7催化剂 FOR LINUX
2、放到个人主文件夹里
3、终端里执行以下命令

代码: 全选

sudo sh ati-driver-installer-8-7-x86.x86_64.run
4、弹出图形化安装界面,按照默认选项即可
5、终端里执行命令

代码: 全选

aticonfig --initial

代码: 全选

aticonfig --overlay-type=Xv
6、重启动电脑
7、注意不要去改动“受限驱动管理器”,这时会自动启用新驱动。
检测驱动是否成功安装的命令及我的返回值:
代码:

代码: 全选

glxinfo |grep -e 'direct' -e 'OpenGL'
引用:
direct rendering: Yes
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 3850
OpenGL version string: 2.1.7769 Release
OpenGL extensions:



代码:

代码: 全选

fglrxinfo
引用:
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 3850
OpenGL version string: 2.1.7769 Release



代码(如果你目前开启了桌面特效,那么这个跑分恐怕只有正常值的40%):

代码: 全选

glxgears
引用:
46929 frames in 5.0 seconds = 9385.687 FPS
60409 frames in 5.0 seconds = 12081.798 FPS
60455 frames in 5.0 seconds = 12090.889 FPS
60326 frames in 5.0 seconds = 12065.128 FPS



代码(如果你目前开启了桌面特效,那么这个跑分恐怕只有正常值的40%):

代码: 全选

fgl_glxgears
引用:
Using GLX_SGIX_pbuffer
Using GLX_SGIX_pbuffer
12228 frames in 5.0 seconds = 2445.600 FPS
14964 frames in 5.0 seconds = 2992.800 FPS
15093 frames in 5.0 seconds = 3018.600 FPS
14759 frames in 5.0 seconds = 2951.800 FPS

二、安装催化剂8.4的方法
以下是zhizunbao的文章,我针对UBUNTU8.04和催化剂8.4驱动,做了一下小的改动
步骤相对7.11省略很多,无需编译内核模块,附修改后的compiz,以供参考。
建议纯净系统安装,这样如果确定显卡在支持范围的话,应该可以100%成功
另外,桌面环境建议使用GNOME,个人测试认为KDE环境下开3D不是很稳定,还有Ubuntu Studio的rt内核是不支持编译驱动的,想要装驱动就用GNOME版本的。个人意见
1。下载地址
http://drivers.mydrivers.com/drivers/21 ... x-x86-x64/
一般都放在主目录下,省得定义路径。
2。支持列表
工作站产品
引用:
FireGL™ V8650
FireGL™ V8600
FireGL™ V7600
FireGL™ V7350
FireGL™ V7300
FireGL™ V7200
FireGL™ V7100
FireGL™ V5600
FireGL™ V5200
FireGL™ V5100
FireGL™ V5000
FireGL HD3870
FireGL HD3850
FireGL™ V3600
FireGL™ V3400
FireGL™ V3300
FireGL™ V3200
FireGL™ V3100
FireGL™ X3-256
FireGL™ X3
[size=9]FireGL™ X2-256
[size=9]FireGL™ Z1-128
[size=9]FireGL™ T2-128
[size=9]FireGL™ X1-128
[size=9]FireGL™ X1-256p
[size=9]FireMV™ 2200 (Single card PCI-e configuration)
[size=9]Mobility™ FireGL™ V5000
[size=9]Mobility™ FireGL™ T2

移动及整合产品
引用:
Mobility™ Radeon™ X1800
Mobility™ Radeon™ X1600
Mobility™ Radeon™ X1400
Mobility™ Radeon™ X1300
Mobility™ Radeon™ X1200
Mobility™ Radeon™ X1100
Mobility™ Radeon™ X800
Mobility™ Radeon™ X700
Mobility™ Radeon™ X600
Mobility™ Radeon™ X300
Mobility™ Radeon™ X200
Mobility™ Radeon™ 9800
Mobility™ Radeon™ 9600
Mobility™ Radeon™ 9550
Mobility™ Radeon™ 9500
Mobility™ Radeon™ Xpress 1200 series
Mobility™ Radeon™ Xpress 1100 series
Mobility™ Radeon™ Xpress 200 series

桌面及整合产品
引用:
[/quote]Radeon™ HD 2900 series
Radeon™ HD 2600 series
Radeon™ HD 2400 series
Radeon™ X1900 series
Radeon™ X1800 series
Radeon™ X1600 series
Radeon™ X1300 series
Radeon™ X850 series
Radeon™ X800 series
Radeon™ X700 series
Radeon™ X600 series
Radeon™ X550/X300 series
Radeon™ 9800 series
Radeon™ 9700 series
Radeon™ 9600 series
Radeon™ 9550 series
Radeon™ 9500 series
Radeon™ Xpress1200 series
Radeon™ Xpress 1100 series
Radeon™ Xpress 200 series
注意:8.42.3是最后一个支持2.4内核的驱动。
3。安装编译所需要的包
代码:

代码: 全选

sudo apt-get update
sudo apt-get install module-assistant build-essential fakeroot dh-make debhelper debconf libstdc++5 linux-headers-generic dkms -y
4。卸载旧的fglrx
在新立得中把含有fglrx的软件包全部删除
5。生成.deb包
代码:

代码: 全选

sudo bash ati-driver-installer-8-4-x86.x86_64.run --buildpkg Ubuntu/hardy
耐心等待有四个deb包生成,共14.2MB。
6。将旧的fglrx模块从受限模块中列入黑名单:
GNOME用户输入:
代码:
gksu gedit /etc/default/linux-restricted-modules-common

KDE用户输入:
代码:
kdesu kate /etc/default/linux-restricted-modules-common

将 "DISABLED_MODULES" 改为DISABLED_MODULES="fglrx",也就是自己在双引号中输入fglrx即可,保存退出。
7。移除旧的fglrx包:
代码:
sudo rm /usr/src/fglrx-kernel*.deb

如果提示找不到文件,没关系,继续。
8。安装生成的.deb包
代码:
sudo dpkg -i xorg-driver-fglrx_8.476-0ubuntu1_i386.deb fglrx-kernel-source_8.476-0ubuntu1_i386.deb fglrx-amdcccle_8.476-0ubuntu1_i386.deb

遇到询问是否更新compiz-manager,选择N就行了。
然后再执行:
代码:
sudo apt-get install -f

9。重启电脑,选择UBUNTU8.04(RECOVERY MODE),就是命令行界面阿,加载完毕后选择ROOT,运行以下命令:
代码:

代码: 全选

sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv
exit
选择RESUME,进入正常登录界面

10。~看看你的人品怎么样~正常显示了么?

注意不要去改动“受限驱动管理器”,这时会自动启用新驱动。
检测驱动是否成功安装的命令及我的返回值:
代码:
glxinfo |grep -e 'direct' -e 'OpenGL'

引用:
direct rendering: Yes
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 3850
OpenGL version string: 2.1.7415 Release
OpenGL extensions:


代码:
fglrxinfo

引用:
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 3850
OpenGL version string: 2.1.7415 Release


代码:
glxgears

引用:
63315 frames in 5.0 seconds = 12662.957 FPS
65340 frames in 5.0 seconds = 13067.971 FPS
62548 frames in 5.0 seconds = 12509.510 FPS


代码:
fgl_glxgears

引用:
Using GLX_SGIX_pbuffer
13062 frames in 5.0 seconds = 2612.400 FPS
15299 frames in 5.0 seconds = 3059.800 FPS
15262 frames in 5.0 seconds = 3052.400 FPS[/size]
上次由 02015678 在 2012-12-09 22:09,总共编辑 5 次。
头像
windwizard
帖子: 27
注册时间: 2008-07-30 20:13
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 windwizard » 2008-08-01 22:20

不是在新立得那里装的么?这样太麻烦了吧?
头像
alexfaye
帖子: 26
注册时间: 2006-02-03 16:37
送出感谢: 0
接收感谢: 0
联系:

你好,我的ati卡安装催化剂失败,请教一下原因

#3

帖子 alexfaye » 2008-08-02 21:54

02015678
我的是ati hd2400的显卡,安装的8。7驱动催化剂之后,运行aticonfig --initial,显示

Uninitialised file found, configuring.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.original-0
aticonfig: Writing to '/etc/X11/xorg.conf' failed. Bad file descriptor.

请问是什么原因阿?
Welcome to my blog:
http://www.2fois.cn
头像
haiweiyangsink
帖子: 68
注册时间: 2008-07-18 9:12
来自: 计算机系
送出感谢: 0
接收感谢: 0

#4

帖子 haiweiyangsink » 2008-08-03 11:33

感谢啊
我顺利安装了
附件
Screenshot-root-desktop1.jpg
Screenshot-ATI Proprietary Linux Driver 8.512 Setup.jpg
Screenshot-root-desktop2.jpg
Screenshot-root-desktop3.jpg
Screenshot-root-desktop4.jpg
AMD Athlon™ Dual-Core + ATI Radeon Xpress 1250 + 500GB + 折腾 Opensuse; Fedora; Ubuntu

我错了,Linux就是给专家用的,我再也不抱怨了。(读《Linux不是Windows》有感)
shallamad
帖子: 15
注册时间: 2008-07-17 7:02
送出感谢: 0
接收感谢: 0

#5

帖子 shallamad » 2008-08-04 5:46

sh: Can't open ati-driver-installer-8-7-x86.x86_64.run

我的这是怎么回事,缺少啥东西吗?
shallamad
帖子: 15
注册时间: 2008-07-17 7:02
送出感谢: 0
接收感谢: 0

#6

帖子 shallamad » 2008-08-04 5:56

好了
是我没放到主文件夹的缘故

要不要先卸载掉 前面自动更新装上的 fglrx 驱动

这步好像有问题

liangmeijun@liangmeijun-desktop:~$ aticonfig --initial
Found fglrx primary device section
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.fglrx-0
aticonfig: Writing to '/etc/X11/xorg.conf' failed. Bad file descriptor.

原来 aticonfig --initial 这个前面也要 sudo

现在驱动还是没启用 准备尝试在新得力里面搜索fglrx 全部删除 再重装ATI 8.7
shallamad
帖子: 15
注册时间: 2008-07-17 7:02
送出感谢: 0
接收感谢: 0

#7

帖子 shallamad » 2008-08-04 6:26

装了 两遍 还是 提示这样子,效果没变化 求救
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (2.1 Mesa 7.0.3)
OpenGL extensions:
k52h
帖子: 33
注册时间: 2008-07-02 0:26
送出感谢: 0
接收感谢: 0

#8

帖子 k52h » 2008-08-05 13:02

direct rendering: Yes
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI MOBILITY RADEON 9600/9700 Series
OpenGL version string: 2.1.7769 Release
OpenGL extensions:
root@k52h-laptop:~# glxgears
14614 frames in 5.0 seconds = 2922.688 FPS
14678 frames in 5.0 seconds = 2935.576 FPS
14275 frames in 5.0 seconds = 2854.943 FPS

root@k52h-laptop:~# fgl_glxgears
Using GLX_SGIX_pbuffer
2780 frames in 5.0 seconds = 556.000 FPS
3214 frames in 5.0 seconds = 642.800 FPS
3196 frames in 5.0 seconds = 639.200 FPS
头像
enetor
帖子: 31
注册时间: 2007-04-29 15:02
来自: SCGY USTC
送出感谢: 0
接收感谢: 0

Re: 你好,我的ati卡安装催化剂失败,请教一下原因

#9

帖子 enetor » 2008-08-05 13:16

sudo
alexfaye 写了:02015678
我的是ati hd2400的显卡,安装的8。7驱动催化剂之后,运行aticonfig --initial,显示

Uninitialised file found, configuring.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.original-0
aticonfig: Writing to '/etc/X11/xorg.conf' failed. Bad file descriptor.

请问是什么原因阿?
Hi there
头像
enetor
帖子: 31
注册时间: 2007-04-29 15:02
来自: SCGY USTC
送出感谢: 0
接收感谢: 0

#10

帖子 enetor » 2008-08-05 13:17

貌似还要

代码: 全选

aticonfig --overlay-type=Xv
在我机器上得这一句,否则用xv播放电影会有问题
Hi there
icedar
帖子: 3
注册时间: 2006-10-06 1:46
送出感谢: 0
接收感谢: 0

#11

帖子 icedar » 2008-08-09 14:16

direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (2.1 Mesa 7.0.3-rc2)
OpenGL extensions:
头像
thydia
帖子: 41
注册时间: 2008-08-10 1:13
来自: 肇庆->广州
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 thydia » 2008-08-10 3:03

请问,ati2600xt的卡,能装Ubuntu和windows xp 双系统吗??
装了催化剂forlinux之后,在xp下还能用吗?(有些时候,我还是要用xp的)
谢谢
我是一根有思想懂想象的芦苇......
takashi
帖子: 20
注册时间: 2007-09-08 13:34
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 takashi » 2008-08-10 9:23

我装了也是这样。。。
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (2.1 Mesa 7.0.3-rc2)
OpenGL extensions:

开桌面特效就白屏,而且恢复不了以前的驱动了,系统管理的硬件驱动不见了
帮帮忙阿。。。
昨天就发帖子问了,还是没人理
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

#14

帖子 jarryson » 2008-08-10 13:31

你们不能跳过编译模块这一步,装内核头文件,不然驱动不能编译模块出来,也就没有办法开启3D
02015678
帖子: 110
注册时间: 2007-11-10 14:29
送出感谢: 1 次
接收感谢: 1 次
联系:

#15

帖子 02015678 » 2008-08-11 8:45

双系统是没有问题的,请先安装Windows系统,再安装Ubuntu。
安装Ubuntu可以采取两种方式:
1、传统安装方式,放入安装光盘,用光盘启动电脑,载入后按F2选择简体中文,然后选择安装。载入Ubungtu Live系统后,双击Install即可。
此方法应注意,分配硬盘分区的时候,注意不要选择使用整块硬盘,有能力的最好自己手动分配分区。
ROOT 10GB HOME 5-8GB SWAP 根据物理内存自定

手动分区可以用平时用的分区工具PQ、PM之类的,但注意,请给Ubuntu分出FAT32的盘就好,不可以用PQ、PM直接格式成EXT3,因为他们是微软的好哥们儿,它们做出来的EXT3,UBUNTU不认识
也可以用UBUNTU自带的分区工具
2、Windows内安装。在Windows下放入光盘,点击在Windows里安装,即可不给UBUNTU单独分区的情况下,安装Ubuntu,安装的Ubuntu同样会出现开机系统菜单里。用这种方法安装,Ubuntu可以像普通应用程序一样,在Windows控制面板里卸载。
优点也是缺点,本方法简单易行,安装后还可以简单卸载,但是据说这样安装不“完美”。Windows XP完全可以用这个方法,Windows Vista慎用(可以使用第一种方法)
回复

回到 “老旧版本支持”