当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 系统音量无法调节……
帖子发表于 : 2008-08-01 23:20 
头像

注册: 2006-12-29 20:13
帖子: 694
送出感谢: 0 次
接收感谢: 0 次
音量始终是100%,怎么调节都回到100%
用alsamixer也不行
引用:
houleihl@houleihl:~$ alsamixer

alsamixer: function snd_mixer_load failed: No such file or directory


_________________
在学习linux的道路上自在而行。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-02 6:26 

注册: 2007-03-24 20:19
帖子: 58
送出感谢: 0 次
接收感谢: 0 次
lz可能要重新装声卡驱动了


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-02 8:16 

注册: 2008-01-09 22:41
帖子: 18311
送出感谢: 0 次
接收感谢: 6
没有遇到过啊

怎么执行alsamixer还提示错误呢?

关注一下


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-08-02 9:35 

注册: 2007-03-24 20:19
帖子: 58
送出感谢: 0 次
接收感谢: 0 次
着好像是某些声卡的声卡驱动的问题http://alsa.opensrc.org/index.php/FAQ#I_get_.22no_such_file_or_directory.22_errors_from_all_alsa-utils._What.27s_wrong.3F
引用:
I get "no such file or directory" errors from all alsa-utils. What's wrong?

If you are sure you have ALSA installed and all necessary modules loaded into the kernel, then one reason could be a version mismatch. Especially version mismatches across major version numbers [like 0.9.7 -> 1.0.2] are bad.

If you're running a 2.6.x ( x <=5 ) series kernel with ALSA compilied into the kernel, you might try running the MAKEDEV.snd script found in the scripts/ directory of your Linux source tree. If the /dev/snd directory is not present, this script will build and populate it with the appropriate devices, which very well might fix your problem. Note: this script must be run as root.

Question from reader: I use ALSA v1.0.8, and a kernel 2.4.20. All the alsa devicefiles in /dev/snd are present. My old OSS applications thru an OSS-emulation layer snd-pcm-oss work properly. But still I can NOT run ANY application from alsa-utils package. What's wrong now? HELP!! The messages are: "Unknown PCM default: no such file or directory" ; "Unknown CLT hw:0,0: no such file or directory" ; and so on...

在ubuntu的bug网站上看到的解决方法
重新编译声卡驱动
sudo apt-get install module-assistant
sudo m-a update
sudo m-a prepare
sudo m-a a-i alsa
然后重新启动系统
gook luck
引用:
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/192382

Fragipani wrote on 2008-05-19: (permalink)

I also had exactly the same problem like you guys.
I fixed it with just typing 4 commands. I hope it works for you:

sudo apt-get install module-assistant
sudo m-a update
sudo m-a prepare
sudo m-a a-i alsa

After this you just have to restart your system. It should work now


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-08-02 14:17 
头像

注册: 2006-12-29 20:13
帖子: 694
送出感谢: 0 次
接收感谢: 0 次
bad luck……悲哀 :?


_________________
在学习linux的道路上自在而行。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-08-02 21:21 

注册: 2007-03-24 20:19
帖子: 58
送出感谢: 0 次
接收感谢: 0 次
你到这里仔细看看
https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/192382


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-08-03 10:48 
头像

注册: 2008-07-18 9:12
帖子: 68
地址: 计算机系
送出感谢: 0 次
接收感谢: 0 次
我用opensuse也是这个问题,realtek 的HD声卡

现在用ubuntu好了


_________________
AMD Athlon™ Dual-Core + ATI Radeon Xpress 1250 + 500GB + 折腾 Opensuse; Fedora; Ubuntu

我错了,Linux就是给专家用的,我再也不抱怨了。(读《Linux不是Windows》有感)


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译