当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]dpkg:严重警告:无法找到软件包“nvidia-kernel-common”的文件名列表文件
帖子发表于 : 2008-08-02 14:07 
头像

注册: 2006-11-06 22:53
帖子: 122
地址: 贵州大学
送出感谢: 0 次
接收感谢: 0 次
麻烦大家看看,有什么解决的办法没? 谢谢了。
在安装文件时就会这样example:
(正在读取数据库 ...
dpkg:严重警告:无法找到软件包“nvidia-kernel-common”的文件名列表文件,现假定该软件包目前没有任何文件被安装在系统里。
系统当前总共安装有 132152 个文件和目录。)
正预备替换 python2.5 2.5.2-2ubuntu4 (使用 .../python2.5_2.5.2-2ubuntu4.1_amd64.deb) ...

搜索到以前的一些帖子,给出的方法有问题阿:
sudo aptitude purge nvidia-kernel-common
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
正在初始化软件包状态... 完成
正在编辑扩展状态信息... 完成
创建标签数据库... 完成
下列软件包是“破损”的:
linux-restricted-modules-2.6.24-16-generic
linux-restricted-modules-2.6.24-20-generic
下列软件包未被使用,将被“删除”:
libqt4-assistant libqt4-core libqt4-dbus libqt4-designer libqt4-gui
libqt4-opengl libqt4-script libqt4-svg libqt4-test libqt4-xml
下列软件包将被“删除”:
nvidia-kernel-common{p}
0 个软件包被升级,新安装0 个, 11 个将被删除, 同时 0 个将不升级。
需要获取 0B 的存档。 解包后将释放 10.0MB。
下列软件包存在未满足的依赖关系:
linux-restricted-modules-2.6.24-16-generic: 依赖: nvidia-kernel-common 但是它不是可安装的
linux-restricted-modules-2.6.24-20-generic: 依赖: nvidia-kernel-common 但是它不是可安装的
Resolving dependencies...
下列动作将解决这些依赖关系:

删除 下列软件包:
jockey-common
jockey-gtk
linux-generic
linux-restricted-modules-2.6.24-16-generic
linux-restricted-modules-2.6.24-20-generic
linux-restricted-modules-generic
ubuntu-desktop

分数是 533

是否接受该解决方案?[Y/n/q/?] q
放弃解决这些依赖关系的全部努力。
放弃。
这些东西删除了,好像系统就会出问题。 求解!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-03 0:59 
头像

注册: 2006-11-06 22:53
帖子: 122
地址: 贵州大学
送出感谢: 0 次
接收感谢: 0 次
没有人能回答么??
我来顶一顶!


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-03 1:12 

注册: 2007-02-06 16:21
帖子: 419
送出感谢: 0 次
接收感谢: 0 次
linux-restricted-modules-2.6.24-16-generic 和 linux-restricted-modules-2.6.24-20-generic 留一个就行了 根据你的内核版本

linux-restricted-modules-2.6.24-20-generic
linux-restricted-modules-generic
是比较重要的,删了可能有大麻烦的,其他的无所谓
等楼下解决


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-08-03 13:05 
头像

注册: 2006-11-06 22:53
帖子: 122
地址: 贵州大学
送出感谢: 0 次
接收感谢: 0 次
太老火了
我这样一删除,肯定系统就废了。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-08-04 0:49 
头像

注册: 2006-11-06 22:53
帖子: 122
地址: 贵州大学
送出感谢: 0 次
接收感谢: 0 次
完了,还没人能帮忙么??


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-08-04 9:24 

注册: 2007-01-07 15:04
帖子: 84
送出感谢: 0 次
接收感谢: 0 次
只有等源更新了.......这是debian系的软肋,太依靠源


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译