[教学]安装ATI显卡驱动8.7催化剂版后屏幕全白的处理办法

为当前最终发行版之前的所有版本提供支持
回复
liujing0146
帖子: 3
注册时间: 2008-08-01 12:43
送出感谢: 0
接收感谢: 0

[教学]安装ATI显卡驱动8.7催化剂版后屏幕全白的处理办法

#1

帖子 liujing0146 » 2008-08-02 22:35

UBUNTU8.04下安装ATI显卡驱动8.7催化剂后重启电脑后屏幕一片空白,鼠标能动,又键也没反应。

重启电脑也一样,无奈回到XP下上网搜索,发现很多网友都有相同的问题,有些是更新了其他包导致的,有网友建议重装系统。

后来百度到一篇文章,贴出来大家分享:

出处:http://www.linuxdiyf.com/viewarticle.php?id=94642

背景:安装系统后,源里的驱动挺好,可是因为我的显卡是集成的ati1250,性能不太好,要想玩特效的话,太勉强。想搞一下最新的官方驱动。安装过程简单,sudo sh ati***.sh,出现图形界面一步一步下一步就行了,安装好后发现性能不如源里的,所以又删除了,删除没有出现问题,完了重新启动,进不了显示器黑屏,用ctrl+alt+F1进入命令行。

代码: 全选

cd /etc/X11/
进入X11文件夹

代码: 全选

sudo rm xorg.conf
删除xorg.conf

代码: 全选

sudo cp xorg.conf.failsafe xorg.conf
将该文件夹的xorg.conf.failsafe文件复制为xorg.conf,注:好像是不能进入图形界面的时候都会有这个文件,如果没有可以自己编辑一个,很简单。

重新启动,能进桌面了,心里不紧张了,呵呵,虽然在此之前一直给自己打气,不紧张不紧张,我叫不紧张,还是紧张的很。

但是现在分辨率很低,我的是800*600(19寸宽屏)。

点开“硬件驱动”看了下,勾选驱动,自动安装,重新启动。

又进不了桌面了。重新上面的步骤进桌面。

代码: 全选

sudo apt-get install envyng-core
安装envyng,这个是帮助安装和卸载显卡驱动的(包括ati和nvidia)

代码: 全选

sudo envyng -t
运行envyng,似乎是需要root权限的,因为是要安装驱动,呵呵,我猜的,大家可以试试不用sudo。

下面的简单的很,给不懂英语的人翻译一下,其实很简单的句子:
QUOTE:
| EnvyNG Menu ver.1.1.1 |
| EnvyNG菜单 版本号1.1.1 |
| 1 - Install the NVIDIA driver |
| 安装nvidia驱动 |
| 2 - Uninstall the NVIDIA driver |
| 卸载nvidia驱动 |
| 3 - Install the ATI driver |
| 安装ati驱动 |
| 4 - Uninstall the ATI driver |
| 卸载ati驱动 |
| 5 - Install the ATI/NVIDIA driver Manually |
| 手动安装ati/nvidia驱动 |
| 6 - Restart the Xserver |
| 重新启动Xserver |
| 7 - Restart your computer |
| 重新启动电脑 |
| 8 - Exit |
| 退出 |
| NOTE: IF THE SCREEN TURNS BLACK, PLEASE TYPE ALT+F1

注意:如果黑屏,按alt+F1

Please select one of the activities displayed above and press ENTER:

请选择菜单前面的数字,并按回车键:(在这里输入上面的数字就行了)

然后就会自动下载驱动并安装。安装完重新启动。

我这里重新启动后分辨率仍然不正常,又执行了

代码: 全选

sudo aticonfig –initial -f
这一句并重新启动后才正常,在此之前没看xorg.conf,不知道是不是有什么变化。

我的电脑一切ok了,大家作个参考。谢谢z_kvn


我没有照文章说的删除xorg.conf,xorg.conf.failsafe文件复制为xorg.conf,而是直接用envyng重新装了一边ATI驱动,重启后桌面又回来了,哈哈!
头像
laowu2141
帖子: 530
注册时间: 2007-06-19 11:25
系统: kubuntu 13.04
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 laowu2141 » 2008-08-02 23:43

我先把compiz升级到0.7.6后再安装驱动,就没有白屏了
回复

回到 “老旧版本支持”