当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : gz包怎么样安装的?
帖子发表于 : 2008-08-05 11:41 
头像

注册: 2008-06-16 14:37
帖子: 185
送出感谢: 0 次
接收感谢: 0 次
gz包不会安装 我不想用DEB包。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-05 13:02 

注册: 2008-07-02 18:33
帖子: 136
地址: Shanghai
送出感谢: 0 次
接收感谢: 0 次
gz就是个压缩包而已


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-05 13:07 
头像

注册: 2008-04-14 23:29
帖子: 2114
地址: 曾也在NB大学呆过
送出感谢: 3
接收感谢: 10
相当于win下的绿色版软件,解压缩就能使用。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-08-05 13:38 

注册: 2007-01-07 15:04
帖子: 84
送出感谢: 0 次
接收感谢: 0 次
tar.gz通常是源代码包,需要编译安装,极其繁琐,lz最好还是用deb包吧


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-08-05 14:11 
头像

注册: 2007-06-30 0:27
帖子: 509
送出感谢: 0 次
接收感谢: 1
一般的压缩包有两种形式,一种是已经编译好的二进制包,只需要解压到想要的位置(一般是/opt),然后找到可执行文件就可以运行;另一种是源代码包,需要编译安装,步骤举例如下(假如压缩包放在桌面上,名字叫做firefox-3.0.1.tar.bz2或firefox-3.0.1.tar.gz):
引用:
cd ~/Desktop

进入桌面

引用:
tar xvfj firefox-3.0.1.tar.bz2
或者
引用:
tar zxvf firefox-3.0.1.tar.gz

解压缩(注意,后缀不想同)

引用:
cd firefox-3.0.1

进入源代码文件夹

引用:
./configure

编译前的配置

引用:
make

编译

引用:
sudo make install

安装

引用:
sudo make clean

清理编译时产生的临时文件
完毕。
但是同样建议用deb包安装,那样便于软件的管理。


_________________
反对台独,反对藏独,反对孤独!
apt-get不是万能的:

代码:
sudo apt-get install girlfriend
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。
下列的信息可能会对解决问题有所帮助:
下列的软件包有不能满足的依赖关系:
girlfiend: 依赖: hourse但是它将不会被安装
girlfiend: 依赖: car但是它将不会被安装
house,car: 依赖: money但是它将不会被安装
E: 无法安装的软件包


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-08-05 15:28 
头像

注册: 2008-06-16 14:37
帖子: 185
送出感谢: 0 次
接收感谢: 0 次
谢谢个位。 我试一下。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-08-05 17:06 
头像

注册: 2008-07-21 0:26
帖子: 221
地址: 郑州-北环-华北水利水电学院
送出感谢: 0 次
接收感谢: 0 次
yyz139 写道:
tar.gz通常是源代码包,需要编译安装,极其繁琐,lz最好还是用deb包吧

恩 同意


_________________
学习就是不断失败再胜利的过程!

望大家多多指教,小弟不胜感激!

邮箱:ququanfang@gmail.com
博客:http://hi.baidu.com/love214925


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-08-05 18:52 

注册: 2008-05-02 15:55
帖子: 200
送出感谢: 0 次
接收感谢: 0 次
推荐有问题先google: linux 编译安装


页首
 用户资料  
 
9 楼 
 文章标题 : Re: gz包怎么样安装的?
帖子发表于 : 2008-08-06 11:09 
头像

注册: 2008-03-23 17:01
帖子: 3340
送出感谢: 0 次
接收感谢: 2
live.cn 写道:
gz包不会安装 我不想用DEB包。

解压就可以了吧。
ps:为何不想用deb?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译