当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 如何让gnome不再提示此会话正以特权用户的身份运行?
帖子发表于 : 2008-08-05 23:18 

注册: 2008-05-23 2:58
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
root登录时,总提示为安全起见,应当避免以特权用户的身份运行会话。如果可能的话,您应该以普通用户的身份登录什么的,很烦!

怎么关掉它?

谢谢!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-23 20:46 

注册: 2006-12-03 17:59
帖子: 156
送出感谢: 0 次
接收感谢: 0 次
我也想关掉它


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-23 20:57 

注册: 2008-01-09 22:41
帖子: 18311
送出感谢: 0 次
接收感谢: 6
不用root登录不就好了?

或者试试系统-系统管理-登录窗口设置


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-09-09 0:13 

注册: 2008-05-23 2:58
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
我只用root,没人解答所以我改用kde了。论坛没人啊!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 如何让gnome不再提示此会话正以特权用户的身份运行?
帖子发表于 : 2008-11-22 16:14 

注册: 2008-11-02 8:52
帖子: 73
送出感谢: 5
接收感谢: 0 次
这个问题真的没人懂了?!


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 如何让gnome不再提示此会话正以特权用户的身份运行?
帖子发表于 : 2008-11-23 11:56 
头像

注册: 2008-10-18 12:41
帖子: 1339
送出感谢: 0 次
接收感谢: 0 次
关不了,用普通用户登录就行了


_________________
Server@Linux:~#


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 如何让gnome不再提示此会话正以特权用户的身份运行?
帖子发表于 : 2008-12-31 13:22 

注册: 2007-05-06 18:13
帖子: 11
地址: 天津
系统: Linux Mint
送出感谢: 0 次
接收感谢: 0 次
这是gnome-session的事情,不是一个bug,但是确实不方便,人总是比计算机聪明,我喜欢用root用户,我知道自己的做什么。ubuntu的新版本好像已经改掉了这个讨厌的地方,不过我现在用的debian5还没有改变,自己动手,丰衣足食,hack一下:

需要下载gnome-session的源码重新编译替换原来的。在debian下面做这些工作非常简单(以 gnome-session-2.22.3为例):

1. 下载gnome-session的源码,最好建一个临时目录去做
# mkdir -v hack-gnome
# cd hack-gnome
# apt-get source gnome-session

2. 注释掉 ./gnome-session-2.22.3/gnome-session/main.c 的 625,626 行
625 /* if (gsm_check_for_root ())
626 return 0; */

上面的作用就是不检查是否为root用户,gsm_check_for_root 是 main.c里面定义的一个函数,检查为root用户就提示那个讨厌的对话框,你可以禁止掉它了。

3. 编译 gnome-session
# apt-get -b source gnome-session

4. 安装 gnome-session ,用下面目录会覆盖以前的 /usr/bin/gnome-session
# dpkg -i gnome-session_2.22.3-2_amd64.deb


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 如何让gnome不再提示此会话正以特权用户的身份运行?
帖子发表于 : 2009-03-12 6:13 
头像

注册: 2009-01-29 2:18
帖子: 41
地址: 河南省平顶山市
送出感谢: 0 次
接收感谢: 0 次
jianlee 写道:
这是gnome-session的事情,不是一个bug,但是确实不方便,人总是比计算机聪明,我喜欢用root用户,我知道自己的做什么。ubuntu的新版本好像已经改掉了这个讨厌的地方,不过我现在用的debian5还没有改变,自己动手,丰衣足食,hack一下:

需要下载gnome-session的源码重新编译替换原来的。在debian下面做这些工作非常简单(以 gnome-session-2.22.3为例):

1. 下载gnome-session的源码,最好建一个临时目录去做
# mkdir -v hack-gnome
# cd hack-gnome
# apt-get source gnome-session

2. 注释掉 ./gnome-session-2.22.3/gnome-session/main.c 的 625,626 行
625 /* if (gsm_check_for_root ())
626 return 0; */

上面的作用就是不检查是否为root用户,gsm_check_for_root 是 main.c里面定义的一个函数,检查为root用户就提示那个讨厌的对话框,你可以禁止掉它了。

3. 编译 gnome-session
# apt-get -b source gnome-session

4. 安装 gnome-session ,用下面目录会覆盖以前的 /usr/bin/gnome-session
# dpkg -i gnome-session_2.22.3-2_amd64.deb


我的是 652,653行。

652 /* if (gsm_check_for_root ())
653 return 0; */

然后编译出错。。。

root@yingmu-desktop:~/hack-gnome# apt-get -b source gnome-session
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
忽略已下载过的文件“gnome-session_2.22.1.1-0ubuntu2.dsc”
忽略已下载过的文件“gnome-session_2.22.1.1.orig.tar.gz”
忽略已下载过的文件“gnome-session_2.22.1.1-0ubuntu2.diff.gz”
需要下载 0B 的源代码包。
对于已经被解包到 gnome-session-2.22.1.1 目录的源代码包就不再解开了
dpkg-buildpackage: set CPPFLAGS to default value:
dpkg-buildpackage: set CFLAGS to default value: -g -O2
dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
dpkg-buildpackage: set FFLAGS to default value: -g -O2
dpkg-buildpackage: set LDFLAGS to default value: -Wl,-Bsymbolic-functions
dpkg-buildpackage: 源码包 gnome-session
dpkg-buildpackage: 源码版本 2.22.1.1-0ubuntu2
dpkg-buildpackage: 源码修改者 Sebastien Bacher <seb128@canonical.com>
dpkg-buildpackage: 主机架构 i386
dpkg-checkbuilddeps:未满足的构建依赖关系: cdbs (>= 0.4.41) quilt liborbit2-dev (>= 2.10.2-1.1) intltool (>= 0.35.0) libgnomeui-dev (>= 2.10) libgconf2-dev (>= 2.10.1-6) libgnomecanvas2-dev (>= 2.10) libgnomevfs2-dev (>= 2.10) gnome-pkg-tools (>= 0.10) debhelper (>= 5.0.13) libx11-dev libxt-dev libice-dev libsm-dev libxrender-dev libxrandr-dev libxmu-dev libxau-dev libwrap0-dev libnotify-dev (>= 0.2.1) libgnome-desktop-dev sharutils libdbus-glib-1-dev (>= 0.35) libgnome-keyring-dev (>= 2.21.92) gnome-settings-daemon-dev libglib2.0-dev (>= 2.13.0) libgtk2.0-dev (>= 2.11.1)
dpkg-buildpackage: 警告: 没有成功建立依赖关系,退出。
dpkg-buildpackage: 警告: (使用 -d 参数来忽略)
执行构造软件包命令“cd gnome-session-2.22.1.1 && dpkg-buildpackage -b -uc”失败。
E: 子进程出错


唉,又夭折了…… :em20


_________________
让复杂的事情变得简单起来。
樱木花盗's Blog http://www.03389.com


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 如何让gnome不再提示此会话正以特权用户的身份运行?
帖子发表于 : 2010-11-16 19:33 
头像

注册: 2010-05-24 12:16
帖子: 1015
送出感谢: 0 次
接收感谢: 0 次
我的怎么没有 5.0 的?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译