[问题]装IPMSG遇到的问题,请大家帮忙

为当前最终发行版之前的所有版本提供支持
回复
kecai_cale
帖子: 16
注册时间: 2008-08-07 14:19
送出感谢: 0
接收感谢: 0

[问题]装IPMSG遇到的问题,请大家帮忙

#1

帖子 kecai_cale » 2008-08-07 17:59

从网上下了个 g2ipmsg-0.9.5.tar.gz ,安装过程中提示glib和gtk版本太低,于是下载了个glib-2.17.0和gtk+-2.12.0 ,结果到gtk安装不下去了,到configure就提示错误,缺文件,提示:
checking for BASE_DEPENDENCIES... configure: error: Package requirements (glib-2.0 >= 2.13.5 atk >= 1.9.0 pango >= 1.17.3 cairo >= 1.2.0) were not met:

No package 'atk' found
No package 'pango' found
No package 'cairo' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
怀疑pango的问题,下了个新版的,安装又提示:
configure: error: *** Could not enable any of FreeType, X11, Cairo, or Win32 backends.
*** Must have at least one backend to build Pango.
搞的头大了!
kecai_cale
帖子: 16
注册时间: 2008-08-07 14:19
送出感谢: 0
接收感谢: 0

#2

帖子 kecai_cale » 2008-08-07 18:01

如何安装缺失文件,有简便点的方法吗?郁闷了!
kecai_cale
帖子: 16
注册时间: 2008-08-07 14:19
送出感谢: 0
接收感谢: 0

#3

帖子 kecai_cale » 2008-08-07 18:37

desktop:~/g2ipmsg-0.9.5# sudo apt-get install libxml-parser-perl libgnomeui-dev libpanel-applet2-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
libxml-parser-perl 已经是最新的版本了。
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libgnomeui-dev: 依赖: libgnomeui-0 (= 2.20.1.1-0ubuntu1) 但是 2.22.1.0-0ubuntu2 正要被安装
依赖: libgnome2-dev (>= 2.13.7) 但是它将不会被安装
依赖: libgtk2.0-dev (>= 2.11.5) 但是它将不会被安装
依赖: libgnomecanvas2-dev (>= 2.6.0) 但是它将不会被安装
依赖: libgnome-keyring-dev (>= 0.4) 但是它将不会被安装
依赖: libgconf2-dev (>= 2.6.0) 但是它将不会被安装
依赖: libbonoboui2-dev (>= 2.13.1) 但是它将不会被安装
依赖: libgnomevfs2-dev (>= 2.8.4-2) 但是它将不会被安装
依赖: libsm-dev 但是它将不会被安装
依赖: libice-dev 但是它将不会被安装
依赖: libpango1.0-dev (>= 1.1.2) 但是它将不会被安装
依赖: libglib2.0-dev (>= 2.13.4) 但是它将不会被安装
libpanel-applet2-dev: 依赖: libpanel-applet2-0 (= 1:2.20.1-0ubuntu1) 但是 1:2.22.2-0ubuntu1 正要被安装
依赖: liborbit2-dev (>= 1:2.12.4-1) 但是它将不会被安装
依赖: libglib2.0-dev (>= 2.13.0) 但是它将不会被安装
依赖: libgtk2.0-dev (>= 2.11.3) 但是它将不会被安装
依赖: libglade2-dev (>= 1:2.5.0) 但是它将不会被安装
依赖: libbonoboui2-dev (>= 2.1.1) 但是它将不会被安装
E: 无法安装的软件包
kecai_cale
帖子: 16
注册时间: 2008-08-07 14:19
送出感谢: 0
接收感谢: 0

#4

帖子 kecai_cale » 2008-08-08 7:45

依赖关系怎么弄不了,哪有问题,大家帮忙阿!
回复

回到 “老旧版本支持”