[问题]apt-get 的问题??

为当前最终发行版之前的所有版本提供支持
回复
头像
bobo4548
帖子: 661
注册时间: 2007-07-17 22:52
来自: cn,shandong
送出感谢: 0
接收感谢: 0
联系:

[问题]apt-get 的问题??

#1

帖子 bobo4548 » 2008-08-07 21:42

在安装LXDE中发生问题,apt-get出现错误,结果无法安装,因为删除了原来安装的lxpanel/lxsession,现在没有任务栏和菜单了,求助!!提示如下:
sudo apt-get install lxpanel
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
lxpanel: 依赖: libasound2 (> 1.0.14) 但是 1.0.13-1ubuntu5 正要被安装
依赖: libatk1.0-0 (>= 1.20.0) 但是 1.18.0-0ubuntu1 正要被安装
依赖: libcairo2 (>= 1.6.0) 但是 1.4.2-0ubuntu1.3 正要被安装
依赖: libfreetype6 (>= 2.3.5) 但是 2.2.1-5ubuntu1.1 正要被安装
依赖: libglib2.0-0 (>= 2.16.0) 但是 2.12.11-0ubuntu1 正要被安装
依赖: libgtk2.0-0 (>= 2.12.0) 但是 2.10.11-0ubuntu3 正要被安装
依赖: libpango1.0-0 (>= 1.20.1) 但是 1.16.2-0ubuntu1 正要被安装
依赖: libpixman-1-0 但却无法安装它
依赖: zlib1g (>= 1:1.2.3.3.dfsg-1) 但是 1:1.2.3-13ubuntu4 正要被安装
E: 无法安装的软件包
头像
bobo4548
帖子: 661
注册时间: 2007-07-17 22:52
来自: cn,shandong
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 bobo4548 » 2008-08-09 20:23

没有人给予解答吗????关键是怎样处理好依赖问题啊!!!
回复

回到 “老旧版本支持”