当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装anjuta过程出现如下错误
帖子发表于 : 2008-08-08 14:54 

注册: 2008-08-07 14:41
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
在./configure步骤中
引用:
checking for pkg-config... /usr/bin/pkg-config
checking for GLIB... configure: error: Package requirements (glib-2.0 >= 2.14.0) were not met:

No package 'glib-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GLIB_CFLAGS
and GLIB_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


我明明已经安装了glib-2.16.0,还做了以下四步,为什么还 有错误呢?
引用:
LD_LIBRARY_PATH=/usr/src/glib/lib:$LD_LIBRARY_PATH
PKG_CONFIG_PATH=/usr/src/glib/lib/pkgconfig:$PKG_CONFIG_PATH
GLIB_CFLAGS=`pkg-config --cflags glib-2.0`
GLIB_LIBS=`pkg-config --libs glib-2.0`

请问该怎么解决?
万分感谢。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-08 15:08 

注册: 2008-08-07 14:41
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
高手快来呀!!


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-08 15:09 
头像

注册: 2007-08-05 17:40
帖子: 4968
送出感谢: 0 次
接收感谢: 4
sudo apt-get install anjuta

為什么一定要編譯安裝呢?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-08-08 15:12 

注册: 2008-08-07 14:41
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
cnkilior 写道:
sudo apt-get install anjuta

为什么一定要编译安装呢?


这种情况很复杂。配置文件使用的检查工具很奇怪,和我以前看遇到的类似,需要改configure。。。


哦,我本想源码安装,可以加快对Linux的学习,现在看来anjuta只有这样装了。
谢谢。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译