当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]安装scim-python时遇到的问题
帖子发表于 : 2008-08-15 20:03 

注册: 2007-06-26 21:16
帖子: 21
地址: 绍兴
送出感谢: 0 次
接收感谢: 0 次
按照这个网站http://code.google.com/p/scim-python/wiki/PinYinUserGuide的描述,我下载了源码包,然后按照它的的提示进行安装,结果

在输入
代码:
$ sudo apt-get install python-dev
命令后出现:
代码:
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  python-dev: 依赖: python2.5-dev (>= 2.5.2) 但是它将不会被安装
E: 无法安装的软件包


在输入
代码:
sudo apt-get install python-gtk2-dev
命令后出现:
代码:
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  python-gtk2-dev: 依赖: python-dev 但是它将不会被安装
                   依赖: python-gobject-dev (>= 2.14) 但是它将不会被安装
E: 无法安装的软件包


这个问题怎么解决呢?[/code][/url]


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-15 20:26 

注册: 2007-02-26 2:29
帖子: 322
地址: 广东
送出感谢: 0 次
接收感谢: 0 次
从源代码编译安装没那么多麻烦事情.


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-15 20:28 

注册: 2007-06-26 21:16
帖子: 21
地址: 绍兴
送出感谢: 0 次
接收感谢: 0 次
怎么搞?
我就是源代码编译的啊?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-08-15 21:31 
头像

注册: 2008-07-19 17:45
帖子: 254
送出感谢: 2
接收感谢: 0 次
很简单
sudo apt-get install 软件包

把你那个依赖的软件包全部输进去。


_________________
http://qydw.blogspot.com


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-08-15 22:30 

注册: 2007-06-26 21:16
帖子: 21
地址: 绍兴
送出感谢: 0 次
接收感谢: 0 次
这样一点用都没有啊。。。
最后不是绕了一个圈子就是那个软件包已经安装了。。。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-08-16 0:10 
头像

注册: 2008-07-14 22:42
帖子: 8078
地址: Beijing
送出感谢: 0 次
接收感谢: 0 次
应该是有一个完全版的deb包的 :lol:


_________________
Ubuntu User


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-08-16 11:00 

注册: 2007-06-26 21:16
帖子: 21
地址: 绍兴
送出感谢: 0 次
接收感谢: 0 次
哪儿有?
我只找到64位的,我需要32位的


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-08-16 17:44 
头像

注册: 2008-07-14 22:42
帖子: 8078
地址: Beijing
送出感谢: 0 次
接收感谢: 0 次
你不说阿!不是很就以前看多的,今天也找了半天,又一个修正版的,很好用
http://cid-d07901ad4b0f9185.skydrive.li ... |_i386.deb
一定能用,还是不要编译了 8)


_________________
Ubuntu User


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-08-18 16:34 

注册: 2007-06-26 21:16
帖子: 21
地址: 绍兴
送出感谢: 0 次
接收感谢: 0 次
地址连接不上,要不你上传一下吧


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-08-18 18:11 
头像

注册: 2008-04-18 20:58
帖子: 136
送出感谢: 0 次
接收感谢: 0 次
deb包是可以自动安装依赖的 就是看你下载的包怎么样了

其实装软件用

sudo apt-get install ****还是好点 很直观


要么就去新立得里用关键字搜索安装


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Exabot [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译