源码安装scim-python执行configure时,遇到scim找不到的问题

为当前最终发行版之前的所有版本提供支持
回复
peng6662001
帖子: 15
注册时间: 2008-08-19 9:25
送出感谢: 0
接收感谢: 0

源码安装scim-python执行configure时,遇到scim找不到的问题

#1

帖子 peng6662001 » 2008-08-19 18:11

checking for SCIM... configure: error: Package requirements (
scim >= 1.4
) were not met:

No package 'scim' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables SCIM_CFLAGS
and SCIM_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


我使用root@SP:/tmp/scim-python-0.1.12# apt-get install scim
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
scim 已经是最新的版本了。
The following packages were automatically installed and are no longer required:
linux-headers-2.6.24-19-generic linux-headers-2.6.24-19
Use 'apt-get autoremove' to remove them.
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级

难道是因为我的scim版本太高而不能装吗
peng6662001
帖子: 15
注册时间: 2008-08-19 9:25
送出感谢: 0
接收感谢: 0

#2

帖子 peng6662001 » 2008-08-19 19:42

$ sudo apt-get install scim-dev
$ sudo apt-get install python-dev
$ sudo apt-get install python-enchant
$ sudo apt-get install python-gtk2-dev
$ sudo apt-get install libgtk2.0-dev
$ tar jxvf scim-python-${version}.tar.bz2
$ cd scim-python-${version}
$ ./configure --prefix=/usr
$ make
$ sudo make install
回复

回到 “老旧版本支持”