当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]Nvidia显卡驱动安装的问题求助(done)
帖子发表于 : 2008-08-20 21:41 

注册: 2008-08-19 12:34
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
显卡比较旧,型号是GeForce2 MX/MX 400;显示器是17“菲利普CRT
系统安装之后分辨率640*480,刷新频率50hz
硬件能检索到该显卡,而且状态是“使用中”
使用新立得更新显卡驱动,无效
按wiki的方法使用“sudo nvidia-xconfig”命令,安装后分辨率可以达到800*600,但刷新频率还是很低(50hz还是60hz,忘记了)
到Nvidia主页下载驱动程序:NVIDIA-Linux-x86-96.43.07-pkg1.run
安装时提示核心不支持,需要编译,确定之后又给了个提示,没有细看,而且只有ok键可以用,然后一路按下去,最后提示说安装不了:(

不知现在还能怎么办?


最后由 zluoj 编辑于 2008-08-21 19:29,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-20 21:43 

注册: 2008-08-19 12:34
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
已经装了wine,能不能用它安装windows的驱动的?
:evil:


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-20 21:48 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
sudo nvidia-settings

wine 那个方法是绝对不可以的


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-08-21 0:20 

注册: 2008-08-19 12:34
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
提示说找不到该指令哦
是不是还要安装什么软件包?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-08-21 11:23 
头像

注册: 2008-06-11 17:02
帖子: 164
送出感谢: 0 次
接收感谢: 0 次
源里不是有受限驱动吗?

http://forum.ubuntu.org.cn/viewtopic.php?t=69241


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-08-21 12:35 

注册: 2008-05-24 8:30
帖子: 1453
送出感谢: 2
接收感谢: 30
那个你没看的提示估计是找不到某个头文件之类的,就是要安装开发包。

初次使用一定要好好看提示。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-08-21 12:38 
头像

注册: 2008-03-26 14:28
帖子: 385
送出感谢: 0 次
接收感谢: 0 次
要先装libc6-dev的。你sudo apt-get install libc6-dev,然后再装nv驱动


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-08-21 12:47 

注册: 2008-01-09 22:41
帖子: 18311
送出感谢: 0 次
接收感谢: 6
boreascn 写道:
要先装libc6-dev的。你sudo apt-get install libc6-dev,然后再装nv驱动


wine只能运行一般程序

像驱动这种程序,wine是带不起来的

还有就是显卡驱动,未必最新版就是好的


至少我这里就是这样子,弄个最新版,反而无法安装,后来找了一个旧版的,完美安装……

不知到英伟达怎么想的

或者安装受限驱动也可以,但是感觉不如自己安有手感(可以练习命令)


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-08-21 13:06 

注册: 2008-07-19 8:44
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
:o :o I Don't Know


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-08-21 19:50 

注册: 2008-08-19 12:34
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
:D 解决了!!
哈哈哈!!!!

过程如下:
按5楼的链接进去想找那个受限驱动,但不知是版本问题(我现在u的版本是8.04,网页上作者的版本是不是早期的?),一直找不到受限驱动的选项。
然后就自己卸载了nvidia-glx,装了nvidia-xconfig,然后再安装从官网下载的run驱动,这次居然能安装了!
(前一次不能安装是因为当时装的是nvidia-glx,有没有高手解释一下nvidia-glx和nvidia-xconfig分别是做什么用的?)

安装方法也是在坛上介绍的:
sudo /etc/init.d/gdm stop
cd /path/to/nvidia/installer
sudo sh NVidia-Linux-x86-1.0-xxxx-yyyy.run
sudo /etc/init.d/gdm start

这次看了提示,分别是(英语水平一般,翻译很可能有误):
1.发现没有对应的核心接口(Kernel interface),是否从官网下载?选择ok
2.在官网没有发现相应源,是否自行编译?选择ok
然后一路下去,顺利装完

但稍微有点问题,就是开启不了3d,一开启就自动卸载nvidia-xconfig而去安装nvidia-glx,结果分辨率又不行了。不知有没有解决方法?

另,坛上说安装官网的驱动,重启后需要再安装,但我故意重启过,并没有出现如此凄凉的情况:)


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-08-26 15:22 

注册: 2008-08-26 14:36
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
我也是这个问题,装不上驱动,没办法就在其它里面的显示器和显卡选项里随便选了一个支持1024*868*75HZ的,用着再说,3D不考虑了,只要屏幕不要太闪就行了


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-08-26 17:30 
头像

注册: 2008-08-23 17:19
帖子: 72
地址: mZD
送出感谢: 0 次
接收感谢: 0 次
我的 GF2 MX200 32MB
VIEWSONIC VA712

装好就驱动好了 1024*768

装了受限驱动后 特效也能开启扩展了。


_________________
aCER ASPIRE 3810T
iNTEL sU3500
iNTEL 4500
dDR3 1GB
hDD: 250GB
uBUNTU 9.04 + BT4 + VISTA


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-08-26 17:55 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
nvidia-glx本来就是错的。。。

你用的驱动应该是 nvidia-glx-legacy

apt://nvidia-glx-legacy


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-08-26 22:28 
头像

注册: 2008-08-21 20:26
帖子: 810
送出感谢: 0 次
接收感谢: 0 次
我的TNT2可以启动3D,很简单
打开系统管理-硬件驱动-勾启动选项

系统自动处理


_________________
软件交流群:17264279
图书分享群:18246379
互动社区:http://www.ubuntuchina.com/


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译