[问题]lfs开始的binutils问题

为当前最终发行版之前的所有版本提供支持
回复
longgyifei
帖子: 72
注册时间: 2007-08-29 0:30
送出感谢: 0
接收感谢: 0

[问题]lfs开始的binutils问题

#1

帖子 longgyifei » 2008-08-21 19:07

最近一直在进行LFS,其中最主要的就是GCC,GLIBC,BINUTILS这三个,在LFS6.3光盘里用的是BINUTILS-2.17,我想用最新的2.18,于是下载了一个下来,开始第一次binutils make 的时候就出现问题了,提示如下:
make[3]: Leaving directory `/mnt/lfs/sources/binutils-build/bfd/po'
make[3]: Entering directory `/mnt/lfs/sources/binutils-build/bfd/po'
make[3]: Nothing to be done for `info'.
make[3]: Leaving directory `/mnt/lfs/sources/binutils-build/bfd/po'
make[3]: Entering directory `/mnt/lfs/sources/binutils-build/bfd'
make[3]: Nothing to be done for `info-am'.
make[3]: Leaving directory `/mnt/lfs/sources/binutils-build/bfd'
make[2]: *** [info-recursive] Error 1
make[2]: Leaving directory `/mnt/lfs/sources/binutils-build/bfd'
make[1]: *** [all-bfd] Error 2
make[1]: Leaving directory `/mnt/lfs/sources/binutils-build'
make: *** [all] Error 2
而我又换了2.17边本的重新编译了一下没有问题,这和我系统里的gcc还是glibc有关系吗?这是什么问题呢
还有在linux下的每个软件安装之前,源代码里面有对应的依赖关系说明吗?有对需要什么软件有说明吗?一直在源代码里面没找到
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 BigSnake.NET » 2008-08-21 19:12

人家说用 2.17 你就 2.17 吧。。。
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
aitilang
帖子: 1026
注册时间: 2007-04-28 21:38
送出感谢: 0
接收感谢: 0

#3

帖子 aitilang » 2008-08-21 19:30

要看更前面一点的错误信息
thinkpad x61 2G DDR no cdrom
--------------------------------------------
ABS学习中
sed学习中
awk学习中
perl学习中
新手描述不清,老手猜测不到,胡乱指挥一通,后果难以预料
头像
tommy007
帖子: 1352
注册时间: 2007-02-18 0:42
送出感谢: 0
接收感谢: 10 次

#4

帖子 tommy007 » 2008-08-22 4:01

有些东西版本是不能乱换的
各位玩amarok的朋友记得去玩玩last.fm啊,一个很特别的的网站。我把它当作音乐统计器用的(last.fm不是在线听歌的网站)
偶的Last.fm
头像
HuntXu
论坛版主
帖子: 5776
注册时间: 2007-09-29 3:09
送出感谢: 0
接收感谢: 6 次

#5

帖子 HuntXu » 2008-08-22 18:05

2.18过了的飘过...dev的已经用2.18了啊...
我当时乱用新的... :oops: 只有gcc4.3少了两个依赖装不上,其他都成功了的~
HUNT Unfortunately No Talent...
回复

回到 “老旧版本支持”