[已解决]ubuntu8.04编辑fstab后无法写入NTFS分区(已安装ntfs-3g并在fstab中使用)

为当前最终发行版之前的所有版本提供支持
回复
猫法师
帖子: 6
注册时间: 2008-08-14 20:10
送出感谢: 0
接收感谢: 0

[已解决]ubuntu8.04编辑fstab后无法写入NTFS分区(已安装ntfs-3g并在fstab中使用)

#1

帖子 猫法师 » 2008-08-22 15:29

我使用wubi安装的UBUNTU8.04,本来安装完以后系统自己就可以读写NTFS分区,具体就是在位置中打开分区,就会自己挂载 上并且可以正常读写,但是这个样子每次开机先点击的分区就是disk,第 二个就是disk-1,目录的名字是不一定的,这样会使 起动器的链接失效,于是我就按照网上的方式编辑/etc/fstab,但是这样以后开机可以自动挂载,但是却发现NTFS分区只能读不能写,打家看看怎么回事?
我已经安装了NTFS-3g
root@mfs666-desktop:/home/mfs666# sudo apt-get install ntfs-3g
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
ntfs-3g 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。

这是我的fstab文件内容:
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
/host/ubuntu/disks/root.disk / ext3 loop,errors=remount-ro 0 1
/host/ubuntu/disks/boot /boot none bind 0 0
/host/ubuntu/disks/swap.disk none swap loop,sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/sda7 /media/F: ntfs-3g defaults,locale=zh_CN.UTF-8 0 0
/dev/sda6 /media/E: ntfs-3g defaults,locale=zh_CN.UTF-8 0 0
/dev/sda8 /media/G: ntfs-3g defaults,locale=zh_CN.UTF-8 0 0
/dev/sda5 /media/D: ntfs-3g defaults,locale=zh_CN.UTF-8 0 0
/dev/sda1 /media/C: ntfs-3g defaults,locale=zh_CN.UTF-8 0 0

我的硬盘是西部数据的SATA硬盘,所有分区都是NTFS,ubuntu由 wubi在windows下安装。
希望能帮忙,谢谢!
上次由 猫法师 在 2008-08-23 15:32,总共编辑 1 次。
头像
steley
帖子: 538
注册时间: 2008-06-14 11:00
系统: ubuntu
来自: sunl@riseup.net
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 steley » 2008-08-22 15:47

这是我的!!!
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda9
UUID=bca6ef51-ec41-4be1-862d-eafabac4d0f9 / ext3 relatime,error
s=remount-ro 0 1
# /dev/sda8
UUID=b7977a05-cb16-4ce7-92ff-8c766e12018a /boot ext3 relatime
0 2
# /dev/sda10
UUID=b2d7692a-d46c-4f4d-9c9d-3f648eae4101 /home ext3 relatime
0 2
# /dev/sda7
UUID=e18be6ce-abc4-44ae-a1ba-0c0ed1e10269 none swap sw
0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/sda6 /mnt/Media ntfs utf8,umask=000 0 0
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 想入非非 » 2008-08-23 3:41

建议LZ安装一个NTFS-3g的前端,
sudo apt-get install ntfs-config
安装玩之后,在系统工具里面可以找到
作相应的配置就行了。。。。 8)
Ubuntu User
头像
gamespy
帖子: 126
注册时间: 2007-02-22 18:20
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 gamespy » 2008-08-23 10:26

defaults前面加一个user,
猫法师
帖子: 6
注册时间: 2008-08-14 20:10
送出感谢: 0
接收感谢: 0

#5

帖子 猫法师 » 2008-08-23 15:32

4楼的方法管用了,非常感谢,不过就是不知道原理是什么。
回复

回到 “老旧版本支持”