大家帮帮我好吗 ?显示有问题

为当前最终发行版之前的所有版本提供支持
回复
laozi888
帖子: 28
注册时间: 2007-12-03 11:37
送出感谢: 0
接收感谢: 0

大家帮帮我好吗 ?显示有问题

#1

帖子 laozi888 » 2008-08-26 10:09

我装的是双系统,昨天晚上开机箱把一个网卡动了一下,然后 再开机进入ubuntu,弹出 一个对话框显示video card 显示只能显示低分辨率,当时没太在意,胡乱把对话框关闭了,也没太在意对话框的内容,随后我的恶梦就来了。进入ubuntu后,屏幕显示不正常,估计比480*680还不如。
我估计是显卡设置的问题,但是我不知道该如何设置,大家帮帮我好吗??? :cry: :cry: :cry: :cry: :cry:
头像
qiang_liu8183
论坛版主
帖子: 10675
注册时间: 2006-09-10 22:36
来自: 北京
送出感谢: 1 次
接收感谢: 6 次

#2

帖子 qiang_liu8183 » 2008-08-26 10:14

有点诡异哦,动网卡怎么可能影响分辨率,楼主想想之前是不是更新过什么东西
看破、放下、自在、随缘、念佛
真诚、清净、平等、正觉、慈悲
头像
JangMunho
帖子: 1347
注册时间: 2006-01-18 12:55
来自: 也许真的没有人理解
送出感谢: 0
接收感谢: 1 次

#3

帖子 JangMunho » 2008-08-26 10:18

动网卡的时候把显卡碰松了,这事常有,现象都和你这差不多……
图片
MacBook Pro 15" User
Cocoa Programmer
头像
forsearch
帖子: 105
注册时间: 2008-05-17 18:36
送出感谢: 0
接收感谢: 0

#4

帖子 forsearch » 2008-08-26 10:20

进入恢复模式,就是 启动菜单的recovery mode
1. cd /etc/X11
2. ls -la xorg.conf*
3. 找到显示正常的时候的那个xorg.conf.xxxx
4. cp xorg.conf xorg.conf.bad
5. cp xorg.conf.xxxx xorg.conf
6. 重启
laozi888
帖子: 28
注册时间: 2007-12-03 11:37
送出感谢: 0
接收感谢: 0

#5

帖子 laozi888 » 2008-08-26 11:10

forsearch 写了:进入恢复模式,就是 启动菜单的recovery mode
1. cd /etc/X11
2. ls -la xorg.conf*
3. 找到显示正常的时候的那个xorg.conf.xxxx
4. cp xorg.conf xorg.conf.bad
5. cp xorg.conf.xxxx xorg.conf
6. 重启
谢谢你
按照网上的改法,我改了一下xorg.conf,下面是我的xorg.conf 文件,大家看一看有什么文题么 ?

代码: 全选

Section "Device"
	Identifier	"Configured Video Device"
	Boardname	"vesa"
	Busid		"PCI:0:2:0"
	Driver		"vesa"
	Screen	0
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
	Vendorname	"Generic LCD Display"
	Modelname	"LCD Panel 1024x768"
	Horizsync	31.5-48.0
	Vertrefresh	56.0 - 65.0
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "1024x768@70" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
	Gamma	1.0
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"Configured Video Device"
	Monitor		"Configured Monitor"
	Defaultdepth	24
	SubSection "Display"
		Depth	24
		Modes		"1024x768@70"	"1024x768@70"	"800x600@56"	"640x480@60"
	EndSubSection
EndSection
头像
JangMunho
帖子: 1347
注册时间: 2006-01-18 12:55
来自: 也许真的没有人理解
送出感谢: 0
接收感谢: 1 次

#6

帖子 JangMunho » 2008-08-26 11:21

你就不会把显卡再插一遍吗,事物都是有因果关系的,你也不想想你的xorg.conf以前怎么没问题,自从动了网卡之后就出了问题,问题能出在xorg.conf身上吗。明显是因为你拆开了机箱。
真不知道你们这些人都是怎么想的。舍近求远,南辕北辙……
MacBook Pro 15" User
Cocoa Programmer
头像
luojie-dune
帖子: 22033
注册时间: 2007-07-30 18:28
系统: Linux
来自: 空气中
送出感谢: 9 次
接收感谢: 61 次

#7

帖子 luojie-dune » 2008-08-26 11:25

更有可能的是你升级了内核,没升级成功,开机时用老内核试试。
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议
头像
gamespy
帖子: 126
注册时间: 2007-02-22 18:20
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 gamespy » 2008-08-26 11:43

重启x试试,我有时候刚开机的分辨率也很低,重启一下x可能可以解决。
不过有可能登录程序会崩溃
回复

回到 “老旧版本支持”