[问题]请问:我内核升级了三四次了,为什么版本没变?还是2.6.24-19(非menu.lst问题)

为当前最终发行版之前的所有版本提供支持
iamcz
帖子: 11
注册时间: 2008-05-17 0:13
送出感谢: 0
接收感谢: 0

[问题]请问:我内核升级了三四次了,为什么版本没变?还是2.6.24-19(非menu.lst问题)

#1

帖子 iamcz » 2008-08-26 13:11

貌似听说早有2.6.24-20的版本了,怎么我升级不上去呢???
上次由 iamcz 在 2008-08-26 13:34,总共编辑 1 次。
shi-gy
帖子: 78
注册时间: 2007-06-30 10:17
送出感谢: 0
接收感谢: 0

#2

帖子 shi-gy » 2008-08-26 13:14

我在升级的时候有个选项,你选第一个就可以了
头像
luojie-dune
帖子: 22033
注册时间: 2007-07-30 18:28
系统: Linux
来自: 空气中
送出感谢: 9 次
接收感谢: 61 次

#3

帖子 luojie-dune » 2008-08-26 13:18

因为你的源的问题我用optus源也是没有换了internode就有了。
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议
头像
mir_lww
帖子: 192
注册时间: 2007-01-12 22:59
来自: GDUT
送出感谢: 0
接收感谢: 0

#4

帖子 mir_lww » 2008-08-26 13:23

是不是grub的配置文件的问题?
头像
jeffwei
帖子: 1344
注册时间: 2007-05-12 22:48
送出感谢: 0
接收感谢: 0

#5

帖子 jeffwei » 2008-08-26 13:24

貌似没有更新menu.lst
iamcz
帖子: 11
注册时间: 2008-05-17 0:13
送出感谢: 0
接收感谢: 0

#6

帖子 iamcz » 2008-08-26 13:26

jeffwei 写了:貌似没有更新menu.lst
不是的,新立得里看了只有一个内核被安装了
更新里只有2.6.24-19
提示可更新,可我用的就是2.6.24-19阿
上次由 iamcz 在 2008-08-26 13:32,总共编辑 1 次。
头像
luojie-dune
帖子: 22033
注册时间: 2007-07-30 18:28
系统: Linux
来自: 空气中
送出感谢: 9 次
接收感谢: 61 次

#7

帖子 luojie-dune » 2008-08-26 13:34

换源
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 想入非非 » 2008-08-26 15:45

可能就是源的问题。。。
看看目录/usr/src下又没有别的内核。。。 :cry:
Ubuntu User
头像
mir_lww
帖子: 192
注册时间: 2007-01-12 22:59
来自: GDUT
送出感谢: 0
接收感谢: 0

#9

帖子 mir_lww » 2008-08-26 19:11

2.6.24-21也早就有了,只不过个人认为不够稳定而已,所以装了也没有使用。我也还在用2.6.24-19(2.6.24-20也不够稳定)

或许你把问题说清楚一些吧。你是说新立德里只有2.6.24-19可以安装,还是装了新版本的内核,内核版本还是2.6.24-19?

截图?
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 想入非非 » 2008-08-26 23:02

mir_lww 写了:2.6.24-21也早就有了,只不过个人认为不够稳定而已,所以装了也没有使用。我也还在用2.6.24-19(2.6.24-20也不够稳定)

或许你把问题说清楚一些吧。你是说新立德里只有2.6.24-19可以安装,还是装了新版本的内核,内核版本还是2.6.24-19?

截图?
其实21已经相当稳定了。。。
Ubuntu User
iamcz
帖子: 11
注册时间: 2008-05-17 0:13
送出感谢: 0
接收感谢: 0

#11

帖子 iamcz » 2008-08-27 3:01

mir_lww 写了:2.6.24-21也早就有了,只不过个人认为不够稳定而已,所以装了也没有使用。我也还在用2.6.24-19(2.6.24-20也不够稳定)

或许你把问题说清楚一些吧。你是说新立德里只有2.6.24-19可以安装,还是装了新版本的内核,内核版本还是2.6.24-19?

截图?
就是我已经装了2.6.24-19了,一直用的也是2.6.24-19,别的内核也都删了,而且是新立得里完全删除的。可还更新2.6.24-19,更新了几次了,也不是每次更新都有。

一直用安装时候自带的那个主服务器的源。
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#12

帖子 dogfox » 2008-08-27 6:46

iamcz 写了:
一直用安装时候自带的那个主服务器的源。
这就是问题的关键所在
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
头像
mir_lww
帖子: 192
注册时间: 2007-01-12 22:59
来自: GDUT
送出感谢: 0
接收感谢: 0

#13

帖子 mir_lww » 2008-08-27 13:22

想入非非 写了:
mir_lww 写了:2.6.24-21也早就有了,只不过个人认为不够稳定而已,所以装了也没有使用。我也还在用2.6.24-19(2.6.24-20也不够稳定)

或许你把问题说清楚一些吧。你是说新立德里只有2.6.24-19可以安装,还是装了新版本的内核,内核版本还是2.6.24-19?

截图?
其实21已经相当稳定了。。。
只能说每个人对“稳定”的要求不同吧,我是个完美主义者....

2.6.24-21在我台机上挂起有点问题,而性能倒不觉得有多少改善.....
头像
tonyluj
帖子: 71
注册时间: 2008-08-21 20:28
来自: 青岛
送出感谢: 0
接收感谢: 0
联系:

Re: [问题]请问:我内核升级了三四次了,为什么版本没变?还是2.6.24-19(非menu.lst问题)

#14

帖子 tonyluj » 2008-08-27 21:55

iamcz 写了:貌似听说早有2.6.24-20的版本了,怎么我升级不上去呢???
查看自己已安装的内核

代码: 全选

 dpkg --get-selections|grep linux 
(列出来带有image的就是内核文件 )
手动更新内核

代码: 全选

sudo apt-get install linux-rt linux-headers-rt
我用的是realtime的 你可以根据情况 选择generic
台式机推荐rt的
详见http://forum.ubuntu.org.cn/viewtopic.php?t=101888
通常就会在开机时出现新内核 选择他启动
查看当前内核的方法

代码: 全选

uname -a 或 uname -r
头像
mir_lww
帖子: 192
注册时间: 2007-01-12 22:59
来自: GDUT
送出感谢: 0
接收感谢: 0

#15

帖子 mir_lww » 2008-08-29 12:11

今天也更新了2.6.24-19...开始也觉得奇怪....
原来用的是2.6.24-19-36,更新后是2.6.24-19-41,莫非lz是这种情况?
回复

回到 “老旧版本支持”