UBUNTU 8.04.1 SERVER 终端乱码

为当前最终发行版之前的所有版本提供支持
回复
daschina
帖子: 19
注册时间: 2008-08-29 18:49
送出感谢: 0
接收感谢: 0

UBUNTU 8.04.1 SERVER 终端乱码

#1

帖子 daschina » 2008-08-29 18:54

安装的时候选择的是简体中文,但是在终端下面,显示中文乱码了!有很多菱形的符号!

请教!
头像
chinesejerry
帖子: 510
注册时间: 2007-10-06 3:48
来自: 霍格沃茨魔法学校葛莱芬多学院
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 chinesejerry » 2008-08-29 19:14

安装zhcon,然后执行zhcon --utf8
Because...nobody really uses an operating system,
people use...programs...on their computer.
And the only mission in life of an operating system is to helps those programs run.
----Linus
头像
cnkilior
论坛版主
帖子: 4979
注册时间: 2007-08-05 17:40
送出感谢: 0
接收感谢: 5 次

#3

帖子 cnkilior » 2008-08-29 19:14

修改~/.bashrc(~./bash_profile)

添加

代码: 全选

export LANG=en_US
我是照rh9给你的代码。可以先在shell中试验一下,看

代码: 全选

man man
是否输出方块。不输出方块就可以保存到~/.bashrc
头像
dsj
帖子: 810
注册时间: 2008-08-21 20:26
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 dsj » 2008-08-29 21:22

首先安装zhcon:
$sudo apt-get install zhcon
这样我们可以通过启动zhcon来显示中文,但是此时不能直接输入zhcon,否则会黑屏,正确的做法是:
$zhcon –utf8 –drv=vga
这样就可以尽情享受文本界面了
软件交流群:17264279
图书分享群:18246379
互动社区:http://www.ubuntuchina.com/
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 想入非非 » 2008-08-30 2:23

zhcon不是很好用的说。。。
Ubuntu User
daschina
帖子: 19
注册时间: 2008-08-29 18:49
送出感谢: 0
接收感谢: 0

#6

帖子 daschina » 2008-08-30 10:30

除了ZHCON,有没有其他的解决方法?
头像
sevk
帖子: 2059
注册时间: 2007-05-08 16:26
系统: arch
来自: 火星内核某分子内某原子核内
送出感谢: 20 次
接收感谢: 6 次
联系:

#7

帖子 sevk » 2008-08-30 18:30

玩了一下,zhcon果然不好用。
笔记本 :
F208S : gentoo
A460P i3G D6 : UBUNTU + WIN7
UN43D1 : UBUNTU + WIN7
1000人超级QQ群 LINUX + WIN : 31465544 或 18210387
marble
帖子: 2
注册时间: 2008-08-08 10:35
送出感谢: 0
接收感谢: 0

Re: UBUNTU 8.04.1 SERVER 终端乱码

#8

帖子 marble » 2009-02-06 14:44

我也是这种情况,但是运行zhcon --utf8 --drv=vga以后出来了下面的提示:
============== I'm really sorry, but... ================
I can not open graphical device on this machine, this can happen when:
1. your kernel does not have framebuffer device enabled, check the output from `dmesg|grep vesa`
2. you are running on a non-i386 machine so no VGA support
3. you are running under X-Window but libggi is not compiled in (required for running zhcon under X-Window

是AMD64的原因还是宽屏显示器的原因?
哪位能帮忙解释一下?
cryhome
帖子: 1
注册时间: 2009-03-05 23:14
送出感谢: 0
接收感谢: 0

Re: UBUNTU 8.04.1 SERVER 终端乱码

#9

帖子 cryhome » 2009-04-02 17:06

1. sudo vim /root/.bashrc

在最后加入export LANG=zh.CN.GBK 保存退出

2.sudo locale-gen zh.CN.GBK

3.exit后重新登录
ub除名
帖子: 1
注册时间: 2010-03-30 16:24
送出感谢: 0
接收感谢: 0

Re: UBUNTU 8.04.1 SERVER 终端乱码

#10

帖子 ub除名 » 2010-03-30 16:27

:em02 告诉你们一个天大的秘密,方屏也不行,还有英特尔酷睿Q8300也不行!
头像
ol_beta
帖子: 31
注册时间: 2010-03-08 23:48
送出感谢: 0
接收感谢: 0
联系:

Re: UBUNTU 8.04.1 SERVER 终端乱码

#11

帖子 ol_beta » 2010-12-12 14:49

:em11
xinzhan
帖子: 3
注册时间: 2011-05-16 5:38
送出感谢: 0
接收感谢: 0

Re: UBUNTU 8.04.1 SERVER 终端乱码

#12

帖子 xinzhan » 2011-05-16 5:42

安装了zhcon 后直接在控制台下运行zhcon --tf8就可以了。
只是切换出的输入法只能是全拼了。
一切正常了
回复

回到 “老旧版本支持”