[问题]请教“不稳定(unstable)发行版”问题

为当前最终发行版之前的所有版本提供支持
回复
squirrel1976
帖子: 26
注册时间: 2007-12-04 22:16
送出感谢: 1 次
接收感谢: 0

[问题]请教“不稳定(unstable)发行版”问题

#1

帖子 squirrel1976 » 2008-08-30 10:07

我已经搜过很多帖子了,还没法解决,所以发帖询问。

我的8.04是从这个站点下载的
http://tw.releases.ubuntu.com/8.04/

安装后,把源改成cn99,系统也都update过。但我发现,安张软件时老是出现安装不了的问题,提示“不稳定(unstable)发行版”,而多数人都没有这种烦恼。我记得前些天装某个软件时就是费了九牛二虎之力换了很多源才成功。

昨天,我开始装smplayer,用

代码: 全选

sudo apt-get install smplayer
,结果提示:

代码: 全选

正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
Reading state information... 完成      
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  mplayer: 依赖: libgif4 (>= 4.1.6) 但是它将不会被安装
           依赖: ttf-dejavu 但是它将不会被安装
E: 无法安装的软件包
我的code32能装。不知道这种问题是否是我的系统不对?麻烦大家点拨一下。
头像
npnufn
帖子: 1845
注册时间: 2005-10-14 15:56
送出感谢: 0
接收感谢: 7 次

#2

帖子 npnufn » 2008-08-30 12:20

mplayer: 依赖: libgif4 (>= 4.1.6) 但是它将不会被安装
依赖: ttf-dejavu 但是它将不会被安装
如果你的源设置的没有问题的话(源完整可靠,是8.04的源而不是8.10的)
sudo apt-get install libgif4 ttf-dejavu
yunio:又一个支持linux的云存储:链接 (非邀请链接)。
BCM4313驱动正常无法联网的解决:这里
plank:轻巧漂亮的dock 介绍在这里
头像
hethe
帖子: 3666
注册时间: 2005-08-01 9:14
送出感谢: 0
接收感谢: 0

#3

帖子 hethe » 2008-08-30 12:39

换个源或者多加个官方源
Gedanken ohne Inhalt sind leer .Anschauungen ohne Begriffe sind blind.
squirrel1976
帖子: 26
注册时间: 2007-12-04 22:16
送出感谢: 1 次
接收感谢: 0

#4

帖子 squirrel1976 » 2008-08-31 21:08

npnufn 写了:
mplayer: 依赖: libgif4 (>= 4.1.6) 但是它将不会被安装
依赖: ttf-dejavu 但是它将不会被安装
如果你的源设置的没有问题的话(源完整可靠,是8.04的源而不是8.10的)
sudo apt-get install libgif4 ttf-dejavu
hethe 写了:换个源或者多加个官方源
我的源是这个,对于8.04,对的吗:
deb http://ubuntu.cn99.com/ubuntu/ gutsy main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ gutsy-security main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ gutsy-updates main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ gutsy-proposed main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ gutsy-backports main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ gutsy main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ gutsy-security main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ gutsy-updates main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ gutsy-proposed main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ gutsy-backports main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu-cn/ gutsy main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ hardy multiverse universe
deb http://archive.ubuntu.org.cn/ubuntu-cn/ gutsy main restricted universe multiverse

deb http://ppa.launchpad.net/compiz/ubuntu hardy main
deb http://archive.ubuntu.com/ubuntu hardy universe multiverse
deb-src http://archive.ubuntu.com/ubuntu hardy universe multiverse
头像
luojie-dune
帖子: 22033
注册时间: 2007-07-30 18:28
系统: Linux
来自: 空气中
送出感谢: 9 次
接收感谢: 61 次

#5

帖子 luojie-dune » 2008-08-31 21:10

不对!!!!!!!!

你加的大多数后缀难道不是gusty? gusty是7.10

hardy才是8.04 这可能直接破坏你的系统!!!
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议
squirrel1976
帖子: 26
注册时间: 2007-12-04 22:16
送出感谢: 1 次
接收感谢: 0

#6

帖子 squirrel1976 » 2008-08-31 21:19

我前面那肯定错了 :cry:

我现在换这个源来update能不能改正错误呢?

deb http://tw.archive.ubuntu.com/ubuntu hardy main restricted universe multiverse
deb http://tw.archive.ubuntu.com/ubuntu hardy-security main restricted universe multiverse
deb http://tw.archive.ubuntu.com/ubuntu hardy-updates main restricted universe multiverse
deb http://tw.archive.ubuntu.com/ubuntu hardy-backports main restricted universe multiverse
deb http://tw.archive.ubuntu.com/ubuntu hardy-proposed main restricted universe multiverse
deb-src http://tw.archive.ubuntu.com/ubuntu hardy main restricted universe multiverse
deb-src http://tw.archive.ubuntu.com/ubuntu hardy-security main restricted universe multiverse
deb-src http://tw.archive.ubuntu.com/ubuntu hardy-updates main restricted universe multiverse
deb-src http://tw.archive.ubuntu.com/ubuntu hardy-backports main restricted universe multiverse
deb-src http://tw.archive.ubuntu.com/ubuntu hardy-proposed main restricted universe multiverse
squirrel1976
帖子: 26
注册时间: 2007-12-04 22:16
送出感谢: 1 次
接收感谢: 0

#7

帖子 squirrel1976 » 2008-08-31 21:22

luojie-dune 写了:不对!!!!!!!!

你加的大多数后缀难道不是gusty? gusty是7.10

hardy才是8.04 这可能直接破坏你的系统!!!
XD,为什么我在网上找的一些8.04源都是gusty呢?你看看这个连接:
http://www.linuxidc.com/Linux/2008-04/12108.htm
头像
solcomo
帖子: 2838
注册时间: 2007-04-25 13:12
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 solcomo » 2008-08-31 21:26

squirrel1976 写了:
luojie-dune 写了:不对!!!!!!!!

你加的大多数后缀难道不是gusty? gusty是7.10

hardy才是8.04 这可能直接破坏你的系统!!!
XD,为什么我在网上找的一些8.04源都是gusty呢?你看看这个连接:
http://www.linuxidc.com/Linux/2008-04/12108.htm
看wiki
别瞎找
♜♞♝♛♚♝♞♜
♟♟♟♟♟♟♟♟
♙♙♙♙♙♙♙♙
♖♘♗♕♔♗♘♖

☠☯⚔⚓☣☦☃☕
☹☻☪☭☬⚖⚛⚜
ℜℳℬ™ ℋℯℓ℘ ℳℭ
sƂɐʍ рǀɹoʍ əɥʇ oS
squirrel1976
帖子: 26
注册时间: 2007-12-04 22:16
送出感谢: 1 次
接收感谢: 0

#9

帖子 squirrel1976 » 2008-08-31 21:35

solcomo 写了:
squirrel1976 写了:
luojie-dune 写了:不对!!!!!!!!

你加的大多数后缀难道不是gusty? gusty是7.10

hardy才是8.04 这可能直接破坏你的系统!!!
XD,为什么我在网上找的一些8.04源都是gusty呢?你看看这个连接:
http://www.linuxidc.com/Linux/2008-04/12108.htm
看wiki
别瞎找
恩,谢谢各位xd,我换了hardy的源后,apt-get update和安装smplayer就对了。
再寒一下自己。
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 想入非非 » 2008-09-01 0:04

squirrel1976 写了:
npnufn 写了:
mplayer: 依赖: libgif4 (>= 4.1.6) 但是它将不会被安装
依赖: ttf-dejavu 但是它将不会被安装
如果你的源设置的没有问题的话(源完整可靠,是8.04的源而不是8.10的)
sudo apt-get install libgif4 ttf-dejavu
hethe 写了:换个源或者多加个官方源
我的源是这个,对于8.04,对的吗:
deb http://ubuntu.cn99.com/ubuntu/ gutsy main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ gutsy-security main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ gutsy-updates main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ gutsy-proposed main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ gutsy-backports main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ gutsy main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ gutsy-security main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ gutsy-updates main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ gutsy-proposed main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ gutsy-backports main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu-cn/ gutsy main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ hardy multiverse universe
deb http://archive.ubuntu.org.cn/ubuntu-cn/ gutsy main restricted universe multiverse

deb http://ppa.launchpad.net/compiz/ubuntu hardy main
deb http://archive.ubuntu.com/ubuntu hardy universe multiverse
deb-src http://archive.ubuntu.com/ubuntu hardy universe multiverse
这个。。。怎么能够瞎弄源呢?
幸亏没出什么大的问题。。。汗
Ubuntu User
回复

回到 “老旧版本支持”