添加删除程序中不能选择任何软件。

为当前最终发行版之前的所有版本提供支持
回复
lilei_new
帖子: 18
注册时间: 2006-08-08 10:12
送出感谢: 0
接收感谢: 0

添加删除程序中不能选择任何软件。

#1

帖子 lilei_new » 2008-08-30 19:37

法安装 'kbruch'

这个应用程序和已经安装的其他程序冲突。想要安装'kbruch' 冲突程序必须先删除。

切换到“新立得”包管理器来解决这个冲突。


进入“新立得”包管理器中蒙了不知道要干些什么!
头像
CLOCKWORKHEART
帖子: 635
注册时间: 2007-11-05 19:26
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 CLOCKWORKHEART » 2008-08-30 23:16

那就直接apt吧,终端下会给更多的提示信息。
Everything that has a beginning has an end.
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 想入非非 » 2008-08-31 0:01

yangfan@yangfan-laptop:~$ sudo apt-get -s install kbruch
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
将会安装下列额外的软件包:
kdeedu-data
建议安装的软件包:
kdeedu-doc-html khelpcenter
下列【新】软件包将被安装:
kbruch kdeedu-data
共升级了 0 个软件包,新安装了 2 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
Inst kdeedu-data (4:3.5.10-0ubuntu1~hardy1 Ubuntu:8.04/hardy-backports)
Inst kbruch (4:3.5.10-0ubuntu1~hardy1 Ubuntu:8.04/hardy-backports)
Conf kdeedu-data (4:3.5.10-0ubuntu1~hardy1 Ubuntu:8.04/hardy-backports)
Conf kbruch (4:3.5.10-0ubuntu1~hardy1 Ubuntu:8.04/hardy-backports)
我的好像没有什么问题阿。。。。
你运行一下

代码: 全选

sudo apt-get -s install kbruch
看看有什么输出?
Ubuntu User
lilei_new
帖子: 18
注册时间: 2006-08-08 10:12
送出感谢: 0
接收感谢: 0

我用apt还是不行

#4

帖子 lilei_new » 2008-08-31 11:21

lilei@ubuntu:~$ sudo apt-get -s install kbruch
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
kbruch: 依赖: kdelibs4c2a (>= 4:3.5.7-1) 但是它将不会被安装
E: 无法安装的软件包
lilei@ubuntu:~$
头像
luojie-dune
帖子: 22033
注册时间: 2007-07-30 18:28
系统: Linux
来自: 空气中
送出感谢: 9 次
接收感谢: 61 次

#5

帖子 luojie-dune » 2008-08-31 11:22

hardy-backports)
不支持
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议
头像
luojie-dune
帖子: 22033
注册时间: 2007-07-30 18:28
系统: Linux
来自: 空气中
送出感谢: 9 次
接收感谢: 61 次

#6

帖子 luojie-dune » 2008-08-31 11:29

设置出错。
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议
lilei_new
帖子: 18
注册时间: 2006-08-08 10:12
送出感谢: 0
接收感谢: 0

现在怎么办?

#7

帖子 lilei_new » 2008-08-31 11:40

现在怎么办?
最好能一步步详细点,先谢
头像
luojie-dune
帖子: 22033
注册时间: 2007-07-30 18:28
系统: Linux
来自: 空气中
送出感谢: 9 次
接收感谢: 61 次

#8

帖子 luojie-dune » 2008-08-31 11:44

换个源,新立得软件包管理器 里 关闭 backport 支持。
终端运行更新。
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议
lilei_new
帖子: 18
注册时间: 2006-08-08 10:12
送出感谢: 0
接收感谢: 0

#9

帖子 lilei_new » 2008-08-31 12:40

能写的傻瓜一点吗?看不懂啊!拜托了
回复

回到 “老旧版本支持”