[问题]装deb包的问题(自己解决了)

为当前最终发行版之前的所有版本提供支持
回复
头像
Bayes
帖子: 94
注册时间: 2008-08-28 16:58
送出感谢: 0
接收感谢: 0

[问题]装deb包的问题(自己解决了)

#1

帖子 Bayes » 2008-09-04 20:10

我的程序需要libtiff.so.3,但是我用的hardy中usr/lib中只有libtiff.so.4,而且做个链接也不行,还是报错: error while loading shared libraries: libtiff.so.3: wrong ELF class: ELFCLASS64

所以我想下个单独的libtiff3的deb包安装,但是下了后,系统不让我安装,说是“软件包的体系架构(i386)与本机系统的架构(amd64)不符“,谁知道有什么办法可以把libtiff.so.3安装上去阿??
上次由 Bayes 在 2008-09-04 22:04,总共编辑 1 次。
头像
bones7456
论坛版主
帖子: 8495
注册时间: 2006-04-12 20:05
来自: 杭州
送出感谢: 0
接收感谢: 8 次
联系:

#2

帖子 bones7456 » 2008-09-04 20:29

找个64位的包装上
关注我的blog: ε==3
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 想入非非 » 2008-09-04 21:22

好像又一个让64位系统安装32位软件的补丁。。。
什么来着
Ubuntu User
头像
Bayes
帖子: 94
注册时间: 2008-08-28 16:58
送出感谢: 0
接收感谢: 0

#4

帖子 Bayes » 2008-09-04 22:04

我自己解决了,用ldd发现应用程序需要的库文件,然后,网上下载库文件对应的deb文件。当然,这个deb文件是不能在64位系统上安装的,extract出相应的库文件,拷贝到usr/lib32目录下,搞定一切。
希望对后来者有用。
basncy
帖子: 315
注册时间: 2009-11-19 10:40
送出感谢: 0
接收感谢: 1 次

Re: [问题]装deb包的问题(自己解决了)

#5

帖子 basncy » 2010-05-20 14:19

楼主是怎么找到那个deb 文件的?能否给个方法?
我和你一样报错
error while loading shared libraries: libtiff.so.3: wrong ELF class: ELFCLASS64
回复

回到 “老旧版本支持”