[问题]linux-image-2.6.24-19-generic_2.6.24-19.41_i386.deb无法更新

为当前最终发行版之前的所有版本提供支持
回复
z89126220
帖子: 40
注册时间: 2008-09-09 11:44
送出感谢: 0
接收感谢: 0

[问题]linux-image-2.6.24-19-generic_2.6.24-19.41_i386.deb无法更新

#1

帖子 z89126220 » 2008-09-10 18:17

出现下面错误提示:
E: /var/cache/apt/archives/linux-image-2.6.24-19-generic_2.6.24-19.41_i386.deb: 无法在安装新的版本前,为“./boot/vmlinuz-2.6.24-19-generic”做一个符号链接备份

我想问下这个是什么更新文件,具体有什么作用,重要吗(好像是内核?)

如果很重要的话请问如何解决?
头像
rosechild
帖子: 306
注册时间: 2007-06-16 15:10
送出感谢: 0
接收感谢: 0

Re: [问题]linux-image-2.6.24-19-generic_2.6.24-19.41_i386.deb无法更新

#2

帖子 rosechild » 2008-10-14 17:06

same here
赤之湖
帖子: 204
注册时间: 2008-09-25 19:57
送出感谢: 0
接收感谢: 0

Re: [问题]linux-image-2.6.24-19-generic_2.6.24-19.41_i386.deb无法更新

#3

帖子 赤之湖 » 2008-10-14 19:56

解决方法:

sudo rm -fv /boot/initrd.img-2.6.24*.bak
sudo rm -fv /boot/vmlinuz-2.6.24-19-generic
sudo rm -fv /boot/initrd.img-2.6.24-19-generic
sudo rm -fv /boot/config-2.6.24-19-generic
sudo rm -fv /boot//abi-2.6.24-19-generic
sudo rm -fv /boot/System.map-2.6.24-19-generic

即可!然后就能正确更新!

网上搜到的方法,管用,但不知其所以然
回复

回到 “老旧版本支持”