当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]弄了两天了,快疯啦!帮帮忙啊。。
帖子发表于 : 2008-09-10 20:49 

注册: 2008-08-12 14:58
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
弄了两天了,快疯了,帮帮忙啊!!
其实这可能算是一个很基本的东西,可我弄了两天了还没好!对了,就是那该死的网络设置,这两天,论坛,google,百度,N种可行性方法我都试过了,就是不行啊,望哪位能帮我指导啊,不知道是我某一步骤给略掉了,还是咋的?总之,就是连不上了网!
昨天还神经的,在网络设置里面用“dhcp”和漫游模式,之间来回的切换,居然能短暂的连上网,之后就再也不行了!
那位热心的能QQ我,帮我详细指导下么?谢谢啊,感激不尽!
qq524396959
对了,我们是校园网,网通,上网要安装插件。


详细再写下问题:

1、上个星期安装完Ubuntu8.04 LTS ,还没有设置任何东西,自然就能上网,(让我很惊讶!)
2、为了学linux基本设置,我尝试自己动手进行网络设置,学校用的是拨号上网的(用户名,密码+上网插件),所以选择,终端——sudo pppoeconf——接着用户名,密码——一路yes下去
3、打开右上角“网络设置”,有线连接设置为自动DHCP
4、不能上网了!郁闷,尝试注销,重启看能否有所起色,依然不行
5、终端——sudo gedit /etc/network/interfaces——按照网上的说法改成
auto lo
auto lo inet loopback
auto eth0
auto etho inet dhcp
还是不行。。。
6、经过一番折腾,也不知道什么原因,(我刚接触Ubuntu的),就按网上,论坛的说法都不行
7、现在就是想能不能哪位类似的网络的帮我发一份/etc/network/interfaces里面的设置信息给我好吗?(网络2
中有)可以邮箱和qq都行啊,xiaozhi2159@126.com谢谢啊


最后由 canliufeng 编辑于 2008-09-11 10:40,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-09-10 21:12 

注册: 2007-10-24 14:51
帖子: 87
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
或许可参照以下方式排查问题:
(1)若以前用Windows能正常上网,则说明软硬件都没有问题。若要求802.1X认证,可在google或百度上搜一下,以前好像见过网友相关的帖子,解决Ubuntu下的802.1X认证。若肯定是802.1X认证问题,则不用参考(2)。另外,我总是关闭“漫游模式”,因为一用就上不了网。
(2)若不能排除硬件或软件问题,可将你的PC与另一PC网卡直连,设上同一网段的IP地址,如192.168.1.1/255.255.255.0, 192.168.1.2/255.255.255.0,不用设网关,互ping一下看是否通(若怀疑网卡不支持自适应,可将直通线换为反绞线),以确定软硬件是否有问题。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-09-10 22:53 

注册: 2008-05-24 8:30
帖子: 1453
送出感谢: 2
接收感谢: 30
我也曾经遇到过不能连网的问题(完全不能连网,不只是不能上 Internet)。当是 Google 到一种情况,有些网卡在 Windows 下禁用了 Wake on LAN 时,再进入 Ubuntu 就会无法激活网卡了。拔掉计算机电源几分钟后再开机进入 Ubuntu 就可以了。网上提供的解决办法是在 Windows 下启用 Wake on LAN。
我没有一一试,但我当时确实是在 Windows 下启用 Wake on LAN,进入 Ubuntu 下再用那个网络连接图标激活了网卡。
楼主看看是不是这种问题。


最后由 aerofox 编辑于 2008-09-11 14:01,总共编辑了 1 次

页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-09-10 23:00 

注册: 2008-08-12 14:58
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
aerofox 写道:
我也曾经遇到过不能连网的问题(完全不能连网,不只是不能上 Internet)。当是 Google 到一种情况,有些网卡在 Windows 下禁用了 Wake on LAN 时,再进入 Ubuntu 就会无法激活网卡了。插掉计算机电源几分钟后再开机进入 Ubuntu 就可以了。网上提供的解决办法是在 Windows 下启用 Wake on LAN。
我没有一一试,但我当时确实是在 Windows 下启用 Wake on LAN,进入 Ubuntu 下再用那个网络连接图标激活了网卡。
楼主看看是不是这种问题。


啊,真的是这样么?我以前是可以上网的,后来记不清是我设置了啥,还是突然就变得不能上了。
要是那样如何在windows下启用Wake on LAN?谢谢!


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-09-10 23:01 

注册: 2008-08-12 14:58
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
Guanglin.Du 写道:
或许可参照以下方式排查问题:
(1)若以前用Windows能正常上网,则说明软硬件都没有问题。若要求802.1X认证,可在google或百度上搜一下,以前好像见过网友相关的帖子,解决Ubuntu下的802.1X认证。若肯定是802.1X认证问题,则不用参考(2)。另外,我总是关闭“漫游模式”,因为一用就上不了网。
(2)若不能排除硬件或软件问题,可将你的PC与另一PC网卡直连,设上同一网段的IP地址,如192.168.1.1/255.255.255.0, 192.168.1.2/255.255.255.0,不用设网关,互ping一下看是否通(若怀疑网卡不支持自适应,可将直通线换为反绞线),以确定软硬件是否有问题。

应该不是啊,以前是可以上的。。。郁闷,还是谢谢啊


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-09-10 23:09 

注册: 2005-10-04 19:38
帖子: 117
送出感谢: 0 次
接收感谢: 0 次
楼主要写一下你这两天都是怎么试的?你在windows下是怎么上网的?是否自动获取IP?网关是多少?有没有拨号?
把问题写清楚,很多人就能看出来你是什么问题了。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-09-11 0:54 
头像

注册: 2008-07-14 22:42
帖子: 8078
地址: Beijing
送出感谢: 0 次
接收感谢: 0 次
校园网一般都是静态ip吧。。。。


_________________
Ubuntu User


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-09-11 14:01 

注册: 2008-05-24 8:30
帖子: 1453
送出感谢: 2
接收感谢: 30
canliufeng 写道:
啊,真的是这样么?我以前是可以上网的,后来记不清是我设置了啥,还是突然就变得不能上了。
要是那样如何在windows下启用Wake on LAN?谢谢!


控制面板中找吧。我想应该是在电源选项中吧,记不清楚了,你找找看吧。

你可以现试试拔掉电源一会儿的方法。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Sogou [Spider] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译