关于alien的安装问题. 里面没有 configure

为当前最终发行版之前的所有版本提供支持
回复
沉沦为奴
帖子: 17
注册时间: 2008-05-11 22:57
送出感谢: 0
接收感谢: 0

关于alien的安装问题. 里面没有 configure

#1

帖子 沉沦为奴 » 2008-09-18 21:54

我是校园网,要用Drcom,现在找到了Drcom.rpm,要转化为.deb格式,需要alien.
下载来了alien_8.53.tar.gz.

解压:tar zxvf alien_8.53.tar.gz
cd alien

然后,./configure .可是文件包里没有啊..这..如何是好啊......
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 想入非非 » 2008-09-18 22:35

代码: 全选

sudo apt-get install alien fakeroot
fakeroot alien ./*deb
不过你好像不能上网? :oops:
Ubuntu User
hongyeing
帖子: 52
注册时间: 2008-09-18 9:46
送出感谢: 0
接收感谢: 0

#3

帖子 hongyeing » 2008-09-18 23:02

额。。我也是学生,也有通样的问题啊。就是因为没网上,才不得不从别人那里下东西,拷进来,不然也不用这么麻烦了啊 。。。



怎么办~怎么办~~?网上都搜遍了啊。没办法解决。。
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 想入非非 » 2008-09-18 23:56

这个错了,不好意思

代码: 全选

fakeroot alien ./*deb

代码: 全选

fakeroot alien ./*.rpm
可以先到别人的机子上安装之后到
/var/cache/apt/archives
找到相应的deb包安装就行了 :cry:
Ubuntu User
hongyeing
帖子: 52
注册时间: 2008-09-18 9:46
送出感谢: 0
接收感谢: 0

#5

帖子 hongyeing » 2008-09-19 0:13

谢谢,答复~我试试~


PS:有人这么快答复,是幸福的感觉~
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

Re: 关于alien的安装问题. 里面没有 configure

#6

帖子 stlxv » 2008-09-19 6:21

沉沦为奴 写了:我是校园网,要用Drcom,现在找到了Drcom.rpm,要转化为.deb格式,需要alien.
下载来了alien_8.53.tar.gz.

解压:tar zxvf alien_8.53.tar.gz
cd alien

然后,./configure .可是文件包里没有啊..这..如何是好啊......
你还是用源代码自己编译吧……

先装上这些包(用WINDOWS从源的网站下载)然后就可以编译了 - -!
binutils-static_2.18.1~cvs20080103-0ubuntu1_i386.deb
busybox-initramfs_1%3a1.1.3-5ubuntu12_i386.deb
coreutils_6.10-3ubuntu2_i386.deb
cpio_2.9-6ubuntu1_i386.deb
gcc-4.2-base_4.2.3-2ubuntu7_i386.deb
initramfs-tools_0.85eubuntu39.2_all.deb
klibc-utils_1.5.7-4ubuntu4_i386.deb
libacl1_2.2.45-1_i386.deb
libattr1_1%3a2.4.39-1_i386.deb
libc6_2.7-10ubuntu3_i386.deb
libgcc1_1%3a4.2.3-2ubuntu7_i386.deb
libgpmg1_1.19.6-25ubuntu1_i386.deb
libklibc_1.5.7-4ubuntu4_i386.deb
libncurses5_5.6+20071124-1ubuntu2_i386.deb
libpam0g_0.99.7.1-5ubuntu6.1_i386.deb
libpam-runtime_0.99.7.1-5ubuntu6.1_all.deb
libselinux1_2.0.55-0ubuntu4_i386.deb
linux-generic_2.6.24.21.23_i386.deb
linux-headers-2.6.24-21_2.6.24-21.42_all.deb
linux-headers-2.6.24-21-generic_2.6.24-21.42_i386.deb
linux-headers-generic_2.6.24.21.23_i386.deb
linux-image-2.6.24-21-generic_2.6.24-21.42_i386.deb
linux-image-generic_2.6.24.21.23_i386.deb
linux-restricted-modules-2.6.24-21-generic_2.6.24.14-21.48_i386.deb
linux-restricted-modules-common_2.6.24.14-21.48_all.deb
linux-restricted-modules-generic_2.6.24.21.23_i386.deb
linux-ubuntu-modules-2.6.24-21-generic_2.6.24-21.32_i386.deb
lsb-base_3.2-4ubuntu1_all.deb
module-init-tools_3.3-pre11-4ubuntu5_i386.deb
ncurses-bin_5.6+20071124-1ubuntu2_i386.deb
nvidia-kernel-common_20051028+1ubuntu8_all.deb
sed_4.1.5-5_i386.deb
PHP是最好的语言!不服来战!
回复

回到 “老旧版本支持”