ubuntu8.04nfs服务时提示:mount.nfs: access denied by server ...

为当前最终发行版之前的所有版本提供支持
lamehu
帖子: 6
注册时间: 2008-09-25 9:01
送出感谢: 0
接收感谢: 0

ubuntu8.04nfs服务时提示:mount.nfs: access denied by server ...

#1

帖子 lamehu » 2008-09-25 10:39

我的主机IP是192.168.0.196,想测试一下本机的nfs服务,mount时出现以下提示
sudo mount -t nfs 192.168.0.196:/QT2440/root /mnt
mount.nfs: access denied by server while mounting 192.168.0.196:/QT2440/root

/etc/exports中:
/QT2440/root 192.168.0.*(rw,sync,no_root_squash,no_subtree_check)
showmount -e :
Export list for hujunli-desktop:
/QT2440/root 192.168.0.*
在论坛里也看到了有人提类似的问题,但是没有解答。
我以前也测试过nfs,是可以的。但是今天测试时却出现了上面“ access denied ”的提示,请问各位这是哪里出了问题?
ben123
帖子: 13
注册时间: 2008-09-26 19:40
送出感谢: 0
接收感谢: 0

Re: ubuntu8.04nfs服务时提示:mount.nfs: access denied by server ...

#2

帖子 ben123 » 2008-10-26 13:02

我也是这个问题阿。有人能帮忙解决一下马?楼上的解决了没?
wuhua0904
帖子: 16
注册时间: 2007-10-29 23:20
来自: 浙江宁波
送出感谢: 0
接收感谢: 0
联系:

Re: ubuntu8.04nfs服务时提示:mount.nfs: access denied by server ...

#3

帖子 wuhua0904 » 2008-11-06 12:50

同问,偶也有此问题!
themyth
帖子: 67
注册时间: 2007-08-23 21:17
送出感谢: 0
接收感谢: 0

Re: ubuntu8.04nfs服务时提示:mount.nfs: access denied by server ...

#4

帖子 themyth » 2008-11-08 21:18

同样,请高手答疑!!! :em05
不过,我这个问题本机mount没有问题,其他机子mount发现同样的问题!
头像
sy_lixiang
帖子: 15
注册时间: 2008-09-30 6:40
送出感谢: 0
接收感谢: 0
联系:

Re: ubuntu8.04nfs服务时提示:mount.nfs: access denied by server ...

#5

帖子 sy_lixiang » 2008-11-17 14:19

关注。。。这个问题 今天 遇到,没有解决。。。
sciedu
帖子: 2
注册时间: 2008-11-18 17:18
送出感谢: 0
接收感谢: 0

Re: ubuntu8.04nfs服务时提示:mount.nfs: access denied by server ...

#6

帖子 sciedu » 2008-11-18 17:26

配置好了NFS Server Share,执行sudo mount x.x.x.x:/yyy /yyy时遇到如下错误:

代码: 全选

mount: wrong fs type, bad option, bad superblock on x.x.x.x:/yyy,
       missing codepage or helper program, or other error
       (for several filesystems (e.g. nfs, cifs) you might
       need a /sbin/mount.<type> helper program)
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

安装nfs-common

代码: 全选

sudo apt-get install nfs-common
再次执行sudo mount x.x.x.x:/yyy /yyy,遇到如下错误:

代码: 全选

mount.nfs: access denied by server while mounting x.x.x.x:/yyy 
执行如下后,我的OK了

代码: 全选

sudo /etc/init.d/portmap restart
sudo /etc/init.d/nfs-common restart
如果还是不行,在Server端,share时设置root对应的用户名

代码: 全选

share -F nfs -o rw=@y.y.y.y/32,root=你的Ubuntu的用户名 /yyy
hemoparrot
帖子: 4
注册时间: 2007-11-18 12:35
送出感谢: 0
接收感谢: 0

Re: ubuntu8.04nfs服务时提示:mount.nfs: access denied by server ...

#7

帖子 hemoparrot » 2008-11-24 12:36

我认为错误是:当你通过本机挂载的时候,它认为本机ip是:127.0.0.1 不在允许ip范围之内,所以进制访问(access denied)。
因为我将访问的ip改为*之后就好了。(注意只有一个*,而不是192.168.0.*或其它)
040230125hit
帖子: 7
注册时间: 2008-01-06 11:44
送出感谢: 0
接收感谢: 0

Re: ubuntu8.04nfs服务时提示:mount.nfs: access denied by server ...

#8

帖子 040230125hit » 2008-12-08 13:09

sciedu 写了:配置好了NFS Server Share,执行sudo mount x.x.x.x:/yyy /yyy时遇到如下错误:

代码: 全选

mount: wrong fs type, bad option, bad superblock on x.x.x.x:/yyy,
       missing codepage or helper program, or other error
       (for several filesystems (e.g. nfs, cifs) you might
       need a /sbin/mount.<type> helper program)
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

安装nfs-common

代码: 全选

sudo apt-get install nfs-common
再次执行sudo mount x.x.x.x:/yyy /yyy,遇到如下错误:

代码: 全选

mount.nfs: access denied by server while mounting x.x.x.x:/yyy 
执行如下后,我的OK了

代码: 全选

sudo /etc/init.d/portmap restart
sudo /etc/init.d/nfs-common restart
如果还是不行,在Server端,share时设置root对应的用户名

代码: 全选

share -F nfs -o rw=@y.y.y.y/32,root=你的Ubuntu的用户名 /yyy
我也是lz这个问题,重启服务也没用,请问最后一步的具体做法是什么?
ruffer
帖子: 1
注册时间: 2009-03-03 22:22
送出感谢: 0
接收感谢: 0

Re: ubuntu8.04nfs服务时提示:mount.nfs: access denied by server ...

#9

帖子 ruffer » 2009-05-17 18:25

7 楼说的正确 :em11 ,刚按你方法试过了,改成*可以。多谢!!
dysunset
帖子: 7
注册时间: 2009-03-17 19:01
送出感谢: 0
接收感谢: 0

Re: ubuntu8.04nfs服务时提示:mount.nfs: access denied by server ...

#10

帖子 dysunset » 2009-06-02 21:59

hemoparrot 写了:我认为错误是:当你通过本机挂载的时候,它认为本机ip是:127.0.0.1 不在允许ip范围之内,所以进制访问(access denied)。
因为我将访问的ip改为*之后就好了。(注意只有一个*,而不是192.168.0.*或其它)
七楼的,人才啊!
我按此方法成功!同志们,跟上。。。。。。
头像
微风成长
帖子: 644
注册时间: 2008-12-14 18:43
送出感谢: 0
接收感谢: 0
联系:

Re: ubuntu8.04nfs服务时提示:mount.nfs: access denied by server ...

#11

帖子 微风成长 » 2009-10-31 13:05

7楼实属馊主意。

如果像7楼说的那样做,就相当于把权限赋给了全世界,达不到只有特定范围IP访问的效果。
所以得用一种新的方法:用192.168.1.0/24代替192.168.1.*就可以实现跟原来的设置一模一样的效果,而且免去把权限赋给全世界这种馊办法了。
上次由 微风成长 在 2010-02-23 8:55,总共编辑 4 次。
头像
微风成长
帖子: 644
注册时间: 2008-12-14 18:43
送出感谢: 0
接收感谢: 0
联系:

Re: ubuntu8.04nfs服务时提示:mount.nfs: access denied by server ...

#12

帖子 微风成长 » 2009-10-31 13:22

7楼实属馊主意。

如果像7楼说的那样做,就相当于把权限赋给了全世界,达不到只有特定范围IP访问的效果。
所以得用一种新的方法:用192.168.1.0/24代替192.168.1.*就可以实现跟原来的设置一模一样的效果,而且免去把权限赋给全世界这种馊办法了。
上次由 微风成长 在 2010-02-23 8:55,总共编辑 3 次。
头像
zesu
帖子: 8
注册时间: 2009-01-10 0:00
送出感谢: 0
接收感谢: 0

Re: ubuntu8.04nfs服务时提示:mount.nfs: access denied by server ...

#13

帖子 zesu » 2009-11-19 0:40

很显然,我已经遇到了换成*也不行到情况。 :em20
头像
微风成长
帖子: 644
注册时间: 2008-12-14 18:43
送出感谢: 0
接收感谢: 0
联系:

Re: ubuntu8.04nfs服务时提示:mount.nfs: access denied by server ...

#14

帖子 微风成长 » 2009-11-19 0:50

7楼实属馊主意。

如果像7楼说的那样做,就相当于把权限赋给了全世界,达不到只有特定范围IP访问的效果。
所以得用一种新的方法:用192.168.1.0/24代替192.168.1.*就可以实现跟原来的设置一模一样的效果,而且免去把权限赋给全世界这种馊办法了。
上次由 微风成长 在 2010-02-23 8:56,总共编辑 3 次。
头像
微风成长
帖子: 644
注册时间: 2008-12-14 18:43
送出感谢: 0
接收感谢: 0
联系:

Re: ubuntu8.04nfs服务时提示:mount.nfs: access denied by server ...

#15

帖子 微风成长 » 2009-11-19 0:54

7楼实属馊主意。

如果像7楼说的那样做,就相当于把权限赋给了全世界,达不到只有特定范围IP访问的效果。
所以得用一种新的方法:用192.168.1.0/24代替192.168.1.*就可以实现跟原来的设置一模一样的效果,而且免去把权限赋给全世界这种馊办法了。
上次由 微风成长 在 2010-02-23 8:56,总共编辑 3 次。
回复

回到 “老旧版本支持”