Qt4安装问题

为当前最终发行版之前的所有版本提供支持
回复
snowwoods
帖子: 14
注册时间: 2008-03-27 12:35
送出感谢: 0
接收感谢: 0

Qt4安装问题

#1

帖子 snowwoods » 2008-09-27 10:28

之前有用新立得安装过qt3 ,最近想安装qt4 ,可老出现
libqt4-dev:
依赖: libglib2.0-dev 但是此软件包将不会被安装

然后查找libglib2-dev,想安装这个,又有

libglib2.0-dev:
依赖: libglib2.0-0 (=2.16.4-0ubuntu2) 但是将会安装 2.16.4-0ubuntu3

这个问题……
再查找libgllib2.0-0,发现如果要重装这个包的话得要删除
alacarte 将被删除
apport-gtk 将被删除
apturl 将被删除
at-spi 将被删除
avahi-daemon 将被删除
bluez-audio 将被删除
bluez-cups 将被删除
bluez-gnome 将被删除
bluez-utils 将被删除
brasero 将被删除
brltty-x11 将被删除
bug-buddy 将被删除
capplets-data 将被删除
compiz 将被删除
compiz-fusion-plugins-extra 将被删除
compiz-fusion-plugins-main 将被删除
compiz-gnome 将被删除
compiz-plugins 将被删
……
等等一堆东西,不敢随便删,想问下有什么办法才能装QT4
头像
dsj
帖子: 810
注册时间: 2008-08-21 20:26
送出感谢: 0
接收感谢: 0
联系:

Re: Qt4安装问题

#2

帖子 dsj » 2008-09-27 11:40

Ubuntu Linux下配置Qt4的步骤(我的Ubuntu是8.04版):



1、请在你的电脑里或虚拟机里安装好Ubuntu 8.04版。



2、改源并更新,详细操作请参考wiki.ubuntu.org.cn上面的“快速配置指南”。



3、请不要按捺不住热切的心情安装任何软件更新。



4、启动终端,命令:sudo apt-get install build-essential



5、等待。



6、sudo apt-get install qt4-dev-tools qt4-doc qt4-qtconfig qt4-demos qt4-designer



7、继续等待并祈祷。



8、你要用QDevelop的话就sudo apt-get install qdevelop吧。



9、如果你用QDevelop的话,就直接启动它,第一页的环境变量设置应该是已经被设置好的,直接确定过去就行。然后尽情地coding吧!
软件交流群:17264279
图书分享群:18246379
互动社区:http://www.ubuntuchina.com/
snowwoods
帖子: 14
注册时间: 2008-03-27 12:35
送出感谢: 0
接收感谢: 0

Re: Qt4安装问题

#3

帖子 snowwoods » 2008-09-27 12:18

现在在弄虚拟机,我是想在原先的系统中安装qt4,不知道该怎么处理才好
回复

回到 “老旧版本支持”