我的部分UBUNTU配置经验

为当前最终发行版之前的所有版本提供支持
回复
bmg99
帖子: 17
注册时间: 2008-09-23 13:07
送出感谢: 0
接收感谢: 0

我的部分UBUNTU配置经验

#1

帖子 bmg99 » 2008-09-27 12:42

先声明,本人也是新手,很多方法来自网络,并且在本人的VM上解决了,证明有效,这才敢贴出来。还有很多没接触到的,不懂,这两天去搞懂,陆续贴上来。

首先,安装好UBUNTU,这个不难,建议新手先用VM试试看,积累一下经验,再用光盘安装,这样更加容易上手。我就是用的VM装的UBUNTU,尚未转正至物理硬盘。
配置好自己的网络,我是最破的宽带有线通,但是好在根本不需要配置,以后的配置都是建立在UBUNTU能上网的基础上的。
刚安装完的UBUNTU是一半中文一半英文,你必须打开终端,输入sudo apt-get update来升级到最新版本。在这之前,你必须更新源列表,可以去WIKI找,这里不多说了。
你会发现SCIM不能输入中文,在语言支持里,选中汉语支持,默认汉语,支持复杂文字,应用,这时会下载中文语言包。升级完毕后,重启系统,重新登陆后,所有的界面都是中文的了。
我的鼠标在VM里不能使用滚轮,在终端里sudo gedit /etc/X11/xorg.conf ,先备份一个。把你看到的全部删除,输入完整配置代码(我在网络上找到的,直接复制粘帖就行了)如下:
Section "InputDevice"
Identifier "Configured Mouse"
Driver "vmmouse"
Option "CorePointer"
Option "ZAxisMapping" "4 5"
Option "Protocol" "ImPS/2"
Option "CorePointer"
Option "Emulate3Buttons" "yes"
Option "Device" "/dev/input/mice"
EndSection
重新启动Xwindow或者注销,滚轮就可以用了。
我的输入法是FCITX,安装配置如下:
sudo apt-get install im-switch fcitx
sudo im-switch -s fcitx -z default
im-switch -s fcitx -z default
安装完重启,输入法就是默认的自动启动。但是又出现了方块问题,解决办法如下:
sudo gedit /etc/fonts/conf.d/49-sansserif.conf
找到最后第4行的 sans-serif 替换为 文泉驿正黑,即可解决。 <string>文泉驿正黑</string>
当然这只是权宜之计,自己可以去下载一些很漂亮的免费字体,并且按照如上步骤,更改成自己需要的字体即可。
UBUNTU自带的播放器其实就不错,但是很多人喜欢MPLAYER,那就这样安装:
sudo apt-get install mplayer mplayer-fonts mozilla-mplayer
----------------------------------------------------------------------------
头像
yingtianli
帖子: 631
注册时间: 2008-09-20 14:27
送出感谢: 1 次
接收感谢: 0

Re: 我的部分UBUNTU配置经验

#2

帖子 yingtianli » 2008-09-27 20:10

在虚拟机上测试了,完全管用。 :em05 :em05
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

Re: 我的部分UBUNTU配置经验

#3

帖子 想入非非 » 2008-09-27 21:06

支持安装配置经验。。。 :em06
Ubuntu User
头像
kevin_liu
帖子: 5
注册时间: 2008-11-03 16:14
送出感谢: 0
接收感谢: 0

Re: 我的部分UBUNTU配置经验

#4

帖子 kevin_liu » 2008-11-03 16:57

感谢分享,我也终于可以使用鼠标中键了,心情大爽!!!!!
以结果思维引导和控制行为
回复

回到 “老旧版本支持”