ubuntu7.10自动挂载NTFS分区,显示不了含中文字符的文件夹!!

为当前最终发行版之前的所有版本提供支持
lucky_pig
帖子: 25
注册时间: 2008-09-29 14:11
送出感谢: 0
接收感谢: 0

ubuntu7.10自动挂载NTFS分区,显示不了含中文字符的文件夹!!

#1

帖子 lucky_pig » 2008-09-29 15:18

我的ubuntu7.10可以开机自动挂载NTFS分区,但是分区里面的文件和文件夹的名字里只要含有中文字符就没挂进来,也就是看不到这些文件活文件夹,英文名的文件和文件夹可以显示出来。
我的fstab文件内容如下:
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda7
UUID=ebe86f43-360f-4e97-ab48-6abf21b541ec / ext3 defaults,errors=remount-ro 0 1
# /dev/sda8
UUID=c06c6239-c102-46da-809a-d08aae20a8af /boot ext3 defaults 0 2
# /dev/sda12
UUID=2db8be8d-eaed-4068-bd92-f8d85e0c8e39 /home ext3 defaults 0 2
# /dev/sda1
UUID=36A0881EA087E2AB /media/sda1 ntfs defaults,utf8,umask=007,gid=46 0 1
# /dev/sda5
UUID=9218CB1A18CAFC6B /media/sda5 ntfs iocharset=gb2312,umask=007,gid=46 0 1
# /dev/sda6
UUID=E8C88F09C88ED56A /media/sda6 ntfs nls=utf-8,utf8,umask=007,gid=46 0 1

# /dev/sda11
UUID=406629c0-f940-4cf7-b772-320b929a075a /usr ext3 defaults 0 2
# /dev/sda9
UUID=e798ac3c-ce11-49b4-a1b6-a91c6ba8f661 /var ext3 defaults 0 2
# /dev/sda10
UUID=d872d29b-d0b5-4f87-8202-dd57835556e4 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
我用不同的选项分别挂载C、D、E盘,结果都不能显示中文名的文件和文件夹
但是我自己用命令挂载这些盘却可以显示所有文件和文件夹。
我的/proc/filesystems文件的内容如下:里面好像没有ntfs的类型?
nodev sysfs
nodev rootfs
nodev bdev
nodev proc
nodev cpuset
nodev debugfs
nodev securityfs
nodev sockfs
nodev pipefs
nodev anon_inodefs
nodev futexfs
nodev tmpfs
nodev inotifyfs
nodev devpts
cramfs
nodev ramfs
nodev mqueue
nodev fuse
fuseblk
nodev fusectl
nodev usbfs
ext3
请问这是怎么回事?怎么解决?现谢谢了!在线等....
头像
dsj
帖子: 810
注册时间: 2008-08-21 20:26
送出感谢: 0
接收感谢: 0
联系:

Re: ubuntu7.10自动挂载NTFS分区,显示不了含中文字符的文件夹!!

#2

帖子 dsj » 2008-09-29 15:31

UBUNTU默认就支持NTFS分区的读写,可是不完美,对NTFS分区下的中文文件支持不好,你会发现找不到中文的文件。

解决方法是在终端输入:

sudo apt-get -y --force-yes install ntfs-3g

sudo apt-get -y --force-yes install ntfs-config

[ -x /usr/bin/ntfs-3g ] && sudo ln -sf /usr/bin/ntfs-3g /sbin/mount.ntfs

gksudo ntfs-config & set v

然后全选上

不能读写的问题

一种方法是在终端输入:

sudo mount -t ntfs-3g /dev/sda1 /media/sda1 -o force

另一种方法是:

add the option to the relevant row in the /etc/fstab file:

/dev/sda1 /media/sda1 ntfs-3g defaults,force 0 0
软件交流群:17264279
图书分享群:18246379
互动社区:http://www.ubuntuchina.com/
lucky_pig
帖子: 25
注册时间: 2008-09-29 14:11
送出感谢: 0
接收感谢: 0

Re: ubuntu7.10自动挂载NTFS分区,显示不了含中文字符的文件夹!!

#3

帖子 lucky_pig » 2008-09-29 15:38

但是我用命令mount /dev/sda5 /media/sda5这样不带任何选项都可以挂载ntfs分区,并且可以显示中文名的文件和文件夹,说明我的系统可以识别ntfs分区中的中文阿。就是开机自动挂载的不能显示中文名的文件和文件夹
lucky_pig
帖子: 25
注册时间: 2008-09-29 14:11
送出感谢: 0
接收感谢: 0

Re: ubuntu7.10自动挂载NTFS分区,显示不了含中文字符的文件夹!!

#4

帖子 lucky_pig » 2008-09-29 15:59

我按照你的方法做了,fstab文件被自动修改了,我刚才重启了一下,结果还是不能显示中文名的文件和文件夹阿?fstab文件变成这样:
# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda7 :
UUID=ebe86f43-360f-4e97-ab48-6abf21b541ec / ext3 defaults,errors=remount-ro 0 1
# Entry for /dev/sda8 :
UUID=c06c6239-c102-46da-809a-d08aae20a8af /boot ext3 defaults 0 2
# Entry for /dev/sda12 :
UUID=2db8be8d-eaed-4068-bd92-f8d85e0c8e39 /home ext3 defaults 0 2
# Entry for /dev/sda5 :
UUID=9218CB1A18CAFC6B /media/sda5 ntfs-3g defaults,locale=en_US.UTF-8 0 1
# Entry for /dev/sda6 :
UUID=E8C88F09C88ED56A /media/sda6 ntfs-3g defaults,locale=en_US.UTF-8 0 1
# Entry for /dev/sda11 :
UUID=406629c0-f940-4cf7-b772-320b929a075a /usr ext3 defaults 0 2
# Entry for /dev/sda9 :
UUID=e798ac3c-ce11-49b4-a1b6-a91c6ba8f661 /var ext3 defaults 0 2
# Entry for /dev/sda10 :
UUID=d872d29b-d0b5-4f87-8202-dd57835556e4 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
/dev/sda1 /media/系统 ntfs-3g defaults,locale=en_US.UTF-8 0 0
lucky_pig
帖子: 25
注册时间: 2008-09-29 14:11
送出感谢: 0
接收感谢: 0

Re: ubuntu7.10自动挂载NTFS分区,显示不了含中文字符的文件夹!!

#5

帖子 lucky_pig » 2008-09-29 16:03

我的ubuntu默认语言是英语,不知道这个有没有影响
头像
dsj
帖子: 810
注册时间: 2008-08-21 20:26
送出感谢: 0
接收感谢: 0
联系:

Re: ubuntu7.10自动挂载NTFS分区,显示不了含中文字符的文件夹!!

#6

帖子 dsj » 2008-09-29 16:06

在 应用程序-》系统工具 中会有个配置选项,只要选上相应的设备支持就可以了。
软件交流群:17264279
图书分享群:18246379
互动社区:http://www.ubuntuchina.com/
lucky_pig
帖子: 25
注册时间: 2008-09-29 14:11
送出感谢: 0
接收感谢: 0

Re: ubuntu7.10自动挂载NTFS分区,显示不了含中文字符的文件夹!!

#7

帖子 lucky_pig » 2008-09-29 16:16

我再试试阿
头像
dsj
帖子: 810
注册时间: 2008-08-21 20:26
送出感谢: 0
接收感谢: 0
联系:

Re: ubuntu7.10自动挂载NTFS分区,显示不了含中文字符的文件夹!!

#8

帖子 dsj » 2008-09-29 16:25

把locale=en_US.UTF-8 改成locale=zh_CN.utf8
软件交流群:17264279
图书分享群:18246379
互动社区:http://www.ubuntuchina.com/
lucky_pig
帖子: 25
注册时间: 2008-09-29 14:11
送出感谢: 0
接收感谢: 0

Re: ubuntu7.10自动挂载NTFS分区,显示不了含中文字符的文件夹!!

#9

帖子 lucky_pig » 2008-09-29 16:44

这个命令sudo ln -sf /usr/bin/ntfs-3g /sbin/mount.ntfs好像没成功阿:

zhu@zhu-desktop:~$ find /sbin -name ntfs*
zhu@zhu-desktop:~$ find /usr/bin -name ntfs*
/usr/bin/ntfs-config
zhu@zhu-desktop:~$
没有ntfs-3g和mount.ntfs这个连接文件!
是不是我没有安装成功阿
lucky_pig
帖子: 25
注册时间: 2008-09-29 14:11
送出感谢: 0
接收感谢: 0

Re: ubuntu7.10自动挂载NTFS分区,显示不了含中文字符的文件夹!!

#10

帖子 lucky_pig » 2008-09-29 17:05

我把local改成zh_CN并重启,还是不能显示中文名的文件和文件夹!我晕死阿.....
lucky_pig
帖子: 25
注册时间: 2008-09-29 14:11
送出感谢: 0
接收感谢: 0

Re: ubuntu7.10自动挂载NTFS分区,显示不了含中文字符的文件夹!!

#11

帖子 lucky_pig » 2008-09-29 17:17

我的系统里面有如下的locale:
zhu@zhu-desktop:~$ locale -a
C
en_AU.utf8
en_BW.utf8
en_CA.utf8
en_DK.utf8
en_GB.utf8
en_HK.utf8
en_IE.utf8
en_IN
en_NZ.utf8
en_PH.utf8
en_SG.utf8
en_US.utf8
en_ZA.utf8
en_ZW.utf8
POSIX
zh_CN.utf8
zh_HK.utf8
zh_SG.utf8
zh_TW.utf8
我选择了zh_CN.utf8放在fstab中:
# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda7 :
UUID=ebe86f43-360f-4e97-ab48-6abf21b541ec / ext3 defaults,errors=remount-ro 0 1
# Entry for /dev/sda8 :
UUID=c06c6239-c102-46da-809a-d08aae20a8af /boot ext3 defaults 0 2
# Entry for /dev/sda12 :
UUID=2db8be8d-eaed-4068-bd92-f8d85e0c8e39 /home ext3 defaults 0 2
# Entry for /dev/sda5 :
UUID=9218CB1A18CAFC6B /media/sda5 ntfs-3g defaults,locale=zh_CN.utf8 0 0
# Entry for /dev/sda6 :
UUID=E8C88F09C88ED56A /media/sda6 ntfs-3g defaults,locale=zh_CN.utf8 0 0
# Entry for /dev/sda11 :
UUID=406629c0-f940-4cf7-b772-320b929a075a /usr ext3 defaults 0 2
# Entry for /dev/sda9 :
UUID=e798ac3c-ce11-49b4-a1b6-a91c6ba8f661 /var ext3 defaults 0 2
# Entry for /dev/sda10 :
UUID=d872d29b-d0b5-4f87-8202-dd57835556e4 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
/dev/sda1 /media/系统 ntfs-3g defaults,locale=zh_CN.utf8 0 0
怎么重启了,还是显示不了中文文件和文件夹呢?
lucky_pig
帖子: 25
注册时间: 2008-09-29 14:11
送出感谢: 0
接收感谢: 0

Re: ubuntu7.10自动挂载NTFS分区,显示不了含中文字符的文件夹!!

#12

帖子 lucky_pig » 2008-09-29 17:39

没有人知道解决办法吗?我在网上搜了好多,也没管用,等待高手赐教阿.....waiting for your answer!
头像
dsj
帖子: 810
注册时间: 2008-08-21 20:26
送出感谢: 0
接收感谢: 0
联系:

Re: ubuntu7.10自动挂载NTFS分区,显示不了含中文字符的文件夹!!

#13

帖子 dsj » 2008-09-29 21:58

sudo gedit /etc/fstab,然后把 locale=zh_CN.utf8 添在首行重启即可!

小事情大搞作
软件交流群:17264279
图书分享群:18246379
互动社区:http://www.ubuntuchina.com/
yuekuen
帖子: 52
注册时间: 2008-09-28 23:37
送出感谢: 0
接收感谢: 0

Re: ubuntu7.10自动挂载NTFS分区,显示不了含中文字符的文件夹!!

#14

帖子 yuekuen » 2008-09-30 15:12

英语是默认的肯定会出现中文乱码,你要把语言里面中文的全部更新了然后选成中文默认的,重启就可以了。这样子好像下载的文件挺多的,不过对于教育网的网速来说,这点更新不算什么,呵呵。 :em02
lucky_pig
帖子: 25
注册时间: 2008-09-29 14:11
送出感谢: 0
接收感谢: 0

Re: ubuntu7.10自动挂载NTFS分区,显示不了含中文字符的文件夹!!

#15

帖子 lucky_pig » 2008-09-30 19:44

非常感谢大家的帮忙阿,问题解决了,不是locale的问题,也不是什么语言的问题
我把加载命令
UUID=E8C88F09C88ED56A /media/sda6 ntfs-3g iocharset=cp936,locale=zh_CN.utf8 0 0
改成
/dev/sda6 /media/sda6 ntfs-3g defaults,locale=zh_CN.utf8 0 0
就可以了
不知道是为什么?
用UUID和用/dev/sda6有什么区别?
回复

回到 “老旧版本支持”