当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu下怎样安装subversion客户端?
帖子发表于 : 2008-10-05 17:29 
头像

注册: 2008-06-11 21:25
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我用apt-get install subversion 命令,系统提示我
libapr1 is not installable.
libsvn1 is not going to be installed。
我该怎么办?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu下怎样安装subversion客户端?
帖子发表于 : 2008-10-05 17:34 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
iBA subversion - Advanced version control system
估计你没刷新列表
使用update了?

或者源不对?


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu下怎样安装subversion客户端?
帖子发表于 : 2008-10-05 20:18 
头像

注册: 2008-06-11 21:25
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我之前apt-get update了。
你说的源不对是指linux版本不对吗?我的是对的。8.04的。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ubuntu下怎样安装subversion客户端?
帖子发表于 : 2009-12-10 15:55 
头像

注册: 2008-07-03 19:25
帖子: 125
送出感谢: 0 次
接收感谢: 0 次
raytheon429 写道:
我用apt-get install subversion 命令,系统提示我
libapr1 is not installable.
libsvn1 is not going to be installed。
我该怎么办?


楼主怎么被这个问题困扰了呢,你是不是感觉在linux/unix下面安装软件比windows下面复杂啊,因为有很多的包的依赖关系,而windows中则很少出现,其实这是两者的根本区别之一,也是linux/Unix理念的不同,这linux/unix系统中,提倡各个软件包的组合而完成复杂的任务,而不是产生一个软件的大杂烩,这样每个软件包都可以做到完美的完成自己的小任务。

楼主遇到的问题就是软件包的依赖问题,subversion软件包需要依赖libapr1和libsvn1,而你的系统中没有安装,所以apt-get程序在首先处理软件包的依赖关系时就出现了上述的错误,解决的办法很简单,因为你没安装,所以直接安装就OK了:

sudo apt-get insall libapr1
sudo apt-get insall libsvn1

应该就可以解决你的问题了,如果还少什么包,也这么做。
但是如果你的运气太背了,一直提示缺少软件包,你就不要使用命令行的方式了,去新立得里面,输入你要安装的软件包名,然后把需要的都选上,一次性全部安装,应该就OK了。

Good luck!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ubuntu下怎样安装subversion客户端?
帖子发表于 : 2009-12-10 16:02 
头像

注册: 2006-10-19 8:43
帖子: 787
地址: 长江口
送出感谢: 1
接收感谢: 2
用aptitude会提示你安装依赖的包?不太记得了


_________________
好好地做一个碌碌无为的人


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译