[问题求助]Ubuntu8.04安装vnc-4.0-x86_linux时出现提示

为当前最终发行版之前的所有版本提供支持
回复
头像
jackie_G
帖子: 2
注册时间: 2008-10-10 16:12
送出感谢: 0
接收感谢: 0

[问题求助]Ubuntu8.04安装vnc-4.0-x86_linux时出现提示

#1

帖子 jackie_G » 2008-10-11 22:01


下载的是4.0版vnc-4.0-x86_linux,安装之。
-----------------------
# tar -zxvf vnc-4.0-x86_linux.tar.gz
vnc-4.0-x86_linux/
vnc-4.0-x86_linux/vncinstall
vnc-4.0-x86_linux/Xvnc
vnc-4.0-x86_linux/vncviewer
vnc-4.0-x86_linux/vncserver
.....
vnc-4.0-x86_linux/java/vncviewer.jar

# cd vnc-4.0-x86_linux
# ./vncinstall /usr/local/bin
Copying Xvnc to /usr/local/bin
Copying vncviewer to /usr/local/bin
Copying vncpasswd to /usr/local/bin
Copying vncconfig to /usr/local/bin
Copying vncserver to /usr/local/bin
Copying x0vncserver to /usr/local/bin

# mkdir -p /usr/local/vnc/classes
# cp java/* /usr/local/vnc/classes
---------------------------
安装好了,我开始配置。按网上介绍的,第一次运行vncserver前先设置远程连接密码,但是执行命令后却出现提示缺少libstdc++库文件,
#vncpasswd
vncpasswd: error while loading shared libraries: libstdc++-libc6.1-1.so.2: cannot open shared object file: No such file or directory

网上没找到libstdc++-libc6.1-1.so.2。看到某些帖子里提到“如果没有成功,发出以下提示:缺少libstdc++库文档.到http://rpm.pbone.net/index.php3/stat/4/idpl/843376/com/compat-libstdc++-7.3-2.96.118.i386.rpm.html下载,安装compat-libstdc++-7.3-2.96.118.i386.rpm”

网上下载了这个文件后安装时又有提示(前面提到的某些帖子没有讨论这种情况的):
# rpm -ivh compat-libstdc++-7.3-2.96.118.i386.rpm
warning: compat-libstdc++-7.3-2.96.118.i386.rpm: Header V3 DSA signature: NOKEY, key ID db42a60e
error: 依赖性检测失败:
/bin/sh 被 compat-libstdc++-7.3-2.96.118.i386 所需要
/sbin/ldconfig 被 compat-libstdc++-7.3-2.96.118.i386 所需要
libc.so.6 被 compat-libstdc++-7.3-2.96.118.i386 所需要
libc.so.6(GLIBC_2.0) 被 compat-libstdc++-7.3-2.96.118.i386 所需要
libc.so.6(GLIBC_2.1) 被 compat-libstdc++-7.3-2.96.118.i386 所需要
libc.so.6(GLIBC_2.1.3) 被 compat-libstdc++-7.3-2.96.118.i386 所需要
libc.so.6(GLIBC_2.3) 被 compat-libstdc++-7.3-2.96.118.i386 所需要
libgcc_s.so.1 被 compat-libstdc++-7.3-2.96.118.i386 所需要
libgcc_s.so.1(GLIBC_2.0) 被 compat-libstdc++-7.3-2.96.118.i386 所需要
libm.so.6 被 compat-libstdc++-7.3-2.96.118.i386 所需要
libm.so.6(GLIBC_2.0) 被 compat-libstdc++-7.3-2.96.118.i386 所需要

不明白这些提示是什么意思,vncpasswd,vncserver,vncviewer等命令还是不能执行(还是提示缺少libstdc++-libc6.1-1.so.2库文件)。
我是新人,第一次用Ubuntu,请大家帮帮我,给些建议也好。 :em01
头像
冲浪板
论坛版主
帖子: 7467
注册时间: 2007-05-06 8:19
送出感谢: 0
接收感谢: 5 次

Re: [问题求助]Ubuntu8.04安装vnc-4.0-x86_linux时出现提示

#2

帖子 冲浪板 » 2008-10-13 8:43

我当初用的是*.rpm,红帽子用这个很容易哒~ :em03
你用的是ubuntu么?怎么找来的是*.rpm哦?
被需求的是被依赖的库文件。

说反了,更正:
你装compat-libstdc++-7.3-2.96.118.i386的时候,缺少一些库,就是说xxxx被compat-libstdc依赖中的xxxx,你可以继续找xxxx,或者将就一下,用稍微低一些版本的compat-libstdc,VNC也可以找前一版本的看看。
flyinflash
帖子: 2376
注册时间: 2006-09-21 14:28
送出感谢: 0
接收感谢: 0

Re: [问题求助]Ubuntu8.04安装vnc-4.0-x86_linux时出现提示

#3

帖子 flyinflash » 2008-10-13 16:01

ubuntu默认好像有vnc/类似远程登陆软件。
如果没有,打开新立得,搜索vnc,看描述,再按需安装;
如果没有还是没有找到,请问google。

我现在不再不用ubuntu,很抱歉,只能给这些建议。 :em06
头像
jackie_G
帖子: 2
注册时间: 2008-10-10 16:12
送出感谢: 0
接收感谢: 0

Re: [问题求助]Ubuntu8.04安装vnc-4.0-x86_linux时出现提示

#4

帖子 jackie_G » 2008-10-13 21:45

感谢楼上两位朋友的帮助和建议。
昨天又弄了下,那个提示还是没有搞定。
跳过这个问题,在windos xp上用tightvnc viewer输入IP,用户名和口令,居然就直接连上了,(Ubuntu事先就打开了“允许远程连接”)。图形界面,鼠标移动速度还不错,可以接受。
Ubuntu果然很强大啊!
回复

回到 “老旧版本支持”