如何卸载“元软件包“,然后恢复到原来的系统?

为当前最终发行版之前的所有版本提供支持
回复
Arh
帖子: 49
注册时间: 2008-08-17 9:01
送出感谢: 0
接收感谢: 0

如何卸载“元软件包“,然后恢复到原来的系统?

#1

帖子 Arh » 2008-10-12 10:37

各位前辈:
今天早晨由于好奇,把新立得软件包里面的“元软件包“全部标记安装,之后重启,发现图标变成KDE的图标了, :em20 我之前用的是Gnome的界面。重启进入系统后,发现系统变成edubuntu的界面了,原来的配置都已改变了,还有就是启动的时候启动项多了四项;开始我想通过终端把这些软件包卸载掉,发现不能卸载;后来有通过启动项recovery mode进入boot项进入shell通过sudo apt-get remove ##来卸载,也不能卸载,现在不知道该怎么办了!
请各位前辈、高手帮帮小弟,让我恢复到之前的Gnome界面,不胜感激!
头像
windwiny
帖子: 2254
注册时间: 2007-03-13 17:26
送出感谢: 0
接收感谢: 1 次

Re: 如何卸载“元软件包“,然后恢复到原来的系统?

#2

帖子 windwiny » 2008-10-12 11:36

到底怎么不能卸载

把 ubuntu-desktop 留下,其它的都不要
Arh
帖子: 49
注册时间: 2008-08-17 9:01
送出感谢: 0
接收感谢: 0

Re: 如何卸载“元软件包“,然后恢复到原来的系统?

#3

帖子 Arh » 2008-10-12 12:33

下面的是在终端中运行的结果:
tuniu@linux:~$ sudo apt-get remove edubuntu-addon-kde
[sudo] password for tuniu:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
软件包 edubuntu-addon-kde 还未安装,因而不会被卸载
已经不需要下列自动安装的软件包:
education-tasks
使用 'apt-get autoremove' 来删除它们。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
tuniu@linux:~$ sudo apt-get remove edubuntu-desktop
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
软件包 edubuntu-desktop 还未安装,因而不会被卸载
已经不需要下列自动安装的软件包:
education-tasks
使用 'apt-get autoremove' 来删除它们。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
tuniu@linux:~$ sudo apt-get autoremove
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
已经不需要下列自动安装的软件包:
education-tasks
下列软件包将被【卸载】:
education-tasks
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 1 个软件包,有 0 个软件未被升级。
操作完成后,会释放 73.7kB 的磁盘空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 229013 个文件和目录。)
正在删除 education-tasks ...
tuniu@linux:~$

现在我的系统桌面默认是edubuntu的,而且好像于compiz fusion有冲突,现在束手无策!?
头像
yaoms
帖子: 4953
注册时间: 2007-10-19 14:51
来自: 深圳
送出感谢: 0
接收感谢: 2 次

Re: 如何卸载“元软件包“,然后恢复到原来的系统?

#4

帖子 yaoms » 2008-10-12 12:47

安装所有“元软件包”?一共下载了多少东西阿?有的删了。元宝很强大的,装的时候扯出一堆,卸的时候是“挥一挥衣袖,不带走一丝云彩”的。。。
Nothing 有事请发邮件到 yms541 AT gmail.com
alias 爱慕颇雷尔='mplayer'
Arh
帖子: 49
注册时间: 2008-08-17 9:01
送出感谢: 0
接收感谢: 0

Re: 如何卸载“元软件包“,然后恢复到原来的系统?

#5

帖子 Arh » 2008-10-12 14:33

大概300多Mb,就下了一个默认的“元软件包”,后来通过相关软件的卸载,把有关KDE的软件包都卸载了,但是登录和关闭的界面还是edubuntu,不过现在感觉与compiz fusion没有冲突了, :em01 ,通过新立得和终端解决一部分问题,下面的期待我自己慢慢摸索,感谢各位前辈的点拔,让我茅塞顿开, :em03
回复

回到 “老旧版本支持”