更新出错???哪位帮忙解决???

为当前最终发行版之前的所有版本提供支持
回复
wwg
帖子: 8
注册时间: 2008-09-30 21:18
送出感谢: 0
接收感谢: 0

更新出错???哪位帮忙解决???

#1

帖子 wwg » 2008-10-13 0:02

新立得软件包管理器
有错误
细节信息如下:
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

用终端
出现如下错误
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

请问如何解决?????? :em20 :em06 :em20
deadboy
帖子: 141
注册时间: 2008-01-20 0:23
送出感谢: 0
接收感谢: 0

Re: 更新出错???哪位帮忙解决???

#2

帖子 deadboy » 2008-10-13 0:29

先照着提示做,在命令行输入命令 dpkg --configure -a
看能不能解决
wwg
帖子: 8
注册时间: 2008-09-30 21:18
送出感谢: 0
接收感谢: 0

Re: 更新出错???哪位帮忙解决???

#3

帖子 wwg » 2008-10-13 0:47

多谢你。但还解决不了问题。
情况如下 :em06
wwg@wwg-desktop:~$ sudo apt-get upgrade
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
wwg@wwg-desktop:~$ dpkg --configure -a
dpkg: 该操作需要超级用户权限
wwg@wwg-desktop:~$
赤之湖
帖子: 204
注册时间: 2008-09-25 19:57
送出感谢: 0
接收感谢: 0

Re: 更新出错???哪位帮忙解决???

#4

帖子 赤之湖 » 2008-10-13 0:52

如果是需要超级用户权限的话,就在前边加上sudo就可以了
$ sudo dpkg --configure -a
wwg
帖子: 8
注册时间: 2008-09-30 21:18
送出感谢: 0
接收感谢: 0

Re: 更新出错???哪位帮忙解决???

#5

帖子 wwg » 2008-10-13 1:10

多谢2楼和4楼帮忙
问题得到解决啦 :em01
回复

回到 “老旧版本支持”