桌面版安装apache2遇到点问题

为当前最终发行版之前的所有版本提供支持
回复
狗尾草
帖子: 18
注册时间: 2007-10-03 8:40
送出感谢: 0
接收感谢: 0

桌面版安装apache2遇到点问题

#1

帖子 狗尾草 » 2008-10-23 9:51

错误提示如下:
XXXX@desktop-L:~$ sudo apt-get install apache2
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting apache2-mpm-itk instead of apache2
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
apache2-mpm-itk: Depends: apache2.2-common (= 2.2.8-1ubuntu0.3) but it is not installable
Depends: libapr1 but it is not installable
Depends: libaprutil1 but it is not installable
E: Broken packages


安装libapr1吧,提示找不到包.
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 桌面版安装apache2遇到点问题

#2

帖子 eexpress » 2008-10-23 9:53

试试用lighttpd, thttpd,nginx吧。
● 鸣学
狗尾草
帖子: 18
注册时间: 2007-10-03 8:40
送出感谢: 0
接收感谢: 0

Re: 桌面版安装apache2遇到点问题

#3

帖子 狗尾草 » 2008-10-23 10:26

eexpress 写了:试试用lighttpd, thttpd,nginx吧。
最基本的都没整明白,先不玩那些吧.
未来肯定会搞的
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 桌面版安装apache2遇到点问题

#4

帖子 eexpress » 2008-10-23 10:29

apache2,就不是小网站需要的。我说的,才是。包括youtube都不用apache的。本论坛也不用这个了。apache是最复杂的。不是最基本的。
● 鸣学
狗尾草
帖子: 18
注册时间: 2007-10-03 8:40
送出感谢: 0
接收感谢: 0

Re: 桌面版安装apache2遇到点问题

#5

帖子 狗尾草 » 2008-10-23 10:54

eexpress 写了:apache2,就不是小网站需要的。我说的,才是。包括youtube都不用apache的。本论坛也不用这个了。apache是最复杂的。不是最基本的。
我换个词,通用行不?
apache+各种各样的CGI能兼容大部分语言.
lighttpd, thttpd,nginx不是说不好,他们有自己的特点和专注的一方面.

AMP是最常用的应用,假如我连这个都没去研究反而去学其它的,是不是有些说不过去?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 桌面版安装apache2遇到点问题

#6

帖子 eexpress » 2008-10-23 11:03

如果只是安装的问题。估计源不同步,等等就好了。
继续研究吧。
● 鸣学
回复

回到 “老旧版本支持”