依赖性检测失败,求解,别的rpm也一样

为当前最终发行版之前的所有版本提供支持
回复
july07
帖子: 5
注册时间: 2008-10-25 14:08
送出感谢: 0
接收感谢: 0

依赖性检测失败,求解,别的rpm也一样

#1

帖子 july07 » 2008-10-27 14:50

sudo rpm -ivh stardict-3.0.1-1.fc8.i386.rpm
error: 依赖性检测失败:
/bin/sh 被 stardict-3.0.1-1.fc8.i386 所需要
GConf2 被 stardict-3.0.1-1.fc8.i386 所需要
bonobo-activation >= 2.2.0 被 stardict-3.0.1-1.fc8.i386 所需要
enchant 被 stardict-3.0.1-1.fc8.i386 所需要
espeak 被 stardict-3.0.1-1.fc8.i386 所需要
gucharmap 被 stardict-3.0.1-1.fc8.i386 所需要
libICE.so.6 被 stardict-3.0.1-1.fc8.i386 所需要
libORBit-2.so.0 被 stardict-3.0.1-1.fc8.i386 所需要
libSM.so.6 被 stardict-3.0.1-1.fc8.i386 所需要
libX11.so.6 被 stardict-3.0.1-1.fc8.i386 所需要
libart_lgpl_2.so.2 被 stardict-3.0.1-1.fc8.i386 所需要
libatk-1.0.so.0 被 stardict-3.0.1-1.fc8.i386 所需要
libbonobo >= 2.2.0 被 stardict-3.0.1-1.fc8.i386 所需要
libbonobo-2.so.0 被 stardict-3.0.1-1.fc8.i386 所需要
libbonobo-activation.so.4 被 stardict-3.0.1-1.fc8.i386 所需要
libbonoboui-2.so.0 被 stardict-3.0.1-1.fc8.i386 所需要
libc.so.6 被 stardict-3.0.1-1.fc8.i386 所需要
libc.so.6(GLIBC_2.0) 被 stardict-3.0.1-1.fc8.i386 所需要
libc.so.6(GLIBC_2.1) 被 stardict-3.0.1-1.fc8.i386 所需要
libc.so.6(GLIBC_2.1.2) 被 stardict-3.0.1-1.fc8.i386 所需要
libc.so.6(GLIBC_2.1.3) 被 stardict-3.0.1-1.fc8.i386 所需要
libc.so.6(GLIBC_2.2) 被 stardict-3.0.1-1.fc8.i386 所需要
libc.so.6(GLIBC_2.3.4) 被 stardict-3.0.1-1.fc8.i386 所需要
libc.so.6(GLIBC_2.4) 被 stardict-3.0.1-1.fc8.i386 所需要
libcairo.so.2 被 stardict-3.0.1-1.fc8.i386 所需要
libdl.so.2 被 stardict-3.0.1-1.fc8.i386 所需要
libenchant.so.1 被 stardict-3.0.1-1.fc8.i386 所需要
libespeak.so.1 被 stardict-3.0.1-1.fc8.i386 所需要
libgcc_s.so.1 被 stardict-3.0.1-1.fc8.i386 所需要
libgcc_s.so.1(GCC_3.0) 被 stardict-3.0.1-1.fc8.i386 所需要
libgconf-2.so.4 被 stardict-3.0.1-1.fc8.i386 所需要
libgdk-x11-2.0.so.0 被 stardict-3.0.1-1.fc8.i386 所需要
libgdk_pixbuf-2.0.so.0 被 stardict-3.0.1-1.fc8.i386 所需要
libglib-2.0.so.0 被 stardict-3.0.1-1.fc8.i386 所需要
libgmodule-2.0.so.0 被 stardict-3.0.1-1.fc8.i386 所需要
libgnome >= 2.2.0 被 stardict-3.0.1-1.fc8.i386 所需要
libgnome-2.so.0 被 stardict-3.0.1-1.fc8.i386 所需要
libgnomecanvas-2.so.0 被 stardict-3.0.1-1.fc8.i386 所需要
libgnomeui >= 2.2.0 被 stardict-3.0.1-1.fc8.i386 所需要
libgnomeui-2.so.0 被 stardict-3.0.1-1.fc8.i386 所需要
libgnomevfs-2.so.0 被 stardict-3.0.1-1.fc8.i386 所需要
libgobject-2.0.so.0 被 stardict-3.0.1-1.fc8.i386 所需要
libgthread-2.0.so.0 被 stardict-3.0.1-1.fc8.i386 所需要
libgtk-x11-2.0.so.0 被 stardict-3.0.1-1.fc8.i386 所需要
libgucharmap.so.6 被 stardict-3.0.1-1.fc8.i386 所需要
libm.so.6 被 stardict-3.0.1-1.fc8.i386 所需要
libm.so.6(GLIBC_2.0) 被 stardict-3.0.1-1.fc8.i386 所需要
libpango-1.0.so.0 被 stardict-3.0.1-1.fc8.i386 所需要
libpangocairo-1.0.so.0 被 stardict-3.0.1-1.fc8.i386 所需要
libpopt.so.0 被 stardict-3.0.1-1.fc8.i386 所需要
libpthread.so.0 被 stardict-3.0.1-1.fc8.i386 所需要
libpthread.so.0(GLIBC_2.0) 被 stardict-3.0.1-1.fc8.i386 所需要
librt.so.1 被 stardict-3.0.1-1.fc8.i386 所需要
libsigc++20 >= 2.0.17 被 stardict-3.0.1-1.fc8.i386 所需要
libsigc-2.0.so.0 被 stardict-3.0.1-1.fc8.i386 所需要
libstdc++.so.6 被 stardict-3.0.1-1.fc8.i386 所需要
libstdc++.so.6(CXXABI_1.3) 被 stardict-3.0.1-1.fc8.i386 所需要
libstdc++.so.6(GLIBCXX_3.4) 被 stardict-3.0.1-1.fc8.i386 所需要
libz.so.1 被 stardict-3.0.1-1.fc8.i386 所需要
rtld(GNU_HASH) 被 stardict-3.0.1-1.fc8.i386 所需要
scrollkeeper 被 stardict-3.0.1-1.fc8.i386 所需要
头像
cnkilior
论坛版主
帖子: 4979
注册时间: 2007-08-05 17:40
送出感谢: 0
接收感谢: 5 次

Re: 依赖性检测失败,求解,别的rpm也一样

#2

帖子 cnkilior » 2008-10-27 14:58

你在Ubuntu中安装rpm包管理器?!

-------
可见你的rpm数据库为空。
-----
不知道你怎么安上的rpm包管理器。
回复

回到 “老旧版本支持”