apt-get install tar时出错了

为当前最终发行版之前的所有版本提供支持
回复
头像
Ragingflames
帖子: 89
注册时间: 2006-09-08 19:59
送出感谢: 0
接收感谢: 0

apt-get install tar时出错了

#1

帖子 Ragingflames » 2008-10-29 14:30

root@ubuntu:/home/ubuntu# sudo dpkg --root=/media/disk-2 -i tar_1.20-1_i386.deb
(正在读取数据库 ... 系统当前总共安装有 114134 个文件和目录。)
正预备替换 tar 1.20-1 (使用 tar_1.20-1_i386.deb) ...
正在解压缩将用于更替的包文件 tar ...
/var/lib/dpkg/info/tar.postrm: 4: cannot create /dev/null: Permission denied
正在设置 tar (1.20-1) ...
/var/lib/dpkg/info/tar.postinst: 17: cannot create /dev/null: Permission denied

Processing triggers for man-db ...
Can't open /dev/null: Permission denied
root@ubuntu:/home/ubuntu#

------------------------------------------------------------------------------------
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
下列软件包是自动安装的并且现在不再被使用了:
libcamel1.2-13
使用'apt-get autoremove'来删除它们
下列【新】软件包将被安装:
ncompress
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 0B/23.0kB 的软件包。
解压缩后会消耗掉 81.9kB 的额外空间。
dpkg-deb (子进程):exec tar 失败: 没有该文件或目录
dpkg-deb: 子进程 tar 返回了错误号 2
dpkg:处理 /var/cache/apt/archives/ncompress_4.2.4.2-1_i386.deb (--unpack)时出错:
子进程 dpkg-deb --control 返回了错误号 2
在处理时有错误发生:
/var/cache/apt/archives/ncompress_4.2.4.2-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
----------------------------------------------------------
删了tar想重装tar,感谢大侠帮助
ALC655 SB450的声卡的福音请去我帖子

http://forum.ubuntu.org.cn/viewtopic.ph ... highlight=
头像
jimmerlin
帖子: 252
注册时间: 2008-08-24 9:41
送出感谢: 0
接收感谢: 1 次

Re: apt-get install tar时出错了

#2

帖子 jimmerlin » 2008-10-29 18:15

tar还用安装?? :em03
回复

回到 “老旧版本支持”