更新安装出问题了!

为当前最终发行版之前的所有版本提供支持
回复
moximoxi
帖子: 1967
注册时间: 2008-09-30 17:46
送出感谢: 4 次
接收感谢: 2 次

更新安装出问题了!

#1

帖子 moximoxi » 2008-10-29 21:49

显示:E: /var/cache/apt/archives/linux-image-2.6.24-21-generic_2.6.24-21.43_i386.deb: 无法在安装新的版本前,为“./boot/vmlinuz-2.6.24-21-generic”做一个符号链接备份

有知道的朋友解解惑!谢过了。
头像
yiding_he
帖子: 2677
注册时间: 2006-10-25 18:10
来自: 长沙
送出感谢: 0
接收感谢: 0
联系:

Re: 更新安装出问题了!

#2

帖子 yiding_he » 2008-10-29 21:53

不知道“./boot/vmlinuz-2.6.24-21-generic”指的到底是什么位置,我才可能是“/boot/vmlinuz-2.6.24-21-generic”

检查一下 /boot/vmlinuz-2.6.24-21-generic 这个文件是否已经存在。如果已经存在,重命名掉看看。
你是自由的。别人也是。
moximoxi
帖子: 1967
注册时间: 2008-09-30 17:46
送出感谢: 4 次
接收感谢: 2 次

Re: 更新安装出问题了!

#3

帖子 moximoxi » 2008-10-29 22:02

yiding_he 写了:不知道“./boot/vmlinuz-2.6.24-21-generic”指的到底是什么位置,我才可能是“/boot/vmlinuz-2.6.24-21-generic”

检查一下 /boot/vmlinuz-2.6.24-21-generic 这个文件是否已经存在。如果已经存在,重命名掉看看。
好的,我试试。谢谢。 :em51
赤之湖
帖子: 204
注册时间: 2008-09-25 19:57
送出感谢: 0
接收感谢: 0

Re: 更新安装出问题了!

#4

帖子 赤之湖 » 2008-10-29 22:11

终端输入命令:

sudo rm -fv /boot/initrd.img-2.6.24*.bak
sudo rm -fv /boot/vmlinuz-2.6.24-21-generic
sudo rm -fv /boot/initrd.img-2.6.24-21-generic
sudo rm -fv /boot/config-2.6.24-21-generic
sudo rm -fv /boot//abi-2.6.24-21-generic
sudo rm -fv /boot/System.map-2.6.24-21-generic

然后就能正确更新。
moximoxi
帖子: 1967
注册时间: 2008-09-30 17:46
送出感谢: 4 次
接收感谢: 2 次

Re: 更新安装出问题了!

#5

帖子 moximoxi » 2008-10-29 22:18

yiding_he 写了:不知道“./boot/vmlinuz-2.6.24-21-generic”指的到底是什么位置,我才可能是“/boot/vmlinuz-2.6.24-21-generic”

检查一下 /boot/vmlinuz-2.6.24-21-generic 这个文件是否已经存在。如果已经存在,重命名掉看看。
这个文件已有了,但无法重命名。需要提升权限吗?
moximoxi
帖子: 1967
注册时间: 2008-09-30 17:46
送出感谢: 4 次
接收感谢: 2 次

Re: 更新安装出问题了!

#6

帖子 moximoxi » 2008-10-29 22:20

赤之湖 写了:终端输入命令:

sudo rm -fv /boot/initrd.img-2.6.24*.bak
sudo rm -fv /boot/vmlinuz-2.6.24-21-generic
sudo rm -fv /boot/initrd.img-2.6.24-21-generic
sudo rm -fv /boot/config-2.6.24-21-generic
sudo rm -fv /boot//abi-2.6.24-21-generic
sudo rm -fv /boot/System.map-2.6.24-21-generic

然后就能正确更新。
热心朋友!谢! :em51
moximoxi
帖子: 1967
注册时间: 2008-09-30 17:46
送出感谢: 4 次
接收感谢: 2 次

Re: 更新安装出问题了!

#7

帖子 moximoxi » 2008-10-29 22:47

删除之后已能更新,系统重启无问题。再次谢谢楼上二位。 :em51 又学到一招。 :em11
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

Re: 更新安装出问题了!

#8

帖子 想入非非 » 2008-10-30 0:32

好久以前的东西。。。 :em04
Ubuntu User
jsh
帖子: 12
注册时间: 2008-09-28 11:38
送出感谢: 0
接收感谢: 0

Re: 更新安装出问题了!

#9

帖子 jsh » 2008-10-31 10:19

不错,我也出现了这样的问题,按照大家的方法解决了。
回复

回到 “老旧版本支持”