安装libdbus-1-dev时提示依赖错误 求解决方法

为当前最终发行版之前的所有版本提供支持
回复
bcn
帖子: 24
注册时间: 2005-12-04 17:46
送出感谢: 0
接收感谢: 0
联系:

安装libdbus-1-dev时提示依赖错误 求解决方法

#1

帖子 bcn » 2009-02-23 11:37

前些天安装完8.04.2再COMPIZ 0.78没问题
今天重装系统
用这个命令安装依赖支持
sudo apt-get install build-essential libxcomposite-dev libpng12-dev libsm-dev libxrandr-dev libxdamage-dev libxinerama-dev libstartup-notification0-dev libgconf2-dev libgl1-mesa-dev libglu1-mesa-dev libmetacity-dev librsvg2-dev libdbus-1-dev libdbus-glib-1-dev libgnome-desktop-dev libgnome-window-settings-dev gitweb curl autoconf automake automake1.9 libtool intltool libxslt1-dev xsltproc libwnck-dev python-dev python-pyrex


一直出下边那个提示

xsltproc 已经是最新的版本了。
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libdbus-1-dev: 依赖: libdbus-1-3 (= 1.1.20-1ubuntu1) 但是 1.1.20-1ubuntu3.2 正要被安装
libdbus-glib-1-dev: 依赖: libglib2.0-dev 但是它将不会被安装
libgconf2-dev: 依赖: libglib2.0-dev 但是它将不会被安装
依赖: liborbit2-dev (>= 1:2.8.0) 但是它将不会被安装
libgnome-desktop-dev: 依赖: libgnome-desktop-2 (= 1:2.22.1-0ubuntu6) 但是 1:2.22.3-0ubuntu1 正要被安装
依赖: libgnomeui-dev (>= 2.14.1-1) 但是它将不会被安装
libmetacity-dev: 依赖: libgtk2.0-dev (>= 2.10.0-1) 但是它将不会被安装
librsvg2-dev: 依赖: libcairo2-dev (>= 1.2.0) 但是它将不会被安装
依赖: libglib2.0-dev (>= 2.12.0) 但是它将不会被安装
依赖: libgtk2.0-dev (>= 2.10.1-1) 但是它将不会被安装
libwnck-dev: 依赖: libgtk2.0-dev (>= 2.8.17-1) 但是它将不会被安装
依赖: libwnck22 (= 2.22.1-0ubuntu1) 但是 2.22.3-0ubuntu1 正要被安装
libxslt1-dev: 依赖: libxslt1.1 (= 1.1.22-1ubuntu1) 但是 1.1.22-1ubuntu1.2 正要被安装
依赖: libxml2-dev (>= 2.6.26) 但是它将不会被安装
python-dev: 依赖: python2.5-dev (>= 2.5.2) 但是它将不会被安装
E: 无法安装的软件包



怕因为其它软件冲突
刚安装好系统其它都不装直接安装也是这个提示

求解决办法
回复

回到 “老旧版本支持”