当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 重新安装fcitx出现错误
帖子发表于 : 2009-10-09 21:56 
头像

注册: 2009-02-14 16:28
帖子: 72
送出感谢: 0 次
接收感谢: 0 次
在包含自 ime.c:42 的文件中:
TrayWindow.h:5:21: 错误: X11/xpm.h:没有该文件或目录
TrayWindow.h:6:25: 错误: X11/Xft/Xft.h:没有该文件或目录
TrayWindow.h:7:34: 错误: X11/extensions/shape.h:没有该文件或目录
In file included from ime.c:42:
TrayWindow.h:20: 错误: expected specifier-qualifier-list before ‘XpmAttributes’
make[2]: *** [ime.o] 错误 1
make[2]:正在离开目录 `/home/found/tmp/fcitx-3.6.1/src'
make[1]: *** [all-recursive] 错误 1
make[1]:正在离开目录 `/home/found/tmp/fcitx-3.6.1'
make: *** [all] 错误 2


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 重新安装fcitx出现错误
帖子发表于 : 2009-10-09 22:00 
头像

注册: 2007-05-08 16:26
帖子: 2058
地址: 火星内核某分子内某原子核内
系统: arch
送出感谢: 20
接收感谢: 6
头像真不错。

fcitx 源码地址 http://code.google.com/p/fcitx/source/checkout

fcitx(小企鹅)3.6.0编译安装
viewtopic.php?f=95&t=180518


_________________
笔记本 :
F208S : gentoo
A460P i3G D6 : UBUNTU + WIN7
UN43D1 : UBUNTU + WIN7
1000人超级QQ群 LINUX + WIN : 31465544 或 18210387


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 重新安装fcitx出现错误
帖子发表于 : 2009-10-09 22:08 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
为啥不直接用现成的3.6.2的最新deb?编译安装也得卸载旧版本,安装依赖库齐全才能编译成功的。
viewtopic.php?f=8&t=192737#由Alpha.gu打的Fcitx最新deb包及安装方法。装好后设置im-switch。修改配置~/.fcitx/config推荐用leafpad。
一般情况下,Ubuntu里总是有AR PL UMing CN这样的中文字体的,把配置文件中的*号改成这个字体就行了,重启X生效。为避免冲突,最好卸了scim或ibus。


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译