如何加装KDE4

为当前最终发行版之前的所有版本提供支持
hbaolong
帖子: 44
注册时间: 2007-07-08 12:02
送出感谢: 0
接收感谢: 0

如何加装KDE4

#1

帖子 hbaolong » 2007-12-23 9:07

我装的是UBUNTU 8。04,现加装KDE4,
执行sudo apt-get instrall kdesktop-kde4 说没有可选的安装项。


大家都用的哪些源呢?
头像
Beetle
帖子: 1637
注册时间: 2005-10-14 16:55
系统: OS X
来自: 江苏
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 Beetle » 2007-12-23 17:53

完全删除之前的kde4包

代码: 全选

sudo apt-get --purge remove kdelibs5 kde4base-data kde4libs-data
增加源:

代码: 全选

deb http://ppa.launchpad.net/kubuntu-members-kde4/ubuntu hardy main
刷新

代码: 全选

sudo apt-get update
安装

代码: 全选

sudo apt-get install kdebase-workspace kdebase-runtime
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#3

帖子 leeaman » 2007-12-23 18:13

cn99有了,如果对你来说更快的话就用它

直接

代码: 全选

sudo apt-get install kdebase-workspace kdebase-runtime 
老农民
帖子: 183
注册时间: 2006-12-22 20:44
送出感谢: 0
接收感谢: 0

#4

帖子 老农民 » 2007-12-24 15:43

下列的软件包有不能满足的依赖关系:
kdebase-runtime: 依赖: kdebase-runtime-bin (>= 4:3.97.0-1ubuntu4) 但是它将不会被安装
kdebase-workspace: 依赖: kdebase-workspace-bin (>= 4:3.97.0-1ubuntu7) 但是它将不会被安装
依赖: klipper-kde4 (>= 4:3.97.0-1ubuntu7) 但是它将不会被安装
依赖: ksysguard-kde4 (>= 4:3.97.0-1ubuntu7) 但是它将不会被安装
依赖: kwin-kde4 (>= 4:3.97.0-1ubuntu7) 但是它将不会被安装
依赖: systemsettings-kde4 (>= 4:3.97.0-1ubuntu7) 但是它将不会被安装
E: 无法安装的软件包
SimonLei
帖子: 12
注册时间: 2007-08-16 15:35
送出感谢: 0
接收感谢: 0

#5

帖子 SimonLei » 2007-12-28 9:23

我也碰到一样的错误,真奇怪。
8.04 alpha2 的release notes 里面不是说带了 kde 4 rc2么。
april_linux
帖子: 144
注册时间: 2005-10-05 23:03
送出感谢: 0
接收感谢: 0

#6

帖子 april_linux » 2007-12-28 9:38

hardy的源里应该会有吧,有谁装过吗?
SimonLei
帖子: 12
注册时间: 2007-08-16 15:35
送出感谢: 0
接收感谢: 0

#7

帖子 SimonLei » 2007-12-28 16:31

总算搞定了。
之所以会出现冲突,是因为在 ppa 那个源里,以及 hardy本身的源里,都有
kde4的内容。但是,其中有些小区别,最重要的就是 kdelibs5 所依赖的一个
gif库不一样。在hardy本身的kdelibs5里面,它依赖的是较新的 libgif4,而在
所有其他的kde程序里面,它又依赖一个老的 libungif4g,并且 libgif4 与
libungif4g 不能同时存在。所以直接 sudo apt-get install kdebase-runtime
肯定会出错。

解决的办法是,在安装 kdelibs5 (还有一个它依赖的软件)的时候,指定从
ppa那个源里面来的那个版本,只要这个安装完成了,剩下的都没有问题。

造成这个问题的原因,大概是因为现在还是alpha2版本,有些不一致的情况吧。

做小白鼠,果然是要付出代价的。
jl_chang
帖子: 115
注册时间: 2006-01-14 1:13
送出感谢: 0
接收感谢: 0

#8

帖子 jl_chang » 2008-01-01 14:08

楼上的,能否给个具体点的操作步骤?我被依赖性问题困扰很久,始终无法解决
butterflyin
帖子: 249
注册时间: 2006-11-08 10:06
送出感谢: 0
接收感谢: 0

#9

帖子 butterflyin » 2008-01-07 15:40

SimonLei 写了:我也碰到一样的错误,真奇怪。
8.04 alpha2 的release notes 里面不是说带了 kde 4 rc2么。
是带了的。不过默认不是,需要登录时选择会话-kde4
头像
robust
帖子: 293
注册时间: 2006-07-04 21:56
送出感谢: 1 次
接收感谢: 0

#10

帖子 robust » 2008-01-08 9:36

不增加源也可以装上了。
我喜欢菜单的方式,不用大幅度地移动鼠标。
但和scim好象配合不好,一输入汉字就崩了。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#11

帖子 eexpress » 2008-01-08 9:56

别人用k的高手,都不用4。你们倒是随意得好。
● 鸣学
sam1860
帖子: 312
注册时间: 2006-10-28 11:05
送出感谢: 0
接收感谢: 0

#12

帖子 sam1860 » 2008-01-08 10:36

再过几天直接上final release版
google drive client for linux 下载
---------------------------------------------------------------
项目|9918视频秀
CentOS, Nginx, Java, C++, Go, MySQL, Redis
头像
zhongsanakang
帖子: 156
注册时间: 2008-01-02 23:08
送出感谢: 0
接收感谢: 0

#13

帖子 zhongsanakang » 2008-03-06 23:41

老农民 写了:下列的软件包有不能满足的依赖关系:
kdebase-runtime: 依赖: kdebase-runtime-bin (>= 4:3.97.0-1ubuntu4) 但是它将不会被安装
kdebase-workspace: 依赖: kdebase-workspace-bin (>= 4:3.97.0-1ubuntu7) 但是它将不会被安装
依赖: klipper-kde4 (>= 4:3.97.0-1ubuntu7) 但是它将不会被安装
依赖: ksysguard-kde4 (>= 4:3.97.0-1ubuntu7) 但是它将不会被安装
依赖: kwin-kde4 (>= 4:3.97.0-1ubuntu7) 但是它将不会被安装
依赖: systemsettings-kde4 (>= 4:3.97.0-1ubuntu7) 但是它将不会被安装
E: 无法安装的软件包
先安装kdelibs5库(正如7楼所说,一定要先添加PPA源)

代码: 全选

sudo apt-get install kdelibs5
然后

代码: 全选

sudo apt-get install -f
sudo apt-get autoremove
再用2楼的方法安装便OK了。 :D
头像
robust
帖子: 293
注册时间: 2006-07-04 21:56
送出感谢: 1 次
接收感谢: 0

#14

帖子 robust » 2008-03-07 11:48

直接安装kubuntu-kde4-desktop就可以了。
bingk
帖子: 68
注册时间: 2007-05-13 23:22
送出感谢: 0
接收感谢: 0

#15

帖子 bingk » 2008-03-07 12:11

我好像是直接用TW的官方源安装的
sudo apt-get install kde4-core
回复

回到 “老旧版本支持”