检查更新时报错:'E:错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持

软件源讨论区
回复
头像
kuishuangye
帖子: 8
注册时间: 2008-07-10 14:40
送出感谢: 0
接收感谢: 0
联系:

检查更新时报错:'E:错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持

#1

帖子 kuishuangye » 2008-12-06 23:29

就是打开更新管理器显示的错误

无法计算更新

在计算升级时遇到一个无法解决的问题。


请汇报这个有关 'update-manager' 的错误,并且将下列错误信息包含在错误报告中:
'E:错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。'

该怎么办啊,没办法更新了……帮帮忙啦~
zzx42
帖子: 5
注册时间: 2008-05-09 20:01
送出感谢: 0
接收感谢: 0

Re: 检查更新时报错:'E:错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持

#2

帖子 zzx42 » 2008-12-25 21:41

我的也再现这样的问题,本来我想手动安装JDK1.5的可是后来出现错后所有安装的东西都会出现这个错误了.
yuanyangliu
帖子: 118
注册时间: 2009-02-05 16:49
送出感谢: 0
接收感谢: 0

Re: 检查更新时报错:'E:错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持

#3

帖子 yuanyangliu » 2009-02-06 2:16

same to me ,but I don't know how to solve this problem ~~
http://www.luabbs.com 月光论坛欢迎你
http://game.luabbs.com月光游戏专区
linuxeden
帖子: 1
注册时间: 2007-11-24 12:40
送出感谢: 0
接收感谢: 0

Re: 检查更新时报错:'E:错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持

#4

帖子 linuxeden » 2009-02-28 20:16

要求解决,高手来阿!!!!!!!!!
hot1232
帖子: 5
注册时间: 2009-03-08 8:47
送出感谢: 0
接收感谢: 0

解决办法

#5

帖子 hot1232 » 2009-04-24 19:27

sudo rm -f /var/lib/apt/lists/lock /*只是应为这个文件的存在,强制删除后,重启APT就好了,反正我的就这样弄好了
回复

回到 “新立得和软件源”