建议将最新的zhcon放入,支持utf-8了

软件源讨论区
回复
zhuomingliang
帖子: 24
注册时间: 2005-11-04 11:14
送出感谢: 0
接收感谢: 0

建议将最新的zhcon放入,支持utf-8了

#1

帖子 zhuomingliang » 2006-06-23 15:48

我编译不来

zhcon.cpp; \
then mv -f ".deps/zhcon.Tpo" ".deps/zhcon.Po"; else rm -f ".deps/zhcon.Tpo"; exit 1; fi
zhcon.cpp:62:18: error: term.h: 没有那个文件或目录
zhcon.cpp: In member function ‘void Zhcon::InitTty()’:
zhcon.cpp:444: 错误: ‘tgetent’ 在此作用域中尚未声明
zhcon.cpp:455: 错误: ‘tgetstr’ 在此作用域中尚未声明
make[3]: *** [zhcon.o] 错误 1
make[3]: Leaving directory `/home/liangke/soft/zhcon/zhcon-0.2.5/src'
make[2]: *** [all-recursive] 错误 1
make[2]: Leaving directory `/home/liangke/soft/zhcon/zhcon-0.2.5/src'
make[1]: *** [all-recursive] 错误 1
make[1]: Leaving directory `/home/liangke/soft/zhcon/zhcon-0.2.5'
make: *** [all] 错误 2
laxsong
帖子: 7
注册时间: 2006-04-15 17:34
送出感谢: 0
接收感谢: 0

#2

帖子 laxsong » 2006-08-27 22:23

我也遇到了这个问题,源码是从sourcefoge上下的。
试了几个,都有这个错误。
jameswang
帖子: 34
注册时间: 2005-09-02 13:44
送出感谢: 0
接收感谢: 0

#3

帖子 jameswang » 2006-08-30 16:14

在你的源里添加deb-src的项,然后apt-get build-dep zhcon。

就可以编译了,apt-get build-dep能够解决编译某软件的依赖问题。
头像
liunix
帖子: 53
注册时间: 2006-06-10 17:33
送出感谢: 0
接收感谢: 0

#4

帖子 liunix » 2006-08-31 8:13

apt-get build_essential
apt-get build-dep zhcon
zhrb
帖子: 53
注册时间: 2005-09-05 17:04
送出感谢: 0
接收感谢: 0

#5

帖子 zhrb » 2006-09-12 22:45

zhcon出来了,可是速度巨慢,请问怎么回事呢?
erinux
帖子: 19
注册时间: 2006-04-13 9:44
送出感谢: 0
接收感谢: 0

#6

帖子 erinux » 2006-09-25 18:03

我的编译okay,但是utf8的支持惨不忍睹,win分区的文件名支离破碎。
how to ???
回复

回到 “新立得和软件源”