当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装build-essential的问题
帖子发表于 : 2009-03-03 0:55 
头像

注册: 2009-02-27 2:11
帖子: 87
送出感谢: 0 次
接收感谢: 0 次
falcon@falcon-Dream:/dev$ sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: g++ (>= 4:4.3.1) 但是它将不会被安装
E: 无法安装的软件包

如上所示我安装这个包失败了,8.10不是稳定版本吗?怎么回事?大家给我看看


_________________
——菜鸟之心,黑客之路

CPU:AMD sempron 2800 (Single Core)
内存:Corsair 512M DDR2 675
主板:ONDA n61v
显卡:Geforce 6100 400集成显卡
硬盘:Westdata 80G
系统:Centos 5.3+windows 2003


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 安装build-essential的问题
帖子发表于 : 2009-03-03 4:19 
头像

注册: 2007-10-23 12:54
帖子: 1689
送出感谢: 0 次
接收感谢: 13
用 aptitude 替代 apt-get ,前者可以自动处理依赖异常并给出解决方案。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译