当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [求助]升级过新,导致依赖关系破坏,该怎么做?
帖子发表于 : 2009-04-12 11:37 

注册: 2009-03-20 10:10
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
apt-get install -f 出现下列提示:

正在更正依赖关系... 失败。
下列的软件包有不能满足的依赖关系:
libperl5.10: 依赖: perl-base (= 5.10.0-11.1ubuntu2) 但是 5.10.0-19 已经安装了
perl: 依赖: perl-base (= 5.10.0-11.1ubuntu2) 但是 5.10.0-19 已经安装了
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。
E: 无法更正依赖关系

之前perl-base是手动升级的,过新了……

之前用的是学校的更新源,软件更新基本瘫痪,有错误
现在只保留官方更新,稍微好一点,但上面两个perl和libperl还是损坏状态

搜过类似的问题,都没有人回答
现在发帖求助,有人知道该怎么办么?

在系统安装区发过这个帖子,后来才知道发错区了,有回复说更换一个比较全而新的软件源,哪个源新呢?

谢谢!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: [求助]升级过新,导致依赖关系破坏,该怎么做?
帖子发表于 : 2009-04-12 11:40 

注册: 2009-03-20 10:10
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
我还搜到downgrade的方法
目前主要的原因是perl base 的版本过新,上面的那两个损坏的都是依赖他
所以是否可以采用降级的方法

该怎么降级呢?


页首
 用户资料  
 
3 楼 
 文章标题 : Re: [求助]升级过新,导致依赖关系破坏,该怎么做?
帖子发表于 : 2009-04-12 16:27 

注册: 2009-03-20 10:10
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
ok
i got it

选中perlbase,选择强制版本,downgrade到以前的版本即可


3Q all the same


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译