apt安装qterm缺少依赖关系如何解决

软件源讨论区
回复
lymslive
帖子: 72
注册时间: 2010-09-02 19:47
送出感谢: 0
接收感谢: 0

apt安装qterm缺少依赖关系如何解决

#1

帖子 lymslive » 2010-09-16 11:43

我的Ubuntu9.10
想装qterm,上网查了下安装方法,但是缺少依赖关系没安装成功,请问是不是该添加什么源啊?
错误信息如下,求教。

@~$sudo apt-get install qterm
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
qterm: 依赖: libqt4-dbus (>= 4.5.1) 但是它将不会被安装
依赖: libqt4-network (>= 4.5.1) 但是它将不会被安装
依赖: libqt4-script (>= 4.5.1) 但是它将不会被安装
E: 无法安装的软件包
头像
pocoyo
论坛版主
帖子: 25878
注册时间: 2008-03-25 15:49
来自: 谁知道?
送出感谢: 5 次
接收感谢: 9 次
联系:

Re: apt安装qterm缺少依赖关系如何解决

#2

帖子 pocoyo » 2010-09-16 11:51

有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
源没写全 ? 换换源 再install 下面那3个
头像
kumox
帖子: 2114
注册时间: 2008-04-14 23:29
来自: 曾也在NB大学呆过
送出感谢: 3 次
接收感谢: 10 次
联系:

Re: apt安装qterm缺少依赖关系如何解决

#3

帖子 kumox » 2010-09-16 11:53

不需要代理的话用pcmanx吧

代码: 全选

sudo apt-get install pcmanx-gtk2
lymslive
帖子: 72
注册时间: 2010-09-02 19:47
送出感谢: 0
接收感谢: 0

Re: apt安装qterm缺少依赖关系如何解决

#4

帖子 lymslive » 2010-09-20 0:07

我就是不知道哪个源有qterm啊

另外,pcmanx又是什么东东
sgt.pepper
帖子: 77
注册时间: 2006-11-22 9:21
送出感谢: 0
接收感谢: 0

Re: apt安装qterm缺少依赖关系如何解决

#5

帖子 sgt.pepper » 2010-09-24 21:47

这些包版本太低找不到了?我查一下新立得,libqt4-dbus已经是4.6.2了,这个包显示维护者是Kubuntu Developers,应该在官方发行版默认的源里面就有。
回复

回到 “新立得和软件源”