当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 无论安装或升级软件包均提示:Can't exec "/usr/local/sbin/charmap"该怎么办
帖子发表于 : 2010-09-29 16:15 

注册: 2009-01-08 18:53
帖子: 50
送出感谢: 1
接收感谢: 0 次
可能是我的系统某一软件包安装、卸载不全或依赖关系破坏,无论安装或升级软件包均提示
Can't exec "/usr/local/sbin/charmap": 没有该文件或目录 at /usr/share/perl5/Debconf/Encoding.pm line 16.
Use of uninitialized value $Debconf::Encoding::charmap in scalar chomp at /usr/share/perl5/Debconf/Encoding.pm line 17.
dpkg:警告:'ldconfig' not found in PATH or not executable.
dpkg: 1 expected program(s) not found in PATH or not executable.
NB: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin.
E: Sub-process /usr/bin/dpkg returned an error code (2)
软件包安装失败。正在试图恢复:
dpkg:警告:'ldconfig' not found in PATH or not executable.
dpkg: 1 expected program(s) not found in PATH or not executable.
NB: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin.

网上查了很多办法,试试均不成功,我也检查发现libc6包的配置不完整,哪位高手能指点一下吗? :em06


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译