软件依赖的问题,太崩溃了,帮帮忙啊

软件源讨论区
回复
头像
spazzzz
帖子: 14
注册时间: 2010-12-16 23:13
送出感谢: 0
接收感谢: 0
联系:

软件依赖的问题,太崩溃了,帮帮忙啊

#1

帖子 spazzzz » 2011-01-28 0:01

我想装个SSH,用apt-get提示要先装openssh-server
然后我用apt-get install openssh-server
又提示:

下列软件包有未满足的依赖关系:
openssh-server : 依赖: openssh-client (= 1:5.5p1-4ubuntu4) 但是 1:5.5p1-6 正要被安装


我再安装openssh-client,提示已经是最新版本了...

我想是不是先卸载了上面提示已经安装的openssh-client_1:5.5p1-6
但提示:
root@hdp0:~# sudo apt-get remove openssh-client
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 208 个软件包未被升级。

卸载不了...
请问高手们这如何解决啊
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 软件依赖的问题,太崩溃了,帮帮忙啊

#2

帖子 eexpress » 2011-01-28 11:28

通常是源不对。导致某些虚拟包找不到。
看下wiki。换cn的源
● 鸣学
头像
spazzzz
帖子: 14
注册时间: 2010-12-16 23:13
送出感谢: 0
接收感谢: 0
联系:

Re: 软件依赖的问题,太崩溃了,帮帮忙啊

#3

帖子 spazzzz » 2011-01-28 14:26

eexpress 写了:通常是源不对。导致某些虚拟包找不到。
看下wiki。换cn的源
和源有关啊?我从来没有更改过那玩意,怎么添加cn的源啊
fayen
帖子: 10
注册时间: 2011-03-08 9:26
送出感谢: 0
接收感谢: 0

Re: 软件依赖的问题,太崩溃了,帮帮忙啊

#4

帖子 fayen » 2011-03-09 8:56

脱机用ubuntu是一件很痛苦的事
回复

回到 “新立得和软件源”